Solved

E00.log was missing, and Mail store can't be mount.

Posted on 2004-10-15
9
7,695 Views
Last Modified: 2008-01-27
This morning, our Exchange Server 2000 (on Windows Server 2000 with up-to-date SP) stopped.
1. I went to ESM and try to mount the Mail Store, but got this error message

An internal processing error has occurred. Try restarting the Exchange System Manager or the Microsoft Exchange Information Store service, or both.
ID no: c1041724
Exchange System Manager

2. Later I found the E00.log was missing and here are some Event Logs:
EventID:9175
The MAPI call 'OpenMsgStore' failed with the following error:
The Microsoft Exchange Server computer is not available.  Either there are network problems or the Microsoft Exchange Server computer is down for maintenance.
The MAPI provider failed.
Microsoft Exchange Server Information Store
ID no: 8004011d-0526-00000000

EventID: 9518
Error Current log file missing starting Storage Group /DC=COM/DC=PROSPER-USA/CN=CONFIGURATION/CN=SERVICES/CN=MICROSOFT EXCHANGE/CN=FIRST ORGANIZATION/CN=ADMINISTRATIVE GROUPS/CN=FIRST ADMINISTRATIVE GROUP/CN=SERVERS/CN=SERVER/CN=INFORMATIONSTORE/CN=FIRST STORAGE GROUP on the Microsoft Exchange Information Store.
Storage Group - Initialization of Jet failed.

3. I tried to use eseutil tools, but got following errors:
C:\Program Files\Exchsrvr\BIN>eseutil /p

Microsoft(R) Exchange Server(TM) Database Utilities
Version 6.0
Copyright (C) Microsoft Corporation 1991-2000.  All Rights Reserved.

Usage Error: Missing source database specification.

Operation terminated with error -1003 (JET_errInvalidParameter, Invalid API para
meter) after 0.32 seconds.


C:\Program Files\Exchsrvr\BIN>eseutil /d "C:\Program Files\Exchsrvr\MDBDATA\priv1.edb"

Microsoft(R) Exchange Server(TM) Database Utilities
Version 6.0
Copyright (C) Microsoft Corporation 1991-2000.  All Rights Reserved.

Initiating DEFRAGMENTATION mode...
            Database: C:\Program Files\Exchsrvr\MDBDATA\priv1.edb
      Streaming File: C:\Program Files\Exchsrvr\MDBDATA\priv1.STM
      Temp. Database: TEMPDFRG5304.EDB
Temp. Streaming File: TEMPDFRG5304.STM


Operation terminated with error -544 (JET_errSoftRecoveryOnBackupDatabase, Soft
recovery is intended on a backup database. Restore should be used instead) after
 2.312 seconds.


4. Unfortunately, I restored last day backup, but here is not E00.log! After restore, I tried to use Eseutil /d , still same error message as above. I need fix this problem before tomorrow, but no idea what’s next step. Anybody could help?
0
Comment
Question by:taoyuxin
9 Comments
 
LVL 7

Accepted Solution

by:
vasanthgnb earned 250 total points
ID: 12324412
Hai,
  You have said that you restored last days backup. I believe you know the temporary location for the log files you have mentioned in the NTBackup software at the time of restore. Have you checked the "Last Backup set" checkbox. If not do the following:

1) Open command prompt. Goto MDBDATA directory.
2) type eseutil /cc "location for temporary log files"
3) Then type eseutil /d priv1.edb
4) try to mount the store.

If you have the corrupted database (the one before you restored), then delete or move all the log files, .chk file from the directory. Then run eseutil /p priv1.edb. thios should repair the database. do the same for pub1.edb. rub eseutil /d on both the databases. mount the stores and unmount them again. then run isinteg -s "server name" -fix -test alltests. it will ask for which store to repair. run it on both the stores. then mount the stores. remember to remove or move the log files and checkpoint files out of the directory.

Regards,
B.Vasanth.
0
 
LVL 27

Assisted Solution

by:Exchange_Admin
Exchange_Admin earned 150 total points
ID: 12324548
You better also figure out what happened to the missing log file. The most likely culprit is a file level anti-virus scanning the Exchange folders.
As you have found out, this is a major no no.
Be sure that you exclude the EXCHSRVR folders from being scanned and install an Exchange Aware anti-virus program.
0
 

Author Comment

by:taoyuxin
ID: 12324929
Thanks for all your response.

Hi yasan,
What is " the temporary location for the log files "?
I did check the "Last Backup Set" when I restored my Difference backup set.
BTW, I used the Windows default Backup Tools to backup "Micrsoft Information Store" and the folder of MDBDATA excluding edb and stm files. The store backuped at 10/14/2004 9:00PM and those Log files backuped on 10/15/2004 2:00AM. Does that cause a dismatch between DB and Log files?
Do you think that the Windows default Backup Tools can be used to backup Exchange? Or, in the future, I need change to another tools, like Veritas?

Hi Admin,
Actually, I knew the issue about anti-virus scanning exchange folders will cause problem, so I did exclude all those folders follow this document :" Preventing Symantec AntiVirus Corporate Edition from scanning the Microsoft Exchange directory structure ". And if the missing caused by this issue, I should be able to find out the E00.log in the Qurantin folder, right? But I didn't.

Any others can cause this missing as you knew?
0
 

Author Comment

by:taoyuxin
ID: 12325104
Hi yasan,
I see what is "the temporary location for the log files". I typed "c:\" when I restored the last backup set. Now I can see a folder named First Storage Group which includes some log files. Do you mean this folder? Let me try.
0
Can’t get the mobile email signature right?

Not having any luck when trying to create an email signature for mobile devices? Does the formatting keep messing up? Make sure you have great email signatures on all devices by using Exclaimer Cloud - Signatures for Office 365.

 

Author Comment

by:taoyuxin
ID: 12325124
I got a error here:
C:\Program Files\Exchsrvr\MDBDATA>"C:\Program Files\Exchsrvr\BIN\eseutil" /cc "c
:\First Storage Group"

Microsoft(R) Exchange Server(TM) Database Utilities
Version 6.0
Copyright (C) Microsoft Corporation 1991-2000.  All Rights Reserved.

Using restore environment
   Restore log file: c:\First Storage Group

Operation terminated with error -939586631 (Unknown Error, Unknown Error) after
0.109 seconds.

What's next?
0
 

Author Comment

by:taoyuxin
ID: 12325162
I tried use "C:\", same error.
0
 

Author Comment

by:taoyuxin
ID: 12325446
Oh, Admin is right. I found the E00.log in the Quarantine folder! I must did that excluding setting on all the other Exchange servers, but forgot this one! My god!

So, yasan, do you think I can restore the E00.log from Quarantine and the whole folder of EDBDATA from a backup I made today after Exchange crashed?

I tried it, but got a error when I run eseutil:
C:\Program Files\Exchsrvr\MDBDATA>"C:\Program Files\Exchsrvr\BIN\eseutil" /d pri
v1.edb

Microsoft(R) Exchange Server(TM) Database Utilities
Version 6.0
Copyright (C) Microsoft Corporation 1991-2000.  All Rights Reserved.

Initiating DEFRAGMENTATION mode...
            Database: priv1.edb
      Streaming File: priv1.STM
      Temp. Database: TEMPDFRG744.EDB
Temp. Streaming File: TEMPDFRG744.STM


Operation terminated with error -550 (JET_errDatabaseDirtyShutdown, Database was
 not shutdown cleanly. Recovery must first be run to properly complete database
operations for the previous shutdown.) after 10.735 seconds.

I will try to do some more research for the DirtyShutdown before I get help from you.
0
 
LVL 5

Assisted Solution

by:Maharajkp
Maharajkp earned 100 total points
ID: 12330642

If it was Quarantined ...
http://support.microsoft.com/?id=819553

0
 

Author Comment

by:taoyuxin
ID: 12334071
Thanks for you guys, I fixed this problem. I put all the steps as following for the pepole who has the same problem.

SYMPTOMS
This morning, our Exchange Server 2000 (on Windows Server 2000 with up-to-date SP) stopped.

When I tried to mount a mailbox or a public folder store, you may receive the following error message:
An internal processing error has occurred. Try restarting the Exchange System Manager or the Microsoft Exchange Information Store service, or both.

ID no: c1041724
Exchange System Manager

Later I found the E00.log was missing and here are some Event Logs:
EventID:9175
The MAPI call 'OpenMsgStore' failed with the following error:
The Microsoft Exchange Server computer is not available.  Either there are network problems or the Microsoft Exchange Server computer is down for maintenance.
The MAPI provider failed.
Microsoft Exchange Server Information Store
ID no: 8004011d-0526-00000000

EventID: 9518
Error Current log file missing starting Storage Group /DC=COM/DC=PROSPER-USA/CN=CONFIGURATION/CN=SERVICES/CN=MICROSOFT EXCHANGE/CN=FIRST ORGANIZATION/CN=ADMINISTRATIVE GROUPS/CN=FIRST ADMINISTRATIVE GROUP/CN=SERVERS/CN=SERVER/CN=INFORMATIONSTORE/CN=FIRST STORAGE GROUP on the Microsoft Exchange Information Store.
Storage Group - Initialization of Jet failed.


Caused by:
This issue may occur if the E00.log file is missing or is no longer present in the Exchsrvr\Mdbdata folder or in the log file folder. The log file may be missing or may not be present in the Exchsrvr\Mdbdata folder if a file-based virus scanner moves the log file to the Quarantine folder.

File-level antivirus scanners sometimes locate data in an Exchange 2000 log file that matches a known virus signature. In this case, the virus scanner may determine that the log file contains a virus and move it to the Quarantine folder.

Refer to:
<a id="'KB" href="http://support.microsoft.com/default.aspx?scid=KB;EN-">Recommendations for troubleshooting an Exchange Server computer with antivirus software installed</a>

<a href="http://support.microsoft.com/?id=819553">XADM: "An Internal Processing Error Has Occurred" Error Message When You Try to Mount a Database</a>

RESOLUTION
To resolve this issue, exclude the installable file system (IFS) drive (M drive) of the Exchange 2000 computer and other files that are related to Exchange 2000 files and folders from scheduled virus scans and real-time scanning operations.

<a href="http://service1.symantec.com/SUPPORT/ent-security.nsf/docid/2002090916040948">Preventing Symantec AntiVirus Corporate Edition 8.x from scanning the Microsoft Exchange directory structure </a>

Move the E00.log file from the Quarantine folder to the Exchsrvr\Mdbdata folder or log file folder, and then mount the database.

If you got error when you try to mount store in ESM(Exchange System Manager)
---------
The database files in this store are inconsistent.
ID no: c1041739
Exchange System Manager
----------
Do following steps:
C:\Program Files\Exchsrvr\MDBDATA>"C:\Program Files\Exchsrvr\BIN\eseutil" /p priv
1.edb
C:\Program Files\Exchsrvr\MDBDATA>"C:\Program Files\Exchsrvr\BIN\eseutil" /d priv
1.edb
C:\Program Files\Exchsrvr\MDBDATA>"C:\Program Files\Exchsrvr\BIN\eseutil" /p pub
1.edb
C:\Program Files\Exchsrvr\MDBDATA>"C:\Program Files\Exchsrvr\BIN\eseutil" /d pub
1.edb

Refer to:
<a href="http://www.experts-exchange.com/Networking/Email_Groupware/Exchange_Server/Q_20655145.html">Solution Title: Restoring Exchange 2000 database with no transaction log files and no backup</a>


Other Refers:
1. I have the other problem during the trouble shooting is Symantec System Center 5.0 running very slow and casue 90% CPU process, so I have to manully uninstall it and Symantec AntiVirus Corporate Edition 8.1 server, detail refer to:
<a href="http://service1.symantec.com/SUPPORT/ent-security.nsf/c9b1ac1936fbf63488256e77006521df/99abfdd5903c38c288256e6e007ae25b?OpenDocument&src=bar_sch_nam">Manually uninstalling Symantec AntiVirus Corporate Edition 9.0 server from Windows NT/2000/XP/2003 </a>

<a href="http://service1.symantec.com/SUPPORT/ent-security.nsf/d04e6f2f2dfad5de88256c910079502c/c2b1c1b565760a9188256caf005d856d?OpenDocument&src=bar_sch_nam">How to manually uninstall Symantec System Center 5.0</a>
2. here are some tips on www.experts-exchange.com were very help for me:
<a href="http://www.experts-exchange.com/Networking/Email_Groupware/Exchange_Server/Q_20943951.html">Mailbox Store Problem</a>

<a href="http://www.experts-exchange.com/Networking/Email_Groupware/Exchange_Server/Q_20723964.html">priv1.edb recovery</a>


Notes: After all steps, I can mount the exchange information store. But the problem is all the newer transaction logs after the E00.log was quarantined can not be included into the database remounted. That's mean I lost all emails in the trouble shooting period. Please note it...

Finally, I have to say thank you to  vasanthgnb, Exchange_Admin  and  Maharajkp.
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Local Continuous Replication is a cost effective and quick way of backing up Exchange server data. The following article describes the steps required to configure Local Continuous Replication. Also, the article tells you how to restore from a backup…
Read this checklist to learn more about the 15 things you should never include in an email signature.
In this video we show how to create a User Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Mailb…
In this video we show how to create an Accepted Domain in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Ac…

920 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

14 Experts available now in Live!

Get 1:1 Help Now