• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 247
  • Last Modified:

Home Network Setup -- Questionable Problems

I've set up a server network 9 clients and 2 servers. Asked a question here and got some help. Now what's confusing me is the simple task of two computers networked together is the issue. I've done this before, but everything I try will not work. Here is my configuration.
MACHINE 1 is connected to Router
MACHINE 2 is connected to Router.
the Router is connected to my cable modem.
I have no problems with internet connectivity, email, ftp, ect.
But I do have problems sharing network resources, i.e. shares on either hard-drive, and printers. Both machines have their own printers. 1 is for regular documents, the other has photo-inks.
I've got both machines in the same workgroup. Both machines have different computer names. The router assigns their IP thru DHCP, so their subnet masks are the same and all configurations on that end seem intact.
I've ran the xp network utility and nothing helps. Both machines are running windows xp home, both updated fully, SP2 and all patches.
What seems to be my problem?
0
iwalmsley
Asked:
iwalmsley
1 Solution
 
CaseybeaCommented:
My first recommendation would be for you to (temporarily) DISABLE XP SP2's firewall, and then see if your connectivity is improved between the machines.    The new firewall in XP is a royal problem for many common applications.

Start.... Control Panel...  Windows Firewall.... (TURN OFF).    

Since you're behind a NAT-enabled router, this is relatively safe to do for the short term.

If this works...   THEN the more appropriate answer is for you to go back in the firewall, and tweak "exceptions" (where you can allow other computers and subnets to access your shared resources).

But temporarily turning off the firewall is the quickest way to see if that's what is causing you grief.

--kcb

0
 
holger12345Commented:
If you have recently updated with SP2 you'll find that firewall activ like casey said - that is now the default mode. If you want to config your firewall exceptions right, just allow your local network to access the computer resources.
0
 
JohnnyCanuckCommented:
Turn off simple file sharing.  Open up My Computer, click tools, folder options, view and uncheck "Use simple file sharing (recommended)".  Click Apply then Apply to all folders.  Browse to your shared resource and right click on it and select Sharing and security.  Click Permissions and select who can access and what kinfd of access.  Click Apply.
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
BrucematCommented:
Have you got the same user anp passwords on both computers ie set up a user called john on both pc's and have the passwords set to password this way the machines trust eachother (well at least the user using them from accross the network)
0
 
JohnnyCanuckCommented:
Oops, I don't think you can do as I suggested with xp home.  Sorry.
0
 
iwalmsleyAuthor Commented:
I turned off Windows Firewall, it was already off because I use Symantec Norton Internet Suite 2004. It is on both machines.
Does my router (Linksys 4-port) have a firewall?
Is it a SNIS 2004 problem?
If it is, whats the solution?

brucemat:
i didn't quite understand your commnet. Do both machines have to have the same users? Because both machines have independent operators, we do not share desktops.. only resources. I don't even use the windows welcome screen, it reverts to classic option. Do I need to be using passwords when I login?

0
 
iwalmsleyAuthor Commented:
could anyone please help me with this question? I've got to missing something simple.
0
 
JohnnyCanuckCommented:
Try temporarily turning off the NIS firewall on BOTH machines.  Does that help?  If not, you will need to create a user on both machines that has the name of the other machine.  For example, machine1 is named xphome1 and machine2 is named xphome2.  On the xphome1 machine, create a user named xphome2.  Leave the password blank (its just easier that way).  Do the same on the machine named xphome2, except use xphome1 as the user name.  You may have to change the way users log on or off temporarily while you create the users, but once they are created you can change it back.  Pick a folder to share on one or both machines and see if you can access it from the other computer.
0
 
iwalmsleyAuthor Commented:
That did not work.
I added some more points, because this question has been in Open status awhile, and I am in still need of some assistance.
Any more suggestions?
0
 
JohnnyCanuckCommented:
Apparently when you use the network wizard, XP turns on its internal firewall.  This blocks file and printer sharing.

http://www.practicallynetworked.com/sharing/xp/filesharing.htm

Make sure ALL firewalls are off.
0

Featured Post

SMB Security Just Got a Layer Stronger

WatchGuard acquires Percipient Networks to extend protection to the DNS layer, further increasing the value of Total Security Suite.  Learn more about what this means for you and how you can improve your security with WatchGuard today!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now