?
Solved

bitstream-vera font no longer working after upgrade to XFree86 4.4 or Xorg

Posted on 2004-10-15
6
Medium Priority
?
409 Views
Last Modified: 2013-12-03
HI All,

A while back, I was running FreeBSD 5.0 and XFree86 4.3.  I found the bitstream-vera font set and loved it.  Then I upgraded to XFree86 4.4 and all of a sudden the font that I'd become accustomed to stopped working and I started to see this in my logs:

FreeType: couldn't find encoding 'ascii-0' for '/usr/X11R6/lib/X11/fonts/bitstream-vera/VeraMoBd.ttf'

Last week, I wiped my system and reinstalled 5.2.1 and Xorg xwindowing system.  Same damn thing in my logs!  

When I try xfontsel, I see the vera fonts listed, but, when I try to preview them, nothing happens and I get another line of the error metnioned above in my logs.  I've verified that the FreeType module is loaded in my X config file for the system and all the other fonts seem to work.  I've attempted to use ttmkfontdir several times to 'fix it' as other suggestions on the net seem to hint at.  All to no avail :(

Has anyone else had this problem and over come it?

TTFN!
0
Comment
Question by:dragonlord
  • 4
  • 2
6 Comments
 
LVL 62

Expert Comment

by:gheist
ID: 12347502
Somehow I use xfs for font serving (like most linuxes do) with 4.9, and never seen any font problem whatsoever. (5.2.1 is beta version just as 5.0 btw)
0
 
LVL 62

Expert Comment

by:gheist
ID: 12427394
There are two views of font configuration - one is X-servers view, another is Xft-s view, if they differ, the font lists desync
First needs to be put as all directories with fonts.dir files into X config or xfs config
Another recognizes subdirs and is updated with fc-cache -v
0
 
LVL 1

Author Comment

by:dragonlord
ID: 12450293
Yeah, 5.2.1 is beta but, it's working really well except for this crazy problem with the bitstream-vera font.  I've tried fc-cache -v and I've checked that the fonts dir is in the config file.  What a pain :)  When I was running xfree86 4.3 it worked really well and then the upgrade to either xfree86 4.4 or xorg and it fails.  Oh well, I'll get over it.  If you have any other ideas, that'd be great :)  Thanks again!
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 62

Accepted Solution

by:
gheist earned 2000 total points
ID: 12451262
cd /usr/X11R6/lib/X11/fonts/bitstream-vera
mkfontscale
mkfontdir

then fc-cache ,and rehash of X-server and/or xfs

???

simply something is really strange - I see all fonts including bitstream vera in all programs using xorg on 4.10, and I am quite sure that 5.2.1 does not break there anything
0
 
LVL 1

Author Comment

by:dragonlord
ID: 12487604
The mkfontscale in conjunction with the fc-cache -v must have done the trick :)  After I read you comment, I ran the commands from home and then the next day, all was well again with my bitstream-vera fonts!  Thanks so much!  I wonder how it got 'wonked up' in the first place.  Thanks!
0
 
LVL 62

Expert Comment

by:gheist
ID: 12491951
To mess things up even more - there is third list of fonts inside ghostscript.... part of universal wysiwg too ..... :-)
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Attention: This article will no longer be maintained. If you have any questions, please feel free to mail me. jgh@FreeBSD.org Please see http://www.freebsd.org/doc/en_US.ISO8859-1/articles/freebsd-update-server/ for the updated article. It is avail…
This tech tip describes how to install the Solaris Operating System from a tape backup that was created using the Solaris flash archive utility. I have used this procedure on the Solaris 8 and 9 OS, and it shoudl also work well on the Solaris 10 rel…
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…
Suggested Courses

850 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question