[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 12477
  • Last Modified:

Can't connect to X11 window server using 'localhost:0.0' as the value of the DISPLAY variable.

0-28-27AM. Please wait ...[oracle@NegusII Disk1]$ Oracle Universal Installer, Version 10.1.0.3.0 Production
Copyright (C) 1999, 2004, Oracle. All rights reserved.
 
Can't connect to X11 window server using 'localhost:0.0' as the value of the DISPLAY variable.
localhost:0.0
localhost:0.0
Unable to start an interactive install session because of the following error:Can't connect to X11 window server using 'localhost:0.0' as the value of the DISPLAY variable. The DISPLAY environment variable should be set to <hostname or IP address>:<screen>, where the <screen> is usually '0.0'.
Depending on the Unix Shell, you can use one of the following commands as examples to set the DISPLAY environment variable:
- For csh:                      % setenv DISPLAY 192.168.1.128:0.0
- For sh, ksh and bash:         $ DISPLAY=192.168.1.128:0.0; export DISPLAY
Use the following command to see what shell is being used:
        echo $SHELL
Use the following command to view the current DISPLAY environment variable setting:
        echo $DISPLAY
- Make sure that client users are authorized to connect to the X Server.
To enable client users to access the X Server, open an xterm, dtterm or xconsole as the user that started the session and type the following command:
% xhost +
To test that the DISPLAY environment variable is set correctly, run a X11 based program that comes with the native operating system such as 'xclock':
        % <full path to xclock... see below>
If you are not able to run xclock successfully, please refer to your PC-X Server or OS vendor for further assistance.
Typical path for 'xclock': '/usr/X11R6/bin/xclock'


The XCLOCK does not work either.  Nor does mozilla.  Netscape works.
0
xoxomos
Asked:
xoxomos
  • 2
1 Solution
 
CaseybeaCommented:
Silly question, but it's where to start:

Please check the content of /etc/hosts.   In it, should be an entry for "localhost".   It should look like this:

127.0.0.1        localhost      localhost.localdomain

(or similar).  "localhost" NEEDS to be there.

If the /etc/hosts file is missing or damaged, that would explaing things.

If this isn't the situation, pop back in- enter the contewnts of /etc/hosts.   I'll try to stay around to help resolve this.    I am travelling all day, but should be back LATE tonight.

Keep us posted- we'll fix this.  --kcb
0
 
xoxomosAuthor Commented:
Ok, I've got a localhost with an ip address, but no localhost with 127.0.1???
0
 
CaseybeaCommented:
"localhost" is almost always 127.0.0.1 (note- two zeros).     The "fqdn" (fully qualified domain name) - the "regular" host name is what is usually used for the external IP address.

0

Featured Post

The new generation of project management tools

With monday.com’s project management tool, you can see what everyone on your team is working in a single glance. Its intuitive dashboards are customizable, so you can create systems that work for you.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now