Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

cisco 837 configuration

Posted on 2004-10-16
6
Medium Priority
?
331 Views
Last Modified: 2008-01-09
Hi I have a cisco 837 adsl router. My internet connection is with Pipex and I have a dynamic IP. I have configured it in as far as all my hosts can comunicate with each other and the router through ping tests on my LAN. But I cannot connect to the internet! Please help! Ping tests to external IP addresses and external hostnames fail!!!

My configuration is below. My ISP uses PPPOA. Please tell me what I am doing wrong!!

Thanks

Barry




Current configuration : 1851 bytes
!
version 12.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname router
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$gD41$MH00DTDFF9oON4SZOmnz01
!
no aaa new-model
ip subnet-zero
!
!
!
!
ip ips po max-events 100
no ftp-server write-enable
!
!
!
!
!
!
!
interface Ethernet0
 description This configures the interface's ip, using NAT, and makes it an
 internal/private interface
 ip address 192.168.0.254 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 hold-queue 100 out
!
interface ATM0
 description dsl-op mode (auto) to detect line encoding used by ISP
 no ip address
 no atm ilmi-keepalive
 dsl operating-mode auto
!
interface ATM0.1 point-to-point
 pvc 0/38
 !
!
interface FastEthernet1
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet2
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet3
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet4
 no ip address
 duplex auto
 speed auto
!
interface Dialer0
 ip address negotiated
 ip mtu 1492
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 dialer pool 1
 ppp authentication chap callin
 ppp chap hostname xxxxxxxxxxxx
 ppp chap password xxxxxxxxx
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer0
!
no ip http server
no ip http secure-server
ip nat inside source list 1 interface Dialer0 overload
!
!
access-list 1 permit 0.0.0.0 255.255.255.0
access-list 1 permit 192.168.0.0 0.0.0.255
!
control-plane
!

!
scheduler max-task-time 5000



0
Comment
Question by:barryantwi
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
  • 2
6 Comments
 
LVL 43

Expert Comment

by:JFrederick29
ID: 12330602
Are you receiving an IP address from your ISP?  Do a "show ip int brief" and see if dialer0 has an IP from your ISP.

Can you ping external websites from the router?
0
 
LVL 8

Assisted Solution

by:MarkDozier
MarkDozier earned 2000 total points
ID: 12331441
I would turn on the http servere and using the web interface and configuration wizard setup the whole thing. a few siimple click and you will be amazed at what happens.
you are missing quite a bit of the needed information from your posted config.
If this is your full config then do run the wizard from the web interface.
Type the IP in the web browser. It should be either 192.168.0.1 or 10.10.10.1
Good luck
0
 

Author Comment

by:barryantwi
ID: 12336027
Hi Guys,

Thanks for your helpful comments. I tried using the web browser interface but I just keep on getting the message contacting router. And it doesn't progress any further. My entire config has been posted! If I am missing some commands could you possibly tell me what they are so I can configure it from the command line???

I will try the show ip int brief command. But anyone if anyone has a working example, I would appreciate it if they could post it up. Or any other useful comments would be appreciated

Cheers

Barry
0
Visualize your virtual and backup environments

Create well-organized and polished visualizations of your virtual and backup environments when planning VMware vSphere, Microsoft Hyper-V or Veeam deployments. It helps you to gain better visibility and valuable business insights.

 
LVL 8

Accepted Solution

by:
MarkDozier earned 2000 total points
ID: 12336495
If you have a pop blocker running it will stop the web interface from working correctlly.
0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 12337352
Add this to your configuration:

interface ATM0.1 point-to-point
encapsulation aal5mux ppp dialer
dialer pool-member 1
0
 

Author Comment

by:barryantwi
ID: 12352955
Sorry, bit of a mistake! The accepted answer was the one by from MarkDozier  Date: 10/17/2004 12:42AM PDT and the assisted was from MarkDozier Date: 10/17/2004 11:27PM PDT. Either way both answers resolved my problem!! Thankyou so much!! And thanks for KFrederick for his helpful comments!! You guys certainly know your stuff! Now I can concentrate on trying to become a CCNA :)
0

Featured Post

Simplify Your Workload with One Tool

How do you combat today’s intelligent hacker while managing multiple domains and platforms? By simplifying your workload with one tool. With Lunarpages hosting through Plesk Onyx, you can:

Automate SSL generation and installation with two clicks
Experience total server control

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this article, I am going to show you how to simulate a multi-site Lab environment on a single Hyper-V host. I use this method successfully in my own lab to simulate three fully routed global AD Sites on a Windows 10 Hyper-V host.
This program is used to assist in finding and resolving common problems with wireless connections.
There's a multitude of different network monitoring solutions out there, and you're probably wondering what makes NetCrunch so special. It's completely agentless, but does let you create an agent, if you desire. It offers powerful scalability …
Michael from AdRem Software explains how to view the most utilized and worst performing nodes in your network, by accessing the Top Charts view in NetCrunch network monitor (https://www.adremsoft.com/). Top Charts is a view in which you can set seve…
Suggested Courses

609 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question