Windows 2000 permissions not working?

I have a folder which I took off inheritable permissions and the NTFS acl shows

admins=FC
Everyone=Read
Managers=Read

Share permissions=everyone FC

If an admin creates a file the managers can still delete it.  I went to the advanced section and removed everyone and managers from the acl and left the upper level permissions as read only.  I can't for the life of me figure out how and why these groups can still add and delete files in this folder.  Again, no inheritable permissions are trickling down.

THanks in advance!


LVL 1
zenportafinoAsked:
Who is Participating?
 
KaliKoderConnect With a Mentor Commented:
Hello zenportafino,

Can you do the following :

- Right Click on your shared folder, go to properties, then select security. Now click on the advanced button and uncheck the "Allow inherrritable permissions" When asked if you want to replace or copy permissions, choose copy. Click Apply and click ok

- While still in the security tab, now put the permissions you want, ie; Admin = FC, Everyone = Read, Managers = Read. Hit Apply. Now click the advanced button one more time,  and on ther permissions tab you get, make sure you check the box that says "Replace permission entries on all chid objects" and click Apply, then click ok and ok one more time to get out of everything.

Now try it, and let us know your results

Thanks and Good Luck!
0
 
cooleditCommented:
hi, Zen

What's the permission on the top folder.
0
 
kobebeConnect With a Mentor Commented:
hi

the way I see it there are 2 options
either everyone/managers are part of the local administrators group or you have a salat in the permisions in the active directory, somehow giving everyone group an "administrators" permisions
look closely into you're drector service
0
 
_anom_Commented:
Also check where you have the permissions applying to--Files only, Folder only, etc.

Cheers
0
 
zenportafinoAuthor Commented:
The users had "log on locally" rights to the server and that messed things up though I still don't understand how that would mess up the ntfs rights.  Anyway, thanks for the good tips and help.

0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.