Solved

When I try to view my pages locally in my browser it opens in http://localhost/TMPd81y55rpx0.htm

Posted on 2004-10-17
22
390 Views
Last Modified: 2010-04-25
I think the problem started when I was trying to connect to an SQL database on a remote server, through a PHP page. ANyway, I played around with some settings and deleted some stuff that perhaps I should not have deleted. Anyway as a result when I try to preview my pages in my browser, the page tries to opem up in http://localhost/TMPd81y55rpx0.htm and as a result displays the following message:

The page cannot be found
The page you are looking for might have been removed, had its name changed, or is temporarily unavailable.

Also, I see that I now have MMDebugjs and MMdebugIEjs MMIEApplet.cab(zipped) in my local site directory. I don't know how these got here.

I am very much a hobby web-designer, so don't really know what it going on. Hope you can help.

Thanks
 
0
Comment
Question by:ayounis
  • 12
  • 9
22 Comments
 
LVL 1

Expert Comment

by:chief77
Comment Utility
you might want to turn off the "view page using temporary file" check box in Dreamweaver MX 2004's preview category.

turn it off by going to Edit > Preferences > Preview in Browser > in the lower section, where it says "Preview using temporary file", untick the check box.

if the page can't be found, make sure you have your "remote site" and "testing server" set up correctly. These can be found in Manage Sites (Advanced tab). Do be watchful for the testing server category's lower section, where it asked about the URL Prefix...


As for the other files, i think it's used by Dreamweaver to debug.
0
 

Author Comment

by:ayounis
Comment Utility
Ok, I unchecked the 'Preview in Browser' box and it seeemed to really slow down preview viewings; and after a wait, where a 'Waiting for server' status dialogue box was displayed, an error message finally appeared saying 'unable to create page'. It tried again automatically but failed again and finally brought up the same message:

The page cannot be found
The page you are looking for might have been removed, had its name changed, or is temporarily unavailable.

in http://localhost/TMPd81y55rpx0.htm

I think, as you suggest, my remote site and testiing server may be set up incorrectly. These problems generally happened around the time I fiddled with these settings(as I was trying to create a dynamic page).

THE TESTING SERVER DETAILS ARE:

Server Model: PHP My SQL

Testing server folder:
C:\Documents and Settings\Adam\My Documents\Websites\orangemonkeyserver files\

Access:  Local/Network

URL Prefix:  http://localhost/

MT REMOTE SERVER DETAILS ARE:

Access: FTP host

FTP Host: ftp.orangutanenglish.com

Host Directory: public_html/

Login """" (These are the logon and password details I use to access my webspace on my hosting company's server)

Password """"
None of the firewall boxes have been selected.

When I click 'test' it returns a 'successful' dialogue box.

Thanks for your help so far. I hope I can get things working again.

Adam




0
 
LVL 2

Expert Comment

by:udayms
Comment Utility
Hey.... Try deleting all the files from the cache and clearing the history. This might work. I dont think there's anything wrong with your Site settings. Also, chief77's answer should have solved your problem. So, just try clearing all the cached files and restarting the web server.

Regards,
Uday
0
 

Author Comment

by:ayounis
Comment Utility
Hi Uday,

I cleared the temp files and deleted the history at Tools/internet options area on my browser.Didn't have any affect(Is this area you mean, or somewhere else?) -I was still redirected to http://localhost/TMPd81y55rpx0.htm

I have other websites on the same computer that have no connection with a remote server, and they work fine when I press f12 or altf12.

thanks for your help

adam
0
 
LVL 1

Expert Comment

by:chief77
Comment Utility
Untick the Preview using Temporary File. you are still viewing the temporary file as indicated by "http://localhost/TMPd81y55rpx0.htm" <-- the "TMP~~~" is temporary file. very bad when testing with dynamic site.
0
 

Author Comment

by:ayounis
Comment Utility
I've done this and went on a short deleting frenzy, deleting all my dynamic pages, and pages I had created recently (not much work). Still no difference.

Now, this problem may have occurred when I was trying to solve another problem of dreamweaver not finding my MySQL database on a dynamic page I was attempting to create. I followed these instructions provided by my Hosting company's support:

1 Download the scripts.zip file (http://www.macromedia.com/support/dreamweaver/ts/documents/err405/scripts.zip), which contains a replacement Scripts folder.

2 Close Dreamweaver MX.

3 Rename the Scripts folder, located in the following directory, to Scripts_bak. (Install location)\Dreamweaver MX\Configuration\Connections\
Note: The default install location is C:\Program Files\Macromedia\;

4 Extract the contents of the downloaded Scripts zip file to the same directory.(Install location)\Dreamweaver MX\Configuration\Connections\

Note: The zip file contains a new Scripts directory and its contents;

5 Delete the _mmServerScripts folder from the site root on the testing server. This must be done for each site experiencing the problem. ; If you connect to the testing server via FTP, use a different FTP client to delete the folder. The _mmServerScripts folder is hidden in Dreamweaver's Site panel.
If you connect to the testing server over the network, use Windows Explorer to delete the _mmServerScripts folder.

OKAY HERE I  MADE A MISTAKE. I COULDN'T FIND  'the _mmServerScripts folder from the site root on the testing server', but found it locally and deleted it there. I have since restored it from the recycle bin, however.

Could this be a reason? Am I missing scripts somewhere? I truly have no idea. I will see if I can find the said temp file somewhere on my system....

Thanks for your help.

Adam

0
 

Author Comment

by:ayounis
Comment Utility
Okay, I went to dreamweaver EDIT Site option and turned REMOTE INFO Access to none,  and at TESTING SERVER turned server model to none and  access to none. I can now preview properly again.

However, I will attempt to create a dynamic page again, and will see if the problem repeats itself.

Thanks for the help everyone

Adam
0
 
LVL 1

Expert Comment

by:chief77
Comment Utility
ok. so far you are viewing just the static html file is it? (did you view it without using temporary file?)
0
 

Author Comment

by:ayounis
Comment Utility
It now previews from the local location of:

C:\Documents and Settings\Adam\My Documents\Websites\orange monkey\monkeyfiles\TMPdv0f65su8d.htm

So , going on what you said earlier, I am still viewing it with the temp file I think....
0
 
LVL 1

Expert Comment

by:chief77
Comment Utility
yup. very likely. unless that file is saved as "TMP~~.htm" which i doubt it is saved as that filename.
0
 

Author Comment

by:ayounis
Comment Utility
No it's not, you're right...problem...?
0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 

Author Comment

by:ayounis
Comment Utility
Anyway, I will return to trying to recreate that Dynamic page. Thanks for your help chief77.

Adam
0
 
LVL 1

Expert Comment

by:chief77
Comment Utility
you're welcome adam.

so what dynamic page are you working on? just take note of the testing server location and especially the URL prefix.

all the best.

Kel
0
 

Author Comment

by:ayounis
Comment Utility
Okay, now that I have changed the Remote Info and Testing Server settings, it doesn't preview again.

However, the error message is different. This time it is the standard 'Page not found' message.

The access method I chose in both these cases was FTP, and when I tested, Dreamweaver said it could connect to my webserver. At the moment the URL prefix remains 'http://'
I'm not sure what my root folder would be? I appear to have 6 at the root from looking at the FTP software I use. I specified public_html/ as my host directory in dreamweaver. Not really sure what I should put here? Public_html?

For the server model I selected MySQL/PHP, as this is what my host has on its server.

All I am trying to do at this stage is to connect to my MySQL database stored on my server. When I tried this previously (before I discovered the previewing problem) I couldn't connect.

Regards,

Adam
0
 
LVL 1

Accepted Solution

by:
chief77 earned 500 total points
Comment Utility
where is your webserver? how do you connect to your webserver? is it on another server? is there a domain name for this site? is it intranet webserver?

the URL prefix here is associating with domain name for the site.

so for example, if your ftp to your remote server is at ftp://ftp.mydomain.com then your www server (URL Prefix) most probably be http://www.mydomain.com


HOWEVER, if this is an intranet webserver, then you ftp to say ftp://10.0.0.1 (example IP address of the intranet server), the URL prefix should be http://10.0.0.1 or http://(server_name).


Try Dreamweaver help, or use the "Basic" wizard to configure the site. it is a bit confusing but you do need to know what/how you connect to your remote site, and whether this site has domain name (viewable from internet) or it is an intranet server (viewable internally).

Hope this help as much too.

Kel.
0
 

Author Comment

by:ayounis
Comment Utility

The site is on the internet. It's domain name is http://www.orangutanenglish.com

I live in Japan, but my hosting company is based in England. I connect to the server in England using a FTP software application called CuteFTP. My ftp to my remote server is at ftp.orangutanenglish.com

I had been merrily uploading files and previewing the temp files for some time now, but it is this change to a dynamic php page that is causing the viewing  problems.

Thanks,

Adam
0
 

Author Comment

by:ayounis
Comment Utility
So now it seems to connect to the server but it doesn't connect at the full correct path. This time the file that it tried to view was 'http://TMPha01p5synr.htm' but of course, that's not the files name.

0
 

Author Comment

by:ayounis
Comment Utility
Okay, It seems, as yo pointed out earlier, it was the URL prefix that wasn't working. I changed this to the http://orangutanenglish.com and now it opens correctly in the browser AND I can set the Testing servers settings.

Thanks for your help.
0
 
LVL 1

Expert Comment

by:chief77
Comment Utility
ok i see...

try use Dreamweaver MX's ftp to connect to the site. you can use CuteFTP too..


anyhow, i'll guide you through setting the site up.

Setup a site by going to Site menu then select Manage Sites (MX2004) or Edit Sites (MX2002)

Once in there, a wizard should pop up. Use the Advanced interface.

in the local info, give your site a friendly name that you can associate to easily identify.

the local root folder is the location of your files stored in the local machine.

leave the default images folder, and the http address blank.

next to remote info:
Access: FTP
ftp host: <ftp server address>
host directory if you know the path/directory
login & password.

testing server:
server model: PHP MySQL
access: ftp
ftp host: same as remote info's FTP
host directory, login, password: same as remote info's FTP

URL Prefix: this is where you type in your webserver address, http://www.orangutanenglish.com, AND if your site is appearing as a sub-folder when you uploaded to the FTP (e.g. htmldoc\sub-folder, then the prefix will be http://www.orangutanenglish.com/sub-folder)


Hope this will guide you a bit closer.


Once this is set up, you can use Dreamweaver to connect to your FTP site from inside Dreamweaver. use the "Connect" button, and expand the Remote/Local view to view two contents at the same time.
0
 
LVL 1

Expert Comment

by:chief77
Comment Utility
oh okay.... was a bit late in replyiing but am glad that you have found it. heheh

don't worry, this is very common mistake and can be quite confusing. My students always ask me for help... pretty annoying at time but well... they just never really learn. LOL.

Cheers.

Kel.
0
 

Author Comment

by:ayounis
Comment Utility
Oooops. Thanks anyway for that quality and lengthy response Kel.

Cheers.

Adam
0
 
LVL 1

Expert Comment

by:chief77
Comment Utility
you're very welcome... and thanks for the A. yay!!!! :-)

Kel.
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
Lock Form Controls 3 301
Debug PHP with Dreamweaver 6 600
Video Not Showing 8 90
Dreamweaver FTP Access 12 81
Adobe Dreamweaver CS5 is a WYSIWYG web page editor that has advanced HTML, CSS, and Javascript rendering functionality and is probably the most well-known HTML editor available. Much of Dreamweaver's appeal centers around the Design View interfac…
This article is very specific and is only intended to help if you are installing Dreamweaver 8 in a Windows 7 environment with Office 2007 installed.   I'm not sure why Microsoft tends to release OS' that should not be released but they do.  Windows…
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, Just open a new email message.  In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…
When you create an app prototype with Adobe XD, you can insert system screens -- sharing or Control Center, for example -- with just a few clicks. This video shows you how. You can take the full course on Experts Exchange at http://bit.ly/XDcourse.

772 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now