Solved

Half duplex on 2612

Posted on 2004-10-17
9
536 Views
Last Modified: 2010-05-18
I have a 2612 router (10mb e0). During the sh run, I noticed it is in half duplex.
"interface Ethernet 0/0
ip address 192.168.1.50  255.255.255.0
half-duplex

 When I ran it at full duplex I suffered performance issues.  What would be the cause of the performance issues after running it full duplex. My clients are set to "auto." Perhaps I needed to reload their NIC because it still thinks the router is running at half?

ps: I thought 10mb e0s could only run at half???

Thanks
0
Comment
Question by:dissolved
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
9 Comments
 
LVL 7

Accepted Solution

by:
NicBrey earned 150 total points
ID: 12335958
No, 10 mb/s can run full duplex.
Is the router interface connected to a switch?  Try hardcoding the switch port to 10/full. Auto does not work all that well. If it is connected to a hub, you can only run half duplex.
If you have a pc directly connected with a crossover cable, also try setting it to full on the PC.
0
 

Author Comment

by:dissolved
ID: 12337982
THe setup is like this

Router (routing between VLANs)
  |
  |             <----------------Trunk Link (int FA0/24)
  |
Switch  (3 VLANs)
  |
  |
  |
Users

So I should hardcode port 24 on the switch to full duplex as well?  I'm assuming full duplex will yield better performance? (slightly faster?)
0
 
LVL 79

Assisted Solution

by:lrmoore
lrmoore earned 175 total points
ID: 12338111
If you attempt to hard-code one end of any connection, then you must hardcode the other end device. You cannot hard code one and leave the other in autonegotiate. What happens is that when you manually set it, the autonegotiation is turned off. The default behavior of a (cisco) switchport is to default to half-duplex if no negotiation packet is received. So if you manually set the router interface to full duplex, the switchport now falls back to half-duplex and now you have a mismatch which causes error and severe performance issues.
 
0
Manage your data center from practically anywhere

The KN8164V features HD resolution of 1920 x 1200, FIPS 140-2 with level 1 security standards and virtual media transmissions at twice the speed. Built for reliability, the KN series provides local console and remote over IP access, ensuring 24/7 availability to all servers.

 

Author Comment

by:dissolved
ID: 12338664
So if I hardcode the router, I must hardcode the switch and the clients?  Or will the clients auto negotiate (windows clients with 3com nics)
Thanks
0
 
LVL 13

Assisted Solution

by:Dr-IP
Dr-IP earned 175 total points
ID: 12338826
When it comes to interconnecting Cisco gear via Ethernet, I have found the best practice is not to use auto negotiation. At best it’s hit and miss, sometimes it negotiates, sometimes it doesn’t, and when it does, it rarely negotiates the optimal setting. So I always manually configure the link speed, and duplex on both ends.

As for full duplex 10M, some equipment can do it, but a lot can’t do it. So keep an eye on the error counters for a while after configuring it to make sure it is working properly, as I have on more than a few occasions been able configure full duplex 10M on both ends, yet it don’t work properly, and I had to revert back to half duplex. Also watch out when trying to do full duplex 10M to an unmanaged switch, as most of them simply refuse to run at full duplex when operating at 10M.    
0
 

Author Comment

by:dissolved
ID: 12339250
Thanks! Got it working. Set the switchport and router e0 to both full duplex.
Should I set the clients to full, or let them auto negotiate?

Quick question though. I have a data drop from my switch (port 1) going to another room. This data drop feeds into a linksys hub. I have 4 pcs plugged into the hub. Is this going to effect whether or not these 4 pcs operate at full or half duplex or not? Or is this unrelated?
thanks!

0
 
LVL 79

Expert Comment

by:lrmoore
ID: 12339302
Unrelated. Hubs only work at half-duplex anyway. If they connect to the hub, they are stuck at half. If it's really a switch, then you should keep the PCs at auto.
0
 

Author Comment

by:dissolved
ID: 12342336
thanks everyone
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 12342362
Anytime!

0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have seen some questions on problems with SSH/telnet access to Cisco routers that may occur despite the fact that from a PC connected to your LAN, Internet connectivity is in place and users can access Internet sites without any issues.  There are…
Quality of Service (QoS) options are nearly endless when it comes to networks today. This article is merely one example of how it can be handled in a hub-n-spoke design using a 3-tier configuration.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Suggested Courses
Course of the Month8 days, 13 hours left to enroll

615 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question