Solved

NTBackup Gives Error When Backing Up Information Store

Posted on 2004-10-17
2
2,443 Views
Last Modified: 2010-05-18
My NTBackup routine backs up to a hard drive on another server. Everything in the backup routine works fine, except the backup of the Microsoft Information Store. I have tried with both the Storage Group unmounted and with it mounted, and it does not work either way. I get one of two errors. Last time I ran it with the information store mounted I got this error:

Backup Type: Copy
Backup started on 10/17/2004 at 4:45 PM.
The 'Microsoft Information Store' returned 'Backup is already active.
' from a call to 'HrESEBackupSetup()' additional data '-'The 'Microsoft Information Store' returned 'Functions called in an invalid sequence.
' from a call to 'HrESEBackupClose()' additional data '-'
The operation was ended.
Backup completed on 10/17/2004 at 4:45 PM.
Directories: 0
Files: 0
Bytes: 0
Time:  1 second

That was actually the first time I have seen that error though. This is the error that I normally get when I run NTBackup, and the one that I got the last time I ran a backup routine with the stores unmounted:

Error: PENGUIN\Microsoft Information Store\First Storage Group is not a valid drive, or you do not have access.
0
Comment
Question by:Grime121
2 Comments
 
LVL 10

Accepted Solution

by:
munichpostman earned 500 total points
ID: 12336215
You see these errors because NT Backup activates all Volume Shadow Copy service backup writers, including the backup writer used for Exchange Server 2003. By doing so, Exchange Server 2003 is in a "backup in progress" state even though Exchange Server 2003 is not selected as a component of the volume shadow copy backup. The Backup utility does not release Exchange Server 2003 from "backup in progress" state until the backup operation is completed.

The Backup utility does not use the Volume Shadow Copy service to back up the Exchange Server 2003 information store. The Backup utility uses the Exchange Server 2003 online backup streaming API to back up the Exchange Server 2003 information store. Because the Volume Shadow Copy service has already locked the Exchange Server 2003 information store for backup, the streaming API cannot bind to the databases hence the error message.

To resolve this issue backup the Operating system and Exchange in two separate jobs. So you can one for the system state and another for Exchange.

http://support.microsoft.com/kb/104169/EN-US/

http://support.microsoft.com/kb/327948/EN-US/
0
 
LVL 1

Author Comment

by:Grime121
ID: 12336245
Yep, that did it. I seperated the two backup jobs and disabled the Volume Shadow Copy on the Exchange backup routine. I don't know why I didn't think of that earlier.... Thanks a lot. :)
0

Featured Post

Are your AD admin tools letting you down?

Managing Active Directory can get complicated.  Often, the native tools for managing AD are just not up to the task.  The largest Active Directory installations in the world have relied on one tool to manage their day-to-day administration tasks: Hyena. Start your trial today.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article explains in simple steps how to renew expiring Exchange Server Internal Transport Certificate.
Find out what you should include to make the best professional email signature for your organization.
In this video we show how to create an Address List in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Organization >> Ad…
In this video we show how to create an email address policy in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Mail Flow…

828 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question