Solved

ASPX generated by VB not executed by IIS

Posted on 2004-10-18
3
184 Views
Last Modified: 2010-04-23
Hi,

I have the following installation on the same machine:
1) Visual Basic.NET 2002
2) Windows XP Professional - with both IIS and the .NET framework installed

I have the following problem:
1) I am trying to produce my first web form using VB.NET.
2) I have created a webform in the IDE and dragged onto it:
   i) a Label with the text "My First WebForm" with bold font settings; and
   ii) a Button with the text "Click Here"
3) I have set the background colour of the form to red
4) When I run the form in debug mode the Internet Explorer opens and:
   i) the Label text is shown unformatted; and
   ii) the button is not displayed.
5) When I look at the source in the browser the aspx tags are still there - as though they havent been recognised by IIS.

Attempts at resolution:
1) I have re-installed VB post install of IIS and the .NET framework but still have the same problem.
2) I have written an asp page that displays "Hello World " & Date and this seems to work fine i.e. IIS translates the Date into todays date and sends it back to the client as HTML.

Could you advise?

thanks,

David
0
Comment
Question by:drostron5
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
3 Comments
 
LVL 20

Assisted Solution

by:ihenry
ihenry earned 200 total points
ID: 12338727
This article might help

PRB: ASP.NET Pages Exhibit Unexpected Behavior Because the Server-Side Code Is Not Processed
http://support.microsoft.com/default.aspx?scid=kb;EN-US;325093
0
 
LVL 20

Accepted Solution

by:
ihenry earned 200 total points
ID: 12338732
0
 
LVL 9

Assisted Solution

by:hismightiness
hismightiness earned 300 total points
ID: 12338754
Is your ASPX ISAPI handler correctly mapped?

1 - In either your machine node, or the web node, right-click and choose Properties.
2 - Go to the ISAPI Filters tab.  If there is nothing there, or you do not see the ASP.NET filter name, then move up to the next node higher in the heirarchy.
3 - You should see one of the filters resembling: "ASP.NET_[version number]".  Left-click on it twice and make sure that if is mapped to the correct ISAPI filter.  It should be something like:

C:\WINNT\Microsoft.NET\Framework\[framework version number]\aspnet_filter.dll
0

Featured Post

Announcing the Most Valuable Experts of 2016

MVEs are more concerned with the satisfaction of those they help than with the considerable points they can earn. They are the types of people you feel privileged to call colleagues. Join us in honoring this amazing group of Experts.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

If you're writing a .NET application to connect to an Access .mdb database and use pre-existing queries that require parameters, you've come to the right place! Let's say the pre-existing query(qryCust) in Access takes a Date as a parameter and l…
Calculating holidays and working days is a function that is often needed yet it is not one found within the Framework. This article presents one approach to building a working-day calculator for use in .NET.

734 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question