Solved

PsExec and XP

Posted on 2004-10-18
6
3,018 Views
Last Modified: 2013-12-04
Hi, I can not get PsExec to work on XP. I have several other 2000 PCs and it works fine. I followed several of the suggestions I found here (turned off simple file sharing, shared folders etc...) I have two computers directly linked and am using a workgroup. I can see the folders and look at all files. I can not look at the c$ folder though and I can not add the user computer2\administrator to computer1. I get "Access is denied" when trying to run psexec. I have tried it with -u and without.
Thank you,
Pam
0
Comment
Question by:pamwestphal
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
6 Comments
 
LVL 23

Expert Comment

by:Tim Holman
ID: 12346479
Try psexec -u remotecomputername/username instead of just psexec -u username.
It sounds like your XP machine is not a member of the domain ?
0
 

Author Comment

by:pamwestphal
ID: 12349687
It didn't work. I am in a workgroup not domain environment. Have you heard of any issues using SP 2 on XP? One of the computers has SP2 on it, the other SP1.
0
 
LVL 23

Expert Comment

by:Tim Holman
ID: 12369099
If the XP firewall is enabled, then psexec would need to be allowed through....  follow the firewall logs, work out what's being blocked, then open the relevant ports.
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
LVL 3

Expert Comment

by:_anom_
ID: 12407543
The problem with this is probably that in the Security Options in the Local Security Policy the Network Access: Sharing and Security model for local accounts is set to guest only (windows default).  If set to guest only, even if you are connecting with the administrator username and password, it will still only have the privileges of the guest account (read: none).  Therefore, you need to change the Sharing and Security model to Classic - Local users authenticate as themselves.

Cheers
0
 
LVL 3

Expert Comment

by:_anom_
ID: 12407565
BTW, to get to the local security policy, go to start-->control panel-->administrative tools-->Local security policy, and then to the Security Options branch.

Cheers
0
 
LVL 4

Accepted Solution

by:
riotz earned 500 total points
ID: 12515119
"(turned off simple file sharing, shared folders etc...)"
hehe well psexec needs the admin$ share to be enabled..

when you disabled that one add it back!
0

Featured Post

Optimize your web performance

What's in the eBook?
- Full list of reasons for poor performance
- Ultimate measures to speed things up
- Primary web monitoring types
- KPIs you should be monitoring in order to increase your ROI

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Recently, I read that Microsoft has analysed statistics for their security intelligence report. It revealed: still, the clear majority of windows users do their daily work as administrator. An administrative account is a burden, security-wise. My ar…
Our Group Policy work started with Small Business Server in 2000. Microsoft gave us an excellent OU and GPO model in subsequent SBS editions that utilized WMI filters, OU linking, and VBS scripts. These are some of experiences plus our spending a lo…
If you’ve ever visited a web page and noticed a cool font that you really liked the look of, but couldn’t figure out which font it was so that you could use it for your own work, then this video is for you! In this Micro Tutorial, you'll learn yo…
Sometimes it takes a new vantage point, apart from our everyday security practices, to truly see our Active Directory (AD) vulnerabilities. We get used to implementing the same techniques and checking the same areas for a breach. This pattern can re…
Suggested Courses

615 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question