Solved

Bouncing Email

Posted on 2004-10-18
25
1,059 Views
Last Modified: 2008-02-01
I am receiving the following error message from bounced emails:

  There was a SMTP communication problem with the recipient's email server. Please contact your system administrator.
  <server.mydomain.local #5.5.0 smtp;550-EarthLink does not recognize your computer (xx.xx.xx.xx) as connecting from an EarthLink connection. If this is in error, please contact technical support.>

Is this because our email server is sending mail using our internal domain name instead of our external public domain name?  How would you change this?  This is on Exchange 2003 with Windows DNS.
0
Comment
Question by:hehewithbrackets
  • 9
  • 7
  • 4
  • +3
25 Comments
 
LVL 16

Expert Comment

by:Sohel Rana
ID: 12342838
0
 
LVL 5

Expert Comment

by:Hammadian2
ID: 12342934
maybe u just have a dynamic IP
0
 
LVL 3

Author Comment

by:hehewithbrackets
ID: 12343093
rsdn, although similar, the article you linked does not apply to me.  We are not getting a syntax error, nor do we use a Watchguard firewall.

Hammadian2, we do not have a dynamic IP.

It seems that the Earthlink server is rejecting our email because our IP does not match with our FQDN.  Assuming that is the case, how do I setup Exchange or DNS to send our header using our public FQDN of server.mydomain.com instead of server.mydomain.local?
0
 
LVL 5

Expert Comment

by:godd31
ID: 12343249
Hi hehwithBrackets,

You could try this: adding your ISP's DNS server addresses to your DNS suffixes. To do this open a command prompt, and IPCONFIG /all or if you have a router bring up the routers config page and find the DNS enteries. Enter those into your DNS suffixes field located under Network Places, Right click, properties then right click, properties of your network adaptor, TCP/IP, advanced, DNS tab, add in the DNS suffixes. This might help I am not couting on it. I think the best course of action would be to contact earthlink. They may have an issue with your account. in which case only they can help. Some ISP's now adays have tighter security in place and the mail servers run independant of the the logon servers so there maybe some sort of authentication issue here.

Let us know, good luck!!
0
 
LVL 5

Expert Comment

by:godd31
ID: 12343328
Sorry about that I misread your question. I was under the impression you had a home setup with Earthlink as your ISP. After rereading the question I did some seraching and found this MS article that may be of assistance.

http://support.microsoft.com/default.aspx?scid=kb;en-us;284204

THis one is definitly worth looking into if the above does not assist:
http://support.microsoft.com/default.aspx?scid=kb;en-us;300171

Another:
http://support.microsoft.com/default.aspx?scid=kb;en-us;317099

Sorry about replying without completely understanding your request. I hope these sites will be of assistance.
Let me know.
Thanks



0
 
LVL 3

Author Comment

by:hehewithbrackets
ID: 12343433
Ok, we are getting closer.  The 2nd article points out that if a reverse lookup of our FQDN fails, the message will bounce with the 5.5.0 NDR.  In my case, it would definitely fail a reverse lookup because our private FQDN is being added to the email header.

Back to my original question, how do I fix this so my server's public FQDN is attached to the headers rather than our private internal address?  Do I need the change something in Exchange or on our DNS server?
0
 
LVL 5

Expert Comment

by:godd31
ID: 12343783
Certain mail servers require specific additional Domain Name Service (DNS) records before allowing mail transfer. A Reverse Zone record needs to be created on the DNS server responsible for the source mail server's e-mail domain.

You may see the following errors in the SMTP log on your server.

"IO: |451 <name@domain.com>... Sender domain must resolve"

"IO: |421 SERVICE NOT AVAILABLE, TEMPORARY DNS FAILURE"
                              
Many organizations do not host their own DNS server(s). If your DNS is being hosted by another organization (i.e. ISP), please contact that organization to verify DNS configuration.

You can look up the reverse routing for your domain on the following link (first find out the IP address for the Exchange Server computer):
http://network-tools.com/
Type the IP address in the text box, and then click the DNS Records option. This gives the result for the reverse lookup.

Give this a shot and let me know.
Good luck
Thanks
0
 
LVL 3

Author Comment

by:hehewithbrackets
ID: 12344591
As I stated above, we host our own DNS records.
0
 
LVL 8

Expert Comment

by:Marakush
ID: 12348801
hehewithbrackets,

You need to setup a reverse lookup zone on your server.

http://support.microsoft.com/default.aspx?scid=kb;en-us;308201

This artice describes how to create a reverse lookup zone in a Win enviroment.

Marakush
0
 
LVL 8

Expert Comment

by:Marakush
ID: 12348823
---SIDE NOTE---

Here is a great site for testing DNS configurations, including reverse lookup zones.

http://www.dnsstuff.com/

Marakush
0
 
LVL 5

Expert Comment

by:godd31
ID: 12349815
Do you use a NAT device?

how about in the SMTP virtual server, configure external DNS servers to bypass the Windows DNS server (System Manager | Properties of virtual SMTP Server item | Delivery tab | Advanced button | Configure button).
The A record is returned when the MX record is unavailable. I don't believe this is correct but worth a shot.

also, On the DNS and Mail servers you can try this -ipconfig /flushdns- ipconfig /registerdns- restart net logon service

here is something I found:

To resolve the DNS resolution problems that are causing occasional MX record
failures.

Examples:

1. Internal DNS servers use forwarders to resolve external DNS queries and one of
the DNS servers in the list returns "server failure" when doing DNS queries.
Action: remove this DNS server from the forwarders tab.

2. The Exchange server has multiple default gateways set on a multi-homed server.
This is not a recommended configuration and can cause a number of unexpected
network problems. If the internal DNS server the internal NIC points to cannot
resolve external DNS queries, this problem can occur. Action: remove the default
gateway from one of the NICs.

Worth a shot.


0
 
LVL 3

Author Comment

by:hehewithbrackets
ID: 12350310
Marakush,

I think we are getting closer.  We do have a reverse lookup zone configured, but apparently it is not responding to queries.  

Interestingly, I'm seeing that luna.earthlink.net is an authoritative nameserver for our reverse lookup zone so it's not even getting to our DNS server for the reverse lookup query.  Obviously, we don't own the entire subnet, but is this normal?
0
Backup Your Microsoft Windows Server®

Backup all your Microsoft Windows Server – on-premises, in remote locations, in private and hybrid clouds. Your entire Windows Server will be backed up in one easy step with patented, block-level disk imaging. We achieve RTOs (recovery time objectives) as low as 15 seconds.

 
LVL 8

Accepted Solution

by:
Marakush earned 300 total points
ID: 12350778
hehewithbrackets,

Ahhh! Haaa! There is the answer.....

Your ISP needs to assign the block to you....

http://www.arin.net/

And use the Whois to lookup your address... Then contact the ISP and tell them what the issue you are having and how you need the block you are assigned in your name...

Cool...

Marakush
0
 
LVL 3

Author Comment

by:hehewithbrackets
ID: 12415778
Ok, I've contacted our ISP and they have added a reverse DNS PTR for our mail server, but emails are still bouncing with the same error message.  I think we've only fixed half the problem.  Going back to my original question, how do I make our mail server add server.mydomain.com to our email headers instead of server.mydomain.local?

Or does anyone have a better suggestion of what is causing the problem?
0
 
LVL 8

Expert Comment

by:Marakush
ID: 12416187
Okay well the block of IP addresses is still asigned to earthlink. You need to have them fork it over to you....

Explain the issue with the tech support for earthlink... and keep esclaiting it to a higher level, don't take its not our problem as the answer...

Marakush
0
 
LVL 3

Author Comment

by:hehewithbrackets
ID: 12416417
Why does it matter if they've added the correct PTR record?
0
 
LVL 5

Expert Comment

by:godd31
ID: 12416568
Solution Title: Sending/Receiving External Email (Relay) through Exchange 2003
asked by kjboughton on 11/12/2003 11:08AM CST  
This solution was worth  250 Points and received a grade of A  
 


Current setup:  Windows Server 2000 with Exchange 2003 Server Enterprise Edition (in the process of upgrading to Windows Server 2003 Enterprise Edition).  One subnet (192.168.0.x) of one local domain (bainet.local).  Only one Exchange server in the single domain.  The computer is shutdown every night to facilitate rebuilding a RAID array for backup. As a result we have an external email account which handles our email.

Employees connect to their external accounts using either Outlook 2000 or 2002 (planning on upgrading all to 2003).  Email is downloaded from boughtonarchitects.com and stored in their personal mailboxes on the server.  Everything worked fine when sending and receiving email (both external to the company through the internet email account) and when sending internal email with Exchange 5.5 but this is not the case now.


I'm not sure I understand SMTP connectors and virtual servers well enough to setup the appropriate relays.  Some external email seems to come in and go out for some clients but not for others.  When sending email out it comes back as a NDR since external SMTP clients cannot validate our internal domain (bainet.local).   How do I set this up?

Kristopher Boughton
Boughton Architects, Inc.

 
 Send to a Friend     Printer Friendly   See Solution  
   
 Comment from kjboughton
Date: 11/12/2003 11:34AM CST
 Author Comment  


Addition for clarification: external email is downloaded from a POP3 account provided by an ISP.  Need correct settings so that external email is sent and received through the POP3 account (boughtonarchitects.com) and all internal email is relayed to mailboxes in the domain (bainet.local).  Thanks.
 
Comment from Vahik
Date: 11/12/2003 05:07PM CST
 Comment  


The reason is that ur bainet.local is assigned as primary smtp address
to ur users.When u send mail out to internet exchange will use primary smtp address that u ahve assigned to each individual user(u can change primary smtp for each individual user).So to prevent that
create another policy called @Boughtonartichect.com and apply it to all ur users as primary.
Now i dont understand wht u mean some mail come in and go for some clients.Dont u use pop3 connectors?
 
Comment from Vahik
Date: 11/12/2003 09:54PM CST
 Comment  


Kj i just saw u made another post without even answering this one so i figure u did not like my name.So i will respect ur wishes and will not post there.Good luck.
 
Comment from kjboughton
Date: 11/12/2003 10:52PM CST
 Author Comment  


No, Vahik....please continue.  I posted the other question because after reviewing my original post I realized that it was not worded very well.

My next question has to be then: How do I change the primary email address without affecting internal email routing?  When I change the default SMTP email address to the "boughtonarchitects.com" domain I then have a problem routing internal email in "bainet.local" via Exchange 2003 Server.
 
Accepted Answer from Vahik
Date: 11/12/2003 11:50PM CST
Grade: A
 Accepted Answer  


U do not change anything.U add another recipient policy for ur
pop domain and addit to all ur users.When u are done u will see to
smtp addresses assigned to eaxh user.The one in bold letters are the primary one and that usually is the default one.Just click on the non
primary address and (which should correspond to ur pop account) and make it primary.Now there is a trick here that u have to remeber.
If for any reason ur internal users would like to comunicate with eachother under pop acounts then mail will not leave ur exchange.
For example A user name joe@localdomain.com would like to send email to mary@popdomain.com mail will not leave.Inorder for this also to work u have to go to ur recipient policy under pop account and uncheck this exchange server is responsible for mail delivery for this address.Now for ur internal emails anytime u send mail to each other names will be checked against ur GAL and pop doamin will not affect it.U can never send mail out under ur local domain if it is not registerd.
Inorder to recieve email all u do is to use ur default smtp server.
Just go to ur firewall and forward port 25 to the internal ip address of ur smtp server(u set it up in ur smtp properties page).Default smtp server works fine and does not need additonal setup(it even prevents relaying).
Now the big problem that u have is that mail for internet domain is being held by ur isp so ur smtp server will not recieve anything and only will be used for sending emails.That is a tricky setup and maybe i am reading it wrong.I am sure u guys are using pop connectors to download ur emails and if u need more help call back.
 
Comment from gunner-sutherlan
Date: 11/30/2003 09:34PM CST
 Comment  


I think this should be able to solve my problem to, but i am using a server which has SBS 2003 and exchange 6.5 installed on it.

I can't seem to find some of the menus.
 
Comment from clodur
Date: 06/15/2004 01:59PM CDT
 Comment  


I am using a SBS 2003 that is not sending emails to the internet.
We have looked high and low, even reinstalled the system a couple of times, we are still not able to send out emails.
We have a Linksys DI-624 with all the Virtual Server ports configuresd to face the Server's IP 192.168.0.1, the Router's internal IP is 192.168.0.2.
We are able to connect to the internet and receive emails just fine.
Please help us, we've been at it for 3 days/12 hours a day now.
 
Comment from Vahik
Date: 06/15/2004 03:41PM CDT
 Comment  


clodur what is ur problem now.i will be here for a while so do call back to see if i can help u.
 
Comment from GGadd
Date: 06/16/2004 03:26AM CDT
 Comment  


These posts have been a great help to me as I have been struggling myself with the SBS 2003 POP3 connector.

I have found that the only way I can get it to work is if I set my primary address to

@domain.local

I can receove and send emails fine using this setting, however the reply address is of course wrong.

I have tried adding my pop3 subdomain

@subdomain.nildram.co.uk

to the default policy, I tried making it the primary in there
I tried having it ticked and unticked
I tried adding @nildram.co.uk in there.
I tried creating a new mailbox policy and adding the same addresses to it.

Nothing works unless I have the primary address set to the @domain.local address.

It seems very much like it is something to do with the recipient policies but I cannot trak it down any further ??

any help would be greatly appreciated.
 
Comment from mike-conrad
Date: 06/17/2004 10:24AM CDT
 Comment  


The main points are to get the domain name into Recipient policy and make sure it is checked in the tick box, set it as the Primary.

In the User menu go to "E Mail Addresses" Tab and highlight the external domain and Set it as Primary, you must also uncheck the box for "Automatically update E mail addresses based on recipient policy" otherwise your users will be advertising a return address something like "fred@domain.local". You need to do that for every user.

Last restart the the IIS, easiest way is to use the "RUN" option on the START menu and type "iisreset"
 
Comment from GGadd
Date: 06/17/2004 10:57AM CDT
 Comment  


wow I don't know what part of what you said fixed it

but I removed all the extra receipient group I had created
and all the email addresses I had added to the users

then I added the external domain to the default recipient policy
I ticked it
I made it primary
when I applied I said yes to apply the changes to mailboxes

Then I opened the user ( where th e pop3 email is being delivered ) and unticked the option to automatically update email addresses based on recipient policy and restarted IIS and it works a treat ;)

thankyou very much I was pulling my hair out with this one ;)
 
Comment from robertkernan
Date: 08/21/2004 08:23AM CDT
 Comment  


i do service work for a company useing sbs 2003 that we had setup. we have some 25 users and all seem to recieve and send email just fine. my question is. we just recently added a new user to the company and there email was setup just like all the other users but the new user cannot recieve external email that is redirected from the server. origanl email account from isp provider goes through but the company external email does not. original emal is from pop3 which is @htctech.net and the exchange uses @illinienv.com. basically when i send email to name@htctech.net they recieve it but if i send name@illinienv.com it states no such user found. any help would be greatly appreciated.
 
Comment from robertkernan
Date: 08/21/2004 08:27AM CDT
 Comment  


i guess one thing i could try is to send an email from users machine and check the reply that should indecate a good email address.

 
Comment from hszuberi
Date: 09/11/2004 06:13AM CDT
 Comment  


Mail is not reaching recipients in some remote domains such as msn.com and hotmail.com.

This is what Event Viewer says:

Type:     Warning
EventID: 4006
Message deliver to the host '65.54.167.230' failed while delivering to the remote domain 'msn.com' for the following reason: The connection was dropped by the remote host.

What could be causing this?
 
I wasn't sure if you had a membership or not but perhaps this article I found on this site may help......
0
 
LVL 5

Expert Comment

by:godd31
ID: 12416674
http://www.awprofessional.com/articles/article.asp?p=170892&seqNum=3

I had to include this site again it may not be directly related but some information here may be helpful or lead in you the right direction.

thanks
0
 
LVL 3

Author Comment

by:hehewithbrackets
ID: 12416969
godd31, I read through the thread and although the problem is similar, it's not the same as my problem.  Is there a special reason why you posted the entire thread instead of a link?  It's really hard to read without the standard borders/colors.
0
 
LVL 3

Author Comment

by:hehewithbrackets
ID: 12416979
I skimmed through the link you posted and didn't see anything that really helps me or gives me any ideas.  Is there something specific you thought might help?
0
 
LVL 5

Assisted Solution

by:godd31
godd31 earned 200 total points
ID: 12417724
Yeah forgive my thinking, I wasn't sure if you were a paying member. I needed to login to view that post. So just wanted to make sure you could get the information. Sorry for the mess.

I was in a hurry trying to get out of work but just wanted to share what I found. On the link there were links to other resources and just some tips.

Do you use a Cisco router? The link I found within the site was:
http://support.microsoft.com/default.aspx?scid=kb;en-us;289553

But as I mentioned I was on the way out. so I didn't put the time into directing. I wanted to list the site as it could have had some other tips I may have missed through skimming it.

Try searching by error message here at these sites..
http://support.microsoft.com/ph/1773/en-us/?aid=3

http://www.microsoft.com/technet/prodtechnol/exchange/2003/default.mspx

0
 
LVL 3

Author Comment

by:hehewithbrackets
ID: 12606661
I gave credit to Marakush for a partial solution and godd31 for effort.  The problem is still outstanding.  My email server is still attaching an incorrect address on email headers and I do not know how to change it.
0
 

Expert Comment

by:iccadmin
ID: 13919698
My question is, how do I tell the email header to put mail.mycompany.com as the sending server instead of servername.mycompany.com.

All of the solutions are DNS related.  Don't you think it is a mild security risk to have the internal name of the server in the email headers?  

I believe I have the same question as hehewithbrackets.  How do I make it so that the headers that are written are mail.mycompany.com?  I don't want to put a DNS with cooresponding PTR record on my public DNS server resolving my internal server name.  This can't be that difficult, but I've been searching for hours trying to figure this out........  I am using Exchange 2003 Enterprise.
0
 

Expert Comment

by:iccadmin
ID: 13919933
Ok, sorry for the rehashing of the same question, but I have found a solution (with a point in the right direction from godd31 in the 10/19/04 post) that is working for me.

Open Exchange System Manager
Expand Administrative Groups
Expand First Administrative Group
Expand Servers
Expand [servername] (SMTP or Front End)
Expand Protocols
Expand SMTP
Right Click on Default SMTP Virtual Server
Click on Properties
Select the Delivery Tab
Click on the Advanced Button
Change the Fully-qualified domain name: field from servername.mycompany.com to mail.mycompany.com
0

Featured Post

Better Security Awareness With Threat Intelligence

See how one of the leading financial services organizations uses Recorded Future as part of a holistic threat intelligence program to promote security awareness and proactively and efficiently identify threats.

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
Free employee timeclock 7 51
FileType E9869 ? 6 43
Need to Edit a PDF 9 83
Free software that handles employee timesheet 1 14
I use more than 1 computer in my office for various reasons. Multiple keyboards and mice take up more than just extra space, they make working a little more complicated. Using one mouse and keyboard for all of my computers makes life easier. This co…
A list of useful business intelligence software.
The viewer will learn how to set up a document for the web and print and the recommended PPI for printing.
The viewer will learn common shortcuts with easy ways to remember them. The viewer will then learn where to find all of the keyboard shortcuts, how to create/change them, and how to speed up their workflow.

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now