• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 356
  • Last Modified:

Connecting to Internet using Redhat 9x with pppoe...

I need some extreme help with this one, not to sure where to start. My speedstream modem is connected to my Linksys router that provides ip addresses to my pc. My linux box has an ip address, i can ping vice-versa my xp can ping my redhat and the other way around. I got this rp-pppoe software installed wen through the procedure of installing it, i can start and stop my adsl connection, i get an ip address from my ISP and DNS but i can't browse the net at all. I am a newbie to this help is greatly appreciated.

4 Solutions
When your connection is up what does the output of "route" give you?
mrochacAuthor Commented:
how would i check that?

To check out your route, type:

route -n

Then post the results back to the list.
The new generation of project management tools

With monday.com’s project management tool, you can see what everyone on your team is working in a single glance. Its intuitive dashboards are customizable, so you can create systems that work for you.

Hi mrochac,

   Can your XP box browse the net? If not, then the issue may be on yur default gateway or DNS setting.
Use "c:\> route PRINT" to see the default gateway of your XP and "c:\> ipconfig /all" to see your DNS setting.

   If your PC have fix IP, then you need to change the default gateway to your Linksys router's IP in "control panel/network connections/Local Area Connection/Properties/Internet Protocol(TCP/IP)". And set the DNS to those assigned by your ISP.

   If your PC use DHCP to get the IP address, then the problem is on your Linksys router setting. On the DHCP setting of your
Linksys router, put the DNS addresses gotten from your ISP in the DHCP binding DNS. And make sure your XP can get the right DNS (ipconfig /all).

   For the RH Linux box, to show the default gateway is
# /bin/netstat -rn
  to set the route is
# /sbin/route add default gw <Linksys router's IP>

   If you can ping IP of www.yahoo.com ( and can not ping www.yahoo.com, then the problem is the DNS.
edit /etc/resolv.conf and put
nameserver   <DNS IP given from ISP>
   and put dns into the host line in /etc/nsswitch.conf.
hosts:  files dns


To test ur connectivity, first of all traceroute to any website like www.yahoo.com.

#traceroute www.yahoo.com
if u get ip address for www.yahoo.com then ur dns is working. If u dont get ip address then dns is a problem. So check ur /etc/resolv.conf

Next is find out where is the problem if u find that its going through some other route than it should u can correct it.

hope it helps


mrochacAuthor Commented:
not exacly the right answers but it help me alot
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now