• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 31084
  • Last Modified:

RPC server is unavailable

I have a newly installed 2003 SBS Proffessional with 2 NICs public/Private IP's assigned and a 2003 Enterprise member server with 2 NICs also running Terminal Services in application mode.  When I use a local user on the enterprise server to log on to terminal services it works fine.  When I use a domain user from active directory in the remote desktop group to log on to the terminal server I get "The system cannot log you on due to the following error: The RPC server is unavailable"  I also get an event ID 1219 winlogon.  I need to use the active directory users.
0
Edgardo Vazquez
Asked:
Edgardo Vazquez
  • 2
1 Solution
 
Sebo2000Commented:
Hi,
This problem occurs if the server is multihomed (a box in a DMZ also attached to a service network) and the NIC bound to terminal services is not the first adapter in the binding / provider order. Open Network connections and go to Advanced Settings. Examine the connections window on the Adapters and Bindings tab. Ensure that the NIC you have set RDP to answer on is the top NIC in the order.
This is also a permissions/access violation error. Check the permissions on the local drive of the Terminal Server. Drive “C” must have read/list/execute for Users.

And make sure if ISA is installed that RPC port 135 is open

Also check:
Terminal Services Client Cannot Obtain Terminal Services User Configuration from Domain Controller During Logon
http://support.microsoft.com/default.aspx?scid=kb;en-us;331627

Troubleshooting "RPC Server is Unavailable" in Windows
http://support.microsoft.com/default.aspx?scid=kb;en-us;224370

The Active Directory Migration Tool displays a "RPC server is unavailable" error message in Windows Small Business Server 2003
http://support.microsoft.com/default.aspx?scid=kb;en-us;837366


0
 
usrhlpCommented:
There seems to be information missing from this.

"Open Network connections and go to Advanced Settings. Examine the connections window on the Adapters and Bindings tab. Ensure that the NIC you have set RDP to answer on is the top NIC in the order."

You can't do that unless it is not applicable to Windows 2003 R2.
0
 
usrhlpCommented:
Typically enough, 5 seconds after posting the above i found where it was. This didn't fix the problem I have. Windows is so unreliable :(
0
 
behringerharvardCommented:
I wanted to thank you for this solution, I never would have though of the NIC binding order causing this problem on our server. Another symptom we were seeing is extremely slow response to in a VNC session, as if the CPU usage was pegged. Again, thanks.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Introducing Cloud Class® training courses

Tech changes fast. You can learn faster. That’s why we’re bringing professional training courses to Experts Exchange. With a subscription, you can access all the Cloud Class® courses to expand your education, prep for certifications, and get top-notch instructions.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now