OpenBSD lockout user after failed login attempts

Is it possible to configure OpenBSD to lock out a user after several failed login attempts?  If yes how.
howardsx5Asked:
Who is Participating?
 
ITG-SSNACommented:
Check the /etc/login.conf

login-backoff     number     3            After login-backoff unsuccess-
                                               ful login attempts during a
                                               single session, login(1) will
                                               start sleeping a bit in between
                                               attempts.


LOGIN.CONF(5)             OpenBSD Programmer's Manual            LOGIN.CONF(5)



NAME
     login.conf - login class capability database



SYNOPSIS
     /etc/login.conf



DESCRIPTION
     The login.conf file describes the various attributes of login classes.  A
     login class determines what styles of authentication are available as
     well as session resource limits and environment setup.  While designed
     primarily for the login(1) program, it is also used by other programs,
     e.g., ftpd(8), to determine what means of authentication are available.
     It is also used by programs, e.g., rshd(8), which need to set up a user
     environment.

     A special record, ``default'', in /etc/login.conf is used for any user
     without a valid login class in /etc/master.passwd.

     Sites with very large /etc/login.conf files may wish to create a database
     version of the file, /etc/login.conf.db, for improved performance.  Using
     a database version for small files does not result in a performance im-
     provement.  To build /etc/login.conf.db from /etc/login.conf the follow-
     ing command may be used:

           # cap_mkdb /etc/login.conf

     Note that cap_mkdb(1) must be run after each edit of /etc/login.conf to
     keep the database version in sync with the plain file.


0
 
paranoidcookieCommented:
Not so familiar with openBSD try asking in UNIX channel

There might be an option in one of

/etc/security/limits.conf

/etc/limits 
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.