Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 592
  • Last Modified:

Can't FTP into AS/400

I have started an FTP server on my AS/400 but I can't log in to it even with QSECOFR rights. The FTP server responds asking for a user name and password but won't take anyones regular sign on and password. Do FTP users need to be defined elsewhere in addition to wrkusrprf?

Thanks,

Paul
0
paul_lcs
Asked:
paul_lcs
3 Solutions
 
HelixirCommented:
First you are sure your FTP server is started up !!
STRTCPSVR  FTP

Second you might have an EXIT Program on an EXIT Point that doesn't allow you to log whatsoever your user.

WRKREGINF will show you all EXIT point. Now you got to see you have any EXIT Program associated with these EXIT Point.

These are the EXIT Point for FTP Login:
QIBM_QTMF_SVR_LOGON
QIBM_QTMF_SVR_LOGON
QIBM_QTMF_SVR_LOGON
QIBM_QTMF_SERVER_REQ
0
 
paul_lcsAuthor Commented:
Yes, I've started the server. I'm just trying to use Cute FTP on a PC to log in to it. I get the FTP welcome message and it asks for username/password but it always rejects it even though I can sign in with that user name and password on a 5250 screen, for example.
0
 
samic400Commented:
Can you open up a DOS session and FTP into the AS400 that way?

This would verify that it isn't the Cute FTP problem but a connection problem using FTP into the AS400.
0
NFR key for Veeam Agent for Linux

Veeam is happy to provide a free NFR license for one year.  It allows for the non‑production use and valid for five workstations and two servers. Veeam Agent for Linux is a simple backup tool for your Linux installations, both on‑premises and in the public cloud.

 
HelixirCommented:
Log on your ISeries and try

FTP LOOPBACK

Just to be sure it's not a problem with EBCDIC ASCII.
Or a problem with Cute FTP like Samic400 sais !!
0
 
theo kouwenhovenCommented:
Hi Paul_lcs

Check the configuration, it's possible that the default FTP port (21) is configured diferently.
0
 
Mind_nlCommented:
Allso in iSeries Navigator you can set permission for the FTP. Open up Navigator, right-click on your machine and select 'Application administration' goto 'Host Applications' / 'TCP/IP Utilities for iSeries' / 'FTP' / 'FTP client' / 'initiate session' click the 'customize' button and select the users to authorize. Under 'Specific operations' set acces for different FTP commands (send, recieve, change dir)

Hope this helps!
0
 
tliottaCommented:
If FTP is responding with prompts for user & password, then (1) it's obvious that the server is started and (2) the correct ports are being used.

FTP exit point programs, FTP LOOPBACK testing and OpsNav Application Administration are all excellent possibilities.

It would be helpful if actual error messages were included with the question though. A comment like "won't take anyones regular sign on and password" isn't helpful enough. Does it simply prompt over and over? Does it print any info before prompting?

Tom
0
 
theo kouwenhovenCommented:
Hi Paul,

Have you already looked in the historylog DSPLOG for messages?
or in the joblog of the FTP job WRKACTJOB while FTP is running?

Maybe the user you try to use has a default job defined in the userprofile?
if yes, remove this and try again.
or create a special userprofile with just a userid and password.

0
 
rpgpgmrAS400Commented:
Paul,
Try using the iSeries Navigator to check several of the aspects of your FTP server, including user rights.  Also, if you are looking for a good program to locally ftp to your AS400, try the following no-charge program which is specifically written to work the the AS400:

http://www.excelsystems.com/ftp123.htm
0

Featured Post

 [eBook] Windows Nano Server

Download this FREE eBook and learn all you need to get started with Windows Nano Server, including deployment options, remote management
and troubleshooting tips and tricks

Tackle projects and never again get stuck behind a technical roadblock.
Join Now