Solved

My router login page appears whenever I am trying to access my webserver's homepage

Posted on 2004-10-19
8
270 Views
Last Modified: 2008-03-10
I have a cisco soho 96 router on a static ADSL line. I have set up an apache webserver on a machine which I can access locally (127.0.0.1) but whenever I try to access it from the internet (www.mydomain.com) I come across the login page of my router. I have forwarded port 80 on my local machine which is on address 10.10.10.2. My webserver is set up to listen to port 80 on 10.10.10.2. My router configuration is the following:

interface Ethernet0
ip address 10.10.10.1 255.255.255.0
ip nat inside
no ip mroute-cache
!
ip nat inside source list 102 interface Dialer1 overload
ip nat inside source static tcp 10.10.10.2 80 interface Dialer 80
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
ip http server
no ip http secure-server
!
access-list 102 permit ip 10.10.10.0 0.0.0.255 any

Is there a way to avoid my router's login page whenever I access my webserver?
0
Comment
Question by:piperak
  • 3
  • 3
8 Comments
 
LVL 79

Expert Comment

by:lrmoore
ID: 12349324
Turn off the router's web service:
   
   no ip http server
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 12403518
Any progress? Are you still working on this? Do you need more information?
0
 

Author Comment

by:piperak
ID: 12404770
I tried that but i did not get my webserver's homepage. It just doen't show the login page anymore(nor any error page). It seems like all the traffic for port 80 goes to my router's address and stays there. No forwarding takes place. However traffic at other ports gets forwarded with no problem.(I am forwarding ports 4662 and 4672 for emule and it works fine). I got a second router from a friend (tomson-alcatel speedtouch 510i) and i get the same problem. I tried to change the address and the ports that apache is listening to and still have the same problem. Then i tried a usb isdn modem and everything works fine. So i know that the router is responsible for the problem and not apache but I am stuck.
0
Easy, flexible multimedia distribution & control

Coming soon!  Ideal for large-scale A/V applications, ATEN's VM3200 Modular Matrix Switch is an all-in-one solution that simplifies video wall integration. Easily customize display layouts to see what you want, how you want it in 4k.

 
LVL 79

Expert Comment

by:lrmoore
ID: 12404816
OK.. couple of suggestions:

router#clear ip nat trans *

ip nat inside source static tcp 10.10.10.2 80 interface Dialer 80
                                                                                   ^^ Should be Dialer1 80
!
access-list 102 deny tcp host 10.10.10.2 eq 80 any
access-list 102 permit ip 10.10.10.0 0.0.0.255 any
!

Also, make sure you are testing it from remote host...

0
 

Author Comment

by:piperak
ID: 12409822
Ok that did it, partly. I can access my webserver from the outside now but not from my own network. I need both because I am trying to use a web application, not just view a local webpage.So what I need is a way to force my router to allow me to view my  homepage when I use my website's address from my local network.
0
 

Author Comment

by:piperak
ID: 12512338
Well i found what was wrong with my network. When i got my domain name i asked my ISP to point my static ip to that domain name. They did it partly. When i do a forward lookup with did i get my domain name. But when i do a reverse lookup i get nothing. I asked them to complete the dns entry and my problems were solved.
0
 
LVL 1

Accepted Solution

by:
DarthMod earned 0 total points
ID: 16143801
PAQed with points (125) refunded

DarthMod
Community Support Moderator
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Not able to route between subnets 8 122
configure ASA Vlan Interface 14 70
Two IPV6 prefixes have same meaning under prefix-set in ASR9K? 2 30
EIGRP Bandwidth 9 18
While it is possible to put two routes in place with the secondary having a higher metric, this may not always work. In the event of a failure that does not bring down the physical interface on the router the primary route is not removed. There is a…
This article is a guide to configure bridging on Cisco Routers.  This is something I never knew was possible until after making a few phone calls to Cisco.  Using bridging saved our company money by not requiring us to purchase a new switch.  Bridgi…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

840 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question