Solved

Zero IP configuration after ipconfig / BSoD while accessing network shares

Posted on 2004-10-19
13
295 Views
Last Modified: 2013-11-13
Hello All,

May be another sign of broken network is new problems accessing ftp service, it suddenly after coonecting hangs on LISTing files / getting data and just passive mode solves it (before it worked w/o passive mode 100%).

I am quite sure first time I get this trouble after installation of CDMA modem driver but I already unninstalled it.

I uninstalled also all network adapters, restarted, manually cleared registry and installed it again from scratch, but this still occurs.
Sometimes ipconfig reply with "zero configuration" just promt c:\ is displayed, no adapter listed.

I tried install SP2 but this don't solved it (and using SP2 now).

I also tried to fix winsocks corruption by entering "netsh winsock reset" and reset IP stack by "netsh int ip reset" but this doesn't help. I used to switch network settings before using netsh -f (pushd interface ip) to home/work as alternate configuration doesn't work for me well - it didn't set gateway right.

I also tried to reinstall Computer Browser and Workstation services - no success.

I hope I have not forget to write anything important.

Ladislav
0
Comment
Question by:om7ar
  • 6
  • 6
13 Comments
 
LVL 65

Expert Comment

by:SheharyaarSaahil
ID: 12351545
Hello om7ar =)

>> Sometimes ipconfig reply with "zero configuration"

Do u mean that it replies with a 0.0.0.0 address  ??
If Yes then can u try the suggestions given here ??

When you use the Ipconfig command to renew the IP address of your Windows XP computer, your receive an error, or a 0.0.0.0 address?
http://www.jsiinc.com/SUBN/tip6900/rh6920.htm
0
 

Author Comment

by:om7ar
ID: 12374379
Thanks for your comment, unfortunately zero configuration probably doesn't express it right,  I mean clean configuration like this:

C:\>ipconfig /all

Windows IP Configuration


C:\>

I checked your link there are good hints but not for this case.

There are also these symptoms I recognize more:

- Sometimes computer crash after at the moment I try to browse network share (total commander, Alt+F1 and network driver letter) I get BSoD saying something like "IRQ not less or equall ... ". This I never get using it at home with no network drives in use.

- I have problems finding computers in network quite long time before (may be as I start using flash network settings through "nesth -f" command), I use FQDN names isntead of WINS names to find them.

Here it is the file I use to flash:
# ----------------------------------
# Interface IP Configuration        
# ----------------------------------
pushd interface ip

# Interface IP Configuration for "Local Area Connection"

set address name="Local Area Connection" source=static addr=10.5.135.86 mask=255.255.255.0
set address name="Local Area Connection" gateway=10.5.135.1 gwmetric=0
set dns name="Local Area Connection" source=static addr=81.27.192.33 register=PRIMARY
set wins name="Local Area Connection" source=static addr=none

popd
# End of interface IP configuration

Thanks for your time reading this.
0
 

Expert Comment

by:evasion
ID: 12385874
Until I read  your second post, I would have suggested that your network card is not installed correctly. You could try checking in Device Manager anyway. If not re-install the drivers.

If you don't run the file and type ipconfig /all, what happens?
0
 
LVL 65

Accepted Solution

by:
SheharyaarSaahil earned 500 total points
ID: 12386698
om7ar.... i was just wondering if u have already tried running this winsockfix tool for xp to reset the default winsock settings for ur system >> http://www.spychecker.com/program/winsockxpfix.html
0
 

Author Comment

by:om7ar
ID: 12387566
Hello SheharyaarSaahil,

no I didn't tried it before, I've just reset ip stack without changing registry. Now I tried tool you recommend and it seems it works better, ftp works without passive mode again at minimum. More I will try when I get to work and let know all of you.

WinSockXPtool does more these registry changes:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Winsock
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Winsock2

Thanks for this moment.

Ladislav
0
 
LVL 65

Expert Comment

by:SheharyaarSaahil
ID: 12388385
ok atleast we are getting better if not Best !! :)
0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 

Author Comment

by:om7ar
ID: 12484620
Hello again,

so it doesn't work as I supposed when using microsoft network client services, BSoD appeared again ;-(

I have tested it a lot, here are the results.

When I uninstalled all network protocols again, then NIC driver, cleaned registry,  after restart and reinstallation the NIC worked well until I have installed MS network client protocol, network configuration begun to loose (no cards nor wifi centrino listed after ipconfig /all).

I tried it more times with same results, it works well (connection to internet) but it brokes again when MS client is installed.

Interesting is, when I put a new PCMCIA NIC it works well also with that client installed and no BSoD apperars. What I should try now? I think I cleaned registry well and used more different drivers when I reinstalled  onboard realtek driver more times. But as it works well not using MS client it seems it should not be a HW problem.

to evasion: sometimes no NIC listed, sometimes just one I use for ethernet missing (same now when using another pcmcia), more below
0
 
LVL 65

Expert Comment

by:SheharyaarSaahil
ID: 12520649
just tell me one thing before i give my next suggestion,, the NIC is on-board one... right ??
when u uninstalled it, did u uninstall it from safemode...... coz sometimes there are hidden NIC entries which cannot be seen in normal mode,,,, and which are required to be uninstalled in order to reinstall the proper drivers to get the device working properly!
0
 

Author Comment

by:om7ar
ID: 12522516
Yes, that's right, the NIC is onboard, I uninstalled all of them through the safe mode, sometimes I had to disable them before to get rid of them ...

thanks,
Ladislav
0
 
LVL 65

Assisted Solution

by:SheharyaarSaahil
SheharyaarSaahil earned 500 total points
ID: 12528926
ok om7ar.... now the situation is looking like as the onboard NIC drivers information in registry are being wrongly assigned by installing and then uninstalling that CDMA modem... and thus this is resulting in these issues !!

That is the reason when u hooked a new NIC.... a new information was created for this card and thus its working well with the system !!

Now there can be two ways...... one is we forget abt the onboard NIC and keep using this new one... or we repair XP installation to refresh all the windows system files and registries so that all the registry information for ur devices can be reset to defaults !!

So Which one will u like to do now ?? :)
0
 

Author Comment

by:om7ar
ID: 12532466
I think registry clean should be enough. I deleted all PCI registrations to devices I found, but obviously not all. Repairing installation I loose everythink I have installed, I tuned iinstallation more weeks to today's (broken) image. What about to get all important registry keys on the list which I delete in safe mode. Could you propose your choice I come then with mine.
Thanks in advance.
0
 

Author Comment

by:om7ar
ID: 12633192
Hello All, so situation with OS got worse and worse (system unstability) so I decided to reinstall from the scratch. As also Assisted answer was right in my condition I decide to accept both to match the Article title. Thanks SheharyaarSaahil. Now I know hot to fix IP stacks.. ;-)
0
 
LVL 65

Expert Comment

by:SheharyaarSaahil
ID: 12633902
>> so situation with OS got worse and worse (system unstability)
hmmmm looks like the system couldn't manage to live without the onboard nic ;-)

>> Thanks SheharyaarSaahil. Now I know hot to fix IP stacks.. ;-)
Ahh atleast some contribution from my side to this question..... =\

lol.... Cheers ^_^
0

Featured Post

IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
only14 challenge 19 64
tenRun challenge 28 81
wordlen challenge 3 47
Adjust the position 3 13
Windows Script Host (WSH) has been part of Windows since Windows NT4. Windows Script Host provides architecture for building dynamic scripts that consist of a core object model, scripting hosts, and scripting engines. The key components of Window…
When you start your Windows 10 PC and got an "Operating system not found" error or just saw  "Auto repair for startup". After a while, you have entered a loop for Auto repair which does not fix anything and you will be in a  panic as all your work w…
Viewers will learn how to properly install Eclipse with the necessary JDK, and will take a look at an introductory Java program. Download Eclipse installation zip file: Extract files from zip file: Download and install JDK 8: Open Eclipse and …
The viewer will learn how to use the return statement in functions in C++. The video will also teach the user how to pass data to a function and have the function return data back for further processing.

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

17 Experts available now in Live!

Get 1:1 Help Now