Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

unable to see dmz and connect to vpn sites on pix 515

Posted on 2004-10-19
5
Medium Priority
?
217 Views
Last Modified: 2013-11-16
I got a cisco pix 515e. the following the my current configuration. Right now I am not able to see my Web-server neither to connect to two remote VPN sites. Please let me know what it is wrong with my configuration. thx.

=================================
: Saved
:
PIX Version 6.3(3)
interface ethernet0 auto
interface ethernet1 auto
interface ethernet2 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
nameif ethernet2 DMZ security4
enable password 1PTSGfq4y.DR2M/U encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname pixfirewall
domain-name ciscopix.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
no fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list outside_access_in remark Access List from Outside to Inside for HTTP traffic.
access-list outside_access_in permit tcp any eq www host <web-server_public-ip>
access-list outside_access_in permit icmp any any
access-list outside_access_in permit tcp any host <MAIL-server_public-ip> eq smtp
access-list outside_access_in remark Access List from Outside to Inside for HTTP traffic.
access-list outside_access_in permit tcp any host <web-server_public-ip> eq www
access-list inside_outbound_nat0_acl permit ip <INTERNAL-network> 255.255.255.0 <VPN1-site>255.255.255.0
access-list inside_outbound_nat0_acl permit ip <INTERNAL-network> 255.255.255.0 <VPN2-site>255.255.255.0
access-list dmz_access_in permit icmp any any
access-list 101 permit ip <INTERNAL-network> 255.255.255.0 <VPN1-site> 255.255.255.0
access-list 102 permit ip <INTERNAL-network> 255.255.255.0 <VPN2-site>255.255.255.0
access-list 100 permit icmp any any echo-reply
access-list 100 permit icmp any any unreachable
access-list 100 permit icmp any any
access-list web permit ip any host <web-server_public-ip>
pager lines 24
mtu outside 1500
mtu inside 1500
mtu DMZ 1500
ip address outside OutsideINT 255.255.255.0
ip address inside InsideINT 255.255.255.0
ip address DMZ DMZint 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
no failover
failover timeout 0:00:00
failover poll 15
no failover ip address outside
no failover ip address inside
no failover ip address DMZ
pdm location 192.168.1.0 255.255.255.0 inside
pdm location <web-server_internal-ip> 255.255.255.255 DMZ
pdm location <Mail-Filtering> 255.255.255.255 inside
pdm location 0.0.0.0 255.255.255.255 outside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
nat (DMZ) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) <MAIL-server_public-ip> <Mail-Filtering> netmask 255.255.255.255 0 0
static (inside,DMZ) <DMZ-network> <INTERNAL-network> netmask 255.255.255.0 0 0
static (DMZ,outside) <web-server_public-ip> <web-server_internal-ip> dns netmask 255.255.255.255 0 0
access-group outside_access_in in interface outside
access-group dmz_access_in in interface DMZ
route outside 0.0.0.0 0.0.0.0 <router_public-ip> 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
http server enable
http <INTERNAL-network> 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
sysopt noproxyarp outside
sysopt noproxyarp inside
sysopt noproxyarp DMZ
crypto ipsec transform-set HACK_VPN esp-3des esp-md5-hmac
crypto ipsec transform-set WNY_VPN esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto map transm 1 ipsec-isakmp
crypto map transm 1 match address 101
crypto map transm 1 set peer outsideINT_VPN1-site
crypto map transm 1 set transform-set VPN1-name
crypto map transm 2 ipsec-isakmp
crypto map transm 2 match address 102
crypto map transm 2 set peer outsideINT_VPN2-site
crypto map transm 2 set transform-set VPN2-name
isakmp enable outside
isakmp key ******** address outsideINT_VPN2-site netmask 255.255.255.255
isakmp key ******** address outsideINT_VPN1-site netmask 255.255.255.255
isakmp policy 1 authentication pre-share
isakmp policy 1 encryption 3des
isakmp policy 1 hash md5
isakmp policy 1 group 2
isakmp policy 1 lifetime 1000
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd dns 198.6.1.122 198.6.1.146
terminal width 80
Cryptochecksum:291a00b9bf9f5256b04d30a8be453619
: end
0
Comment
Question by:delsof
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
5 Comments
 
LVL 79

Expert Comment

by:lrmoore
ID: 12353410
Where are you trying to access the web server from? From outside, or from the inside lan?
If from inside the lan, add this line:
  global (DMZ) 1 interface

For the VPN's - can you post result of "show cry is sa"
  Looking for QM_IDLE or MM_something
  QM_IDLE is good, means the tunnel is actually established. If you get the tunnel up, but can't send packets through, that's usually a routing issue.
What are the end points that you are trying to connect to?

0
 
LVL 1

Author Comment

by:delsof
ID: 12358129
I am trying to access the webserver from inside as well as from outside.
I added the global line to my pix, clear xlate, and nothing happen yet.
the following is the output of show cry command.

show cry is sa
Total     : 0
Embryonic : 0
        dst               src        state     pending     created

The end points are two remote sites using pix 501 boxes.
Let me know what else can be done. thx

delsof
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 12358366
>I am trying to access the webserver from inside as well as from outside.
With the global command entered, you should now be able to access the web server from inside, using it's "real" ip address, not the static nat public ip address.

Try taking out this line:
    >static (inside,DMZ) <DMZ-network> <INTERNAL-network> netmask 255.255.255.0 0 0

and this line:
   >access-group dmz_access_in in interface DMZ

We'll work on the VPN tunnels separately.
0
 
LVL 1

Author Comment

by:delsof
ID: 12359394

In addition I also add a route in the internet router for the web-server. The DMZ access from inside and outside is up. Thx. Now, lets deal with the VPN sites now.
0
 
LVL 79

Accepted Solution

by:
lrmoore earned 2000 total points
ID: 12359739
For starters, since you have statics you might want to disable this:
  > sysopt noproxyarp outside
==>   no sysopt noproxyarp outside


Critical components to check:
 
  1. Verify same crypto key both ends - can't tell from your side alone..
     isakmp key ******** address outsideINT_VPN2-site netmask 255.255.255.255
     isakmp key ******** address outsideINT_VPN1-site netmask 255.255.255.255

   2. for PIX-PIX, add no-xauth no-config-mode
     isakmp key ******** address outsideINT_VPN2-site netmask 255.255.255.255 no-xauth no-config-mode
     isakmp key ******** address outsideINT_VPN1-site netmask 255.255.255.255 no-xauth no-config-mode

   3. Nat Zero acls to bypass NAT - looks OK (mirror image on remote PIXs)
    access-list inside_outbound_nat0_acl permit ip <INTERNAL-network> 255.255.255.0 <VPN1-site>255.255.255.0
    access-list inside_outbound_nat0_acl permit ip <INTERNAL-network> 255.255.255.0 <VPN2-site>255.255.255.0

   4. Access-lists that define tunnel traffic - looks OK: (mirror image on remote PIXs)
     access-list 101 permit ip <INTERNAL-network> 255.255.255.0 <VPN1-site> 255.255.255.0
     access-list 102 permit ip <INTERNAL-network> 255.255.255.0 <VPN2-site>255.255.255.0

   5. sysopt applied to permit ipsec - looks OK
      sysopt connection permit-ipsec

   6. Crypto transform sets defined - since they are all the same, you only need one..pick one and delete the others.
       verify same transforms used on both ends. Names don't matter except as in #7 below
     crypto ipsec transform-set HACK_VPN esp-3des esp-md5-hmac
     crypto ipsec transform-set WNY_VPN esp-3des esp-md5-hmac
     crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac

   7. crypto map defined (one set per peer) - Same config on remote peers
     crypto map transm 1 ipsec-isakmp
     crypto map transm 1 match address 101
     crypto map transm 1 set peer outsideINT_VPN1-site <== double-check peer IP
     crypto map transm 1 set transform-set VPN1-name <== you don't have this defined. Use the one in #6 that you kept
     crypto map transm 2 ipsec-isakmp
     crypto map transm 2 match address 102
     crypto map transm 2 set peer outsideINT_VPN2-site <== double-check peer IP
     crypto map transm 2 set transform-set VPN2-name <== you don't have this defined. Use the one in #6 that you kept

   8. crypto map applied to interface - WOOPS!, I don't see anything like this. Check all peers
     crypto map transam interface outside

    9. isakmp policy matches transform set - looks OK. The only difference in the two policies is the lifetime. That's OK
        Make sure you have exact same policies on the remote PIX's

isakmp policy 1 authentication pre-share
isakmp policy 1 encryption 3des
isakmp policy 1 hash md5
isakmp policy 1 group 2
isakmp policy 1 lifetime 1000
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
   
   10. Tell isakmp to use the IP address of peer as identity - I don't see this in your config - check all peers
     isakmp identity address

   11. enable Isakmp on interface - looks OK
     isakmp enable outside

Next issue of one of routing. No tunnel is established unless and until you have actual traffic to pass, and the routing is OK.
You need to start a continuous ping from a PC on your site to a PC on each remote site.
Make sure this PC has default gateway pointing to pix 192.168.1.x -- VERIFY with c:\>route print
Make sure the PC that your pinging on the remote site has its default gateway pointing to its local PIX - verify it.

Check:
   sho cry is sa
    Should see QM_IDLE x2 sites
    If you see MM_NOSTATE, or MM_KEYEXCHANGE, you might have to remove, then re-insert the crypto key on both ends.




     
     



0

Featured Post

Introducing the WatchGuard 420 Access Point

WatchGuard's newest access point includes an 802.11ac Wave 2 chipset, providing the fastest speeds for VoIP, video and music streaming, and large data file transfers. Additionally, enjoy the benefits of strong security as the 3rd radio delivers dedicated WIPS protection!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Concerto Cloud Services, a provider of fully managed private, public and hybrid cloud solutions, announced today it was named to the 20 Coolest Cloud Infrastructure Vendors Of The 2017 Cloud  (http://www.concertocloud.com/about/in-the-news/2017/02/0…
Many of the companies I’ve worked with have embraced cloud solutions due to their desire to “get out of the datacenter business.” The ability to achieve better security and availability, and the speed with which they are able to deploy, is far grea…
Both in life and business – not all partnerships are created equal. As the demand for cloud services increases, so do the number of self-proclaimed cloud partners. Asking the right questions up front in the partnership, will enable both parties …
As a trusted technology advisor to your customers you are likely getting the daily question of, ‘should I put this in the cloud?’ As customer demands for cloud services increases, companies will see a shift from traditional buying patterns to new…
Suggested Courses

670 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question