Solved

Running an Application on Terminal Server(Citrix)

Posted on 2004-10-20
10
750 Views
Last Modified: 2008-01-09
Hi,

I have a Windows application that has to run when users log in. I have pointed to the app in the Group Policies. The app tried to run when the user logs on and throws this error :
 
"The application failed to initialise properly(0xc0000022)"

What could be the problem???

Thanx in advance
0
Comment
Question by:JaBs206
10 Comments
 
LVL 1

Expert Comment

by:MathewSchlabaugh
ID: 12356479
This often happen when an application loads before Windows can grant access to the resource.
Issue usually occurs to non-administrative users. ACL permissions are not granted yet.  Replacement of shared files may effect the operation of other executables. The code 0xC0000022 indicates "access denied."

Possible Resolution:

Give the Everyone group Read permissions on the resource!
0
 

Author Comment

by:JaBs206
ID: 12357261
Hi,

The app (exe) is sitting on a folder where the Everyone group has "Read & Execute" and "Read" permissions and I still get the same error!!!

Thanx !!!
0
 

Expert Comment

by:patrick_henry_1776
ID: 12357348
After you are logged in, can you manually run the program from that location?

If not, is the program a .NET application?

If so, you can go to Administrative Tools-->.NET Framework Configuration and click the "Configure Code Access Security Policy" link. Then choose "Adjust Zone Security".  Click Next and move the slider for Local Intranet up to "Full Trust."

This may not be your problem, but I hope it helps.

patrick_henry_1776
0
 

Expert Comment

by:patrick_henry_1776
ID: 12357358
Oh.  I forgot this was on Citrix.  I don't know if my previous comment is applicable.  Sorry.
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 

Author Comment

by:JaBs206
ID: 12357595

I cannot run the app manually after logging in since it gives the same error. THis is a VB6 app. It only runs manually when logged on as the administrator...

Thanx
0
 
LVL 5

Expert Comment

by:kemp_a
ID: 12358461
Hi there,

Specific to Terminal Service/Citrix is this knowledgebase: http://support.microsoft.com/default.aspx?scid=kb;en-us;199080

The resolution is "Give the group Everyone, Read rights to the file Msjet35.dll on the Terminal Server."
Hopefully this sorts out your problem.

Cheers!
0
 

Author Comment

by:JaBs206
ID: 12359005
Hi there,

There's only the Msjet40.dll file on my system32 directory on the terminal server and there are Read rights allocated to the Everyone group. I have also visited the Knowledgebase you suggested above. The server doesn't have Office installed yet and the app connects to a SQL db on another machine on the network.

Thanx
0
 

Author Comment

by:JaBs206
ID: 12441500
Hi

I have finally found a solution to this question. I used Filemon.exe to monitor which files from the system32 directory gets accessed by the app. I then gave Read rights to the Everyone group for those files...namely wtsapi32.dll, wtsclientinfo.dll,msado.dll...

Thanx to all those who contributed in any way
0
 

Accepted Solution

by:
ee_ai_construct earned 0 total points
ID: 12485007
Question answered by asker or dialog valuable.
Closed, 250 points refunded.
ee_ai_construct (replacement part #xm34)
Community Support Admin
0

Featured Post

Top 6 Sources for Identifying Threat Actor TTPs

Understanding your enemy is essential. These six sources will help you identify the most popular threat actor tactics, techniques, and procedures (TTPs).

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
add text to end of existing text in file 16 62
scoreUp challenge 14 48
base64 decode encode 12 100
recursion example 16 70
If you’re thinking to yourself “That description sounds a lot like two people doing the work that one could accomplish,” you’re not alone.
In this post we will learn how to connect and configure Android Device (Smartphone etc.) with Android Studio. After that we will run a simple Hello World Program.
Viewers will learn how to properly install Eclipse with the necessary JDK, and will take a look at an introductory Java program. Download Eclipse installation zip file: Extract files from zip file: Download and install JDK 8: Open Eclipse and …
In this seventh video of the Xpdf series, we discuss and demonstrate the PDFfonts utility, which lists all the fonts used in a PDF file. It does this via a command line interface, making it suitable for use in programs, scripts, batch files — any pl…

746 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

9 Experts available now in Live!

Get 1:1 Help Now