[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 389
  • Last Modified:

problem installing Symantec Mail Security for SMTP - port invalid\in use

installing Symantec Mail Security for SMTP on Win2K Server get stuck when I have to configure the listening port numbers for SMTP, HTTP & HTTPS.
I leave the default ports (SMTP=25, http=8003, https=8043) & get this assage:
"One of the ports specified is already in use or invalid"
only when I changed all the ports I could get on with the installation but I couldn't change it back in the configuration screen so I had to uninstall it.
there is another mail relay installed on another machine in the network which would be shutdown once the new verison is up & running. I don't see any connection but anyway I even tried installing while that machine is turned off. same result.
I have no idea where to start...
0
chuku
Asked:
chuku
  • 3
  • 2
1 Solution
 
TannerManCommented:
The ports are machine specific. Even though you have another machine somewhere operating on port 25, this should not matter. Try leaving port 25, but using something different for the http and https. There apears to be something running on your machine already using these ports. Now, if you find that port 25 is also the problem, then you have something running on this machine that is listening on port 25 already. If IIS is installed, there may be the default smtp server running as well. You'll need to verify that. Hope it helps
0
 
chukuAuthor Commented:
I agree with your call that 'The ports are machine specific'
I just want to remind you that every win2k server listen to port 25, all the time,
the machine is new, just installed & no app running!

here are the 1st few rows when using netstat,

C:\>netstat -a -n

Active Connections

  Proto  Local Address          Foreign Address        State
  TCP    0.0.0.0:25             0.0.0.0:0              LISTENING
  TCP    0.0.0.0:80             0.0.0.0:0              LISTENING
  TCP    0.0.0.0:135            0.0.0.0:0              LISTENING
  TCP    0.0.0.0:443            0.0.0.0:0              LISTENING
  TCP    0.0.0.0:445            0.0.0.0:0              LISTENING
0
 
TannerManCommented:
I will disagree on port 25 listening by default. If you installed IIS and the smtp feature, then yes. A machine listens on ports that applications ask it to. You have to have a server side service desiring to listen to a port for a port to be open. Otherwise, the netstat you just did would list every single port listening whether there was an application requesting it or not.

Go to your services in computer managment and see if SMTP service is running. If it is,,,,,something has it running which, if as you said there are no applications running, then it will be IIS. Since your listening scan shows 25/80/443 then you have IIS installed and smtp. You can also go into add/remove programs and windows components.....find IIS and then it's details and uncheck smtp server.....if you do not want IIS to operate a default smtp server.
Hope it helps
0
 
chukuAuthor Commented:
you are so right! it was theh IIS
unlike win2k3server that uncheck almost everything, win2kserver install it all by default.
thx :)
0
 
TannerManCommented:
chuku,

I am so glad that worked out for you !!!
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now