Solved

NoBody Can Connect To My Computer/IP Address

Posted on 2004-10-20
10
490 Views
Last Modified: 2012-05-05
Hello,

I am trying to setup an FTP server on my home computer. I am using BulletProofv2.3.1. Once it is up and running, i can connect to it fine from my own computer but nobody else seems to be able to connect to my computer. Also, nobody is able to ping my computer's ip address. I have checked and there isnt any firewalls running in my processes. I was wondering if anybody has any ideas on how i can solve this problem

thanx,
Tom
0
Comment
Question by:tommyboy2214
10 Comments
 
LVL 9

Expert Comment

by:TannerMan
ID: 12359433
Does your ISP allow port 21 for FTP use? I would assume so.
Before you isntalled BulletProof could folks ping your IP?
Are you running a static IP address? Keep in mind that static or not, a lot of ISP's are blocking ICMP protocol, which does the pinging, to prevent discovery tasks by unwanted individuals.

No help, just some questions that might eventually get you there.
0
 
LVL 8

Expert Comment

by:cooljai1
ID: 12359458
Have you setup an anonymous account on the system?
http://www.bpftpserver.com/help/bpftpserver.com/manual_en/
this manual page gives you the steps to create an anonymous acount. Leave the login option unchecked.
0
 
LVL 3

Expert Comment

by:ccceqo2
ID: 12359539
Are you using a router to share your internet connection?
You will need to make sure that it is configured to forward port 21 to the private IP address of your computer.
0
Easy, flexible multimedia distribution & control

Coming soon!  Ideal for large-scale A/V applications, ATEN's VM3200 Modular Matrix Switch is an all-in-one solution that simplifies video wall integration. Easily customize display layouts to see what you want, how you want it in 4k.

 
LVL 20

Expert Comment

by:DVation191
ID: 12359691
If you are using Windows XP, you may have the built-in firewall on without even knowing it.

Disabling the XP SP2 Firewall
http://its.ucsf.edu/information/software/windows_xp/disable_sp2_fw.jsp

Disabling the XP Firewall (Pre-SP2)
http://www.webcamsoft.com/en/faq/xp_firewall.html
0
 
LVL 5

Expert Comment

by:AutoSponge
ID: 12360607
I'm guessing that you have a broadband connection to the Internet and your IP address is a NAT address (something like 192.168.1.101).  If that's the case, tell your router to forward port 21 to your IP and tell people trying to connect to you to use your public IP (the one your router knows as the WAN address).
0
 

Author Comment

by:tommyboy2214
ID: 12361566
Hi Guys, thanx for all the suggestions

I guess i should have explained a little more about my topology. I just have a straight broadband connection to the internet through a cable modem. I dont have a router, or anyting. Also, i checked that XP firewall and it is disabled. I will put a call into my ISP to see if maybe they have something to do with it.  Also, when the ftp server is running, i can connnect to it from my own computer by typing in my ipaddress from an ftp client. Just going from my ftp client to my ftp server on same computer. Thanx for all suggestions and any more would be appreciated. I will split up the points to all who helped if i cant get a solution that works.

thanx
0
 
LVL 2

Assisted Solution

by:GazzerH
GazzerH earned 50 total points
ID: 12371911
Which IP address are you using to connect from your own computer. Is it the one assigned from the ISP or your internal network.

You will always have problems doing this with just a modem without a router. This is what a router is designed to do. To route packets from one network (the internet) and another network (your LAN). If you want to accomplish this I would recommend you splash out and buy a Router. Netgear RP614 is good. This allows Port Forwarding (21 in FTPs case) and includes a firewall as well.

Not knowing much about Cable Modems not such I presume they have a network interface as such. ie What gateway do you use to access the internet. type:
ipconfig /all
at the command prompt and check out your default gateway.

You may then need to add this into your routing table using:
route add <default gateway address>

Just a few ideas for you to try...
0
 
LVL 20

Accepted Solution

by:
DVation191 earned 450 total points
ID: 12372331
Most ISP's block popular ports for servers. Try chaning the port your FTP server listens on to something over the 5,000 range...something like 5500. See if anyone can connect then. If somebody cannot ping your public IP address (find out your public IP address here ... http://www.whatismyip.com/ ), then either you are running software (typically a firewall) that is discarding PING packets, or your ISP is not allowing PING packets. If that is the case, it should only stop people from pinging you, not from connecting via FTP, assuming the port you are using is not block.

After chaning the port on the server, run a port scan on yourself to see if the port is available to the public. Go to https://grc.com/x/ne.dll?bh0bkyd2
Choose the "User Specified Custom Port Provbe" button. Enter in 21, 5500 ... and see how if it reports either port open.
0
 

Author Comment

by:tommyboy2214
ID: 12373444
thanx everybody for the help,

Tuns out my ISP was blocking PORT 21 so i switched and it worked,

thanx,
Tom
0
 
LVL 20

Expert Comment

by:DVation191
ID: 12373555
Thank you
0

Featured Post

Connect further...control easier

With the ATEN CE624, you can now enjoy a high-quality visual experience powered by HDBaseT technology and the convenience of a single Cat6 cable to transmit uncompressed video with zero latency and multi-streaming for dual-view applications where remote access is required.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Web site adult filtering solutions for a small LAN network 27 150
Internet Protocol Security question 3 94
BGP prefix and routing 3 58
Windows 7 Internet issue 14 54
If you're not part of the solution, you're part of the problem.   Tips on how to secure IoT devices, even the dumbest ones, so they can't be used as part of a DDoS botnet.  Use PRTG Network Monitor as one of the building blocks, to detect unusual…
PRTG Network Monitor lets you monitor your bandwidth usage, so you know who is using up your bandwidth, and what they're using it for.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

809 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question