Solved

SQUID 2.5 on redhat 8

Posted on 2004-10-20
7
314 Views
Last Modified: 2012-05-05
Hi i have just compiled the new versione of squid on redhat 8
and it doesn't start.
Can you help me ?
0
Comment
Question by:alextesi
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
7 Comments
 
LVL 14

Expert Comment

by:pablouruguay
ID: 12360864
yes can we help you if you specify your problem and paste the tail of  /var/log/messages  or the squid.log   and you habve squid.conf in the /etc/ ????
0
 
LVL 19

Accepted Solution

by:
Gabriel Orozco earned 250 total points
ID: 12371929
you need to edit the configuration file.

also squid needs a user so it can run as that user.

once you configure your squid.conf, you need to create the cache directory with "squid -z" (without quotes) and then check the directory was created under the user you specified on the squid.conf file. if not, do a chown -R username /directory/of/squid/cache

and then you can start squid with it's command. if you configured standard from sources, it should be on /usr/local/squid/sbin/squid

test it and give some feedback if you need.

Regards
0
 
LVL 1

Author Comment

by:alextesi
ID: 12372862
My squid.conf file is under /usr/local/squid/etc/squid.conf
I'have just configured my squid.conf file but squid doesn't start.
i have inizialized my squid cache.
................. can i give you any other information ?
Bye
Alessandro
0
Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

 
LVL 19

Expert Comment

by:Gabriel Orozco
ID: 12373141
well, yes.

use squid -N and see the error log. then post it here
0
 
LVL 17

Expert Comment

by:owensleftfoot
ID: 12375085
You probably dont have a valid domainname - look at the visiblehost option in squid.conf
0
 

Expert Comment

by:omphs_XXXX
ID: 12388160
is this a new installation or you have previous installation of squid?

are your done configuring  your squid.conf? try to check your configuration
squid -k parse to check if your squid.conf has no error.
0
 
LVL 19

Expert Comment

by:Gabriel Orozco
ID: 12391157
any feedback?

we are still waiting for output log in order to be helpful.

Regards
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
With Secure Portal Encryption, the recipient is sent a link to their email address directing them to the email laundry delivery page. From there, the recipient will be required to enter a user name and password to enter the page. Once the recipient …
Finding and deleting duplicate (picture) files can be a time consuming task. My wife and I, our three kids and their families all share one dilemma: Managing our pictures. Between desktops, laptops, phones, tablets, and cameras; over the last decade…

737 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question