Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 758
  • Last Modified:

Stopping named: rndc: connect failed: connection refused

Hello,

I am facing the issue related to the named.
My /etc/named.conf is as per given below :

controls {
        inet 127.0.0.1 port 953
        allow { 127.0.0.1; } keys { "rndc-key"; };
};
// Setting up secondaries is way easier and the rough picture for this
// is explained below.
//
// If you enable a local name server, don't forget to enter 127.0.0.1
// into your /etc/resolv.conf so this server will be queried first.
// Also, make sure to enable it in /etc/rc.conf.

zone "." {
        type hint;
        file "named.root";
};

zone "0.0.127.IN-ADDR.ARPA" {
        type master;
        file "localhost.rev";
};

====================
and logs tell me :

Oct 19 18:23:07 nifty-west named[18478]: starting BIND 9.2.1 -u named
Oct 19 18:23:07 nifty-west named[18478]: using 1 CPU
Oct 19 18:23:07 nifty-west named[18480]: loading configuration from '/etc/named.conf'
Oct 19 18:23:07 nifty-west named: named startup succeeded
Oct 19 18:23:07 nifty-west named[18480]: no IPv6 interfaces found
Oct 19 18:23:07 nifty-west named[18480]: listening on IPv4 interface lo, 127.0.0.1#53
Oct 19 18:23:07 nifty-west named[18480]: listening on IPv4 interface eth0, 65.75.176.150#53
Oct 19 18:23:07 nifty-west named[18480]: listening on IPv4 interface eth0:1, 65.75.176.151#53
Oct 19 18:23:07 nifty-west named[18480]: listening on IPv4 interface eth0:2, 65.75.176.152#53
Oct 19 18:23:07 nifty-west named[18480]: listening on IPv4 interface eth0:3, 65.75.176.153#53
Oct 19 18:23:07 nifty-west named[18480]: listening on IPv4 interface eth0:4, 65.75.176.154#53
Oct 19 18:23:07 nifty-west named[18480]: listening on IPv4 interface eth0:5, 65.75.176.155#53
Oct 19 18:23:07 nifty-west named[18480]: listening on IPv4 interface eth0:6, 65.75.176.156#53
Oct 19 18:23:07 nifty-west named[18480]: listening on IPv4 interface eth0:7, 65.75.176.157#53
Oct 19 18:23:07 nifty-west named[18480]: listening on IPv4 interface eth0:8, 65.75.176.158#53
Oct 19 18:23:07 nifty-west named[18480]: listening on IPv4 interface eth0:9, 65.75.176.159#53
Oct 19 18:23:07 nifty-west named[18480]: could not configure root hints from 'named.root': file not found
Oct 19 18:23:07 nifty-west named[18480]: loading configuration: file not found
Oct 19 18:23:07 nifty-west named[18480]: exiting (due to fatal error)
============================

Please help me..

Thank you,
0
sandeepaher
Asked:
sandeepaher
1 Solution
 
blklineCommented:
You don't have a named.root file.  

Please check out:
http://www.tldp.org/HOWTO/DNS-HOWTO.html

That will tell you everything that you need to set up a cacheing name server.



0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now