?
Solved

Search Criteria in LOV in Oracle forms 6i

Posted on 2004-10-20
6
Medium Priority
?
1,180 Views
Last Modified: 2012-08-13
Hi Guys,
      I have a problem in LOV search criteria.Hopefully ,you guys could help me out in resolving the issue.

There are two scenarios for the above problem:


1: When the enter the search criteria in the field itself without invoking the LOV.
      so when i enter B%  in the field column, i get the LOV display of the items starting with B only ...
     (This way it is working)

2: Without entering the search criteria on the field ,i opened  the LOV list and enter B% ,i am getting all
    the values (just not starting with B).
    But when i enter the second time again with B% in the LOV list ,i am getting the values starting with B only.

I am unable to guess what is making it work like this?
Help me out on this.

Thanks.
   
   
0
Comment
Question by:babunagendra
  • 4
  • 2
6 Comments
 
LVL 22

Expert Comment

by:Helena Marková
ID: 12378378
It is a LOV behaviour.
1) the Validate from List property is true, so it validates B% and because there is no such item in LOV it displays the LOV with items starting with B.
2) " ...i opened  the LOV list and enter B%" - you ought to push "Find" button on LOV and you'll get items starting with B.
0
 

Author Comment

by:babunagendra
ID: 12380987
I tried the same as you suggested,this is what's happening?

I have the LOV list drop down,
            then            Find   --->B%     and then clicked the "find" button then i get all the values(just not starting with B).
 
The second time, i did the same, i am getting the values starting with B.
   
0
 
LVL 22

Expert Comment

by:Helena Marková
ID: 12397531
It looks like a bug ... It ought to work for the first time.
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
LVL 22

Accepted Solution

by:
Helena Marková earned 2000 total points
ID: 12398244
I have searched metalink just now and found a lot of bugs.
0
 

Author Comment

by:babunagendra
ID: 12437431
You are right about the bugs.

I tried this procedure. It is working fine in the testing instance,the way we expect it would.

So, i took the .fmb from the testing instance and renamed the form and did the customizations needed to the form(which is very minimal, just rearranging 2 items in the Canvas) and did try again.

It is still throwing up the same error. !!!
0
 
LVL 22

Expert Comment

by:Helena Marková
ID: 12441420
So it seems that we must live with the bugs. I think that it is something caused by OS.
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article shows how to get a list of available printers for display in a drop-down list, and then to use the selected printer to print an Access report or a Word document filled with Access data, using different syntax as needed for working with …
In this article, we’ll look at how to deploy ProxySQL.
This is a high-level webinar that covers the history of enterprise open source database use. It addresses both the advantages companies see in using open source database technologies, as well as the fears and reservations they might have. In this…
In this video, Percona Solution Engineer Dimitri Vanoverbeke discusses why you want to use at least three nodes in a database cluster. To discuss how Percona Consulting can help with your design and architecture needs for your database and infras…
Suggested Courses

755 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question