• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1221
  • Last Modified:

Search Criteria in LOV in Oracle forms 6i

Hi Guys,
      I have a problem in LOV search criteria.Hopefully ,you guys could help me out in resolving the issue.

There are two scenarios for the above problem:

1: When the enter the search criteria in the field itself without invoking the LOV.
      so when i enter B%  in the field column, i get the LOV display of the items starting with B only ...
     (This way it is working)

2: Without entering the search criteria on the field ,i opened  the LOV list and enter B% ,i am getting all
    the values (just not starting with B).
    But when i enter the second time again with B% in the LOV list ,i am getting the values starting with B only.

I am unable to guess what is making it work like this?
Help me out on this.

  • 4
  • 2
1 Solution
Helena Markováprogrammer-analystCommented:
It is a LOV behaviour.
1) the Validate from List property is true, so it validates B% and because there is no such item in LOV it displays the LOV with items starting with B.
2) " ...i opened  the LOV list and enter B%" - you ought to push "Find" button on LOV and you'll get items starting with B.
babunagendraAuthor Commented:
I tried the same as you suggested,this is what's happening?

I have the LOV list drop down,
            then            Find   --->B%     and then clicked the "find" button then i get all the values(just not starting with B).
The second time, i did the same, i am getting the values starting with B.
Helena Markováprogrammer-analystCommented:
It looks like a bug ... It ought to work for the first time.
Easily Design & Build Your Next Website

Squarespace’s all-in-one platform gives you everything you need to express yourself creatively online, whether it is with a domain, website, or online store. Get started with your free trial today, and when ready, take 10% off your first purchase with offer code 'EXPERTS'.

Helena Markováprogrammer-analystCommented:
I have searched metalink just now and found a lot of bugs.
babunagendraAuthor Commented:
You are right about the bugs.

I tried this procedure. It is working fine in the testing instance,the way we expect it would.

So, i took the .fmb from the testing instance and renamed the form and did the customizations needed to the form(which is very minimal, just rearranging 2 items in the Canvas) and did try again.

It is still throwing up the same error. !!!
Helena Markováprogrammer-analystCommented:
So it seems that we must live with the bugs. I think that it is something caused by OS.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

  • 4
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now