Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3568
  • Last Modified:

Default Recipient policy setting

How is it possible to force lower-case lettering for the recipient policy email address.  We want it to be firstname.lastname@domain.com - but all lower case.  I have set the policy to be %g.%s@domain.com.  But since it pulls the information from AD we input it as John Smith and the email address is them Jim.Smith@domain.com and we need it to be jim.smith@domain.com

Is this possible?  BTW - we can't use the display name and do that lower case.  And they don't want me to input the first name and last name in lower case.  Is there another variable I can use?  Any help is GREATLY appreciated.

0
trbosol
Asked:
trbosol
1 Solution
 
salberdCommented:
When setting up the account, enter jim.smith@domain.com instead of Jim.Smith@domain.com in the email field.  This will make the display name be Jim Smith but the email address jim.smith@domain.com.

0
 
trbosolAuthor Commented:
I was mainly looking for an automatic way of doing it through the policy.
0
 
rlindermeierCommented:
Please give me any plausible reason why your addresses shouldn´t be Jim.Smith@..... ?

Exchange doesn´t give a damn whether lower or upper-case lettering in an email address ..... That´s not UNIX !!
Your can send to jim.smith and Jim.Smith, both e-mail are post in the same mailbox
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
trbosolAuthor Commented:
The company is VERY big on formality and structure.  They want email addresses to go out lower case b/c of the look - they don't like Jim.Smith even though it has been explained they both function correctly and it would be easier to go the Jim.Smith route.  I can't be the first one to need to do this.
0
 
rlindermeierCommented:
i fear that you the first one with this "problem" ... Sorry, but there is no known solution to do that ....
0
 
tjeerdvandermeerCommented:
Same problem here!
The Exchange email address policy unfortunately does not have a setting to use lowercase for an uppercase character in the user properties. That is very annoying if you want to use the email address data in your autosignature. Our house style prescribes lowercase email addresses, but the email address policy turns it to upper case automatically. The only way to workaround is to put it to lower case manually and turn off "Automatically update email addresses based on recipient policy".
0
 
SectorX4Commented:
I was looking into this problem as well and found this:

http://www.tech-archive.net/Archive/Exchange/microsoft.public.exchange.admin/2006-01/msg03704.html

It is possible to do (I have tested this and it works in Exchange 2003) with a little bit of creative %rxy use.
0
 
mpitadminCommented:
Check this site out
http://support.microsoft.com/kb/285136/

Basically you need to replace all capitals with lower case as shown below
Create the Smtp string to read:
"%rAa%rBb%rCc%rDd%rEe%rFf%rGg%rHh%rIi%rJj%rKk%rLl%rMm%rNn%rOo%rPp%rQq%rRr%rSs%rTt%rUu%rVv%rWw%rXx%rYy%rZz%g.%s@domain.com"

Hope this helps
0

Featured Post

Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now