Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win


upgrading samba 3.03-1 to 3.07-1 redhat linux 9.0

Posted on 2004-10-20
Medium Priority
Last Modified: 2013-12-16

I'm running samba 3.03 and want to upgrade to the latest stable release that has just been issued.  it is a member server in active directory.  they system has beem happily spinning for the last 141 days without a hicough.  

so my question is this.  
after downloading the new package from samba.org,  are there any gotchas that I need to be aware of before I type "rpm -Uvh newsamba307.rpm" in my shell?

this is a production server, and I would rather have this go smoothly so my opensource initiative keeps it's untarnished reputation.


Question by:tanelorn
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 3
LVL 40

Accepted Solution

jlevie earned 2000 total points
ID: 12364321
It should go smoothly... However, you are upgrading a RedHat package with a non-vendor binary. There's nothing that I can see that tells me that the rpm was built against an up to date RH 9 or the original version as shipped on the RH 9 CD's, or something in between. If it were me I'd make sure that my system had all relevant RH 9 errata applied (see http://www.fedoralegacy.org) and then I'd get the SRPM from samba.org and build my own copy.

Author Comment

ID: 12365187
Thanks for responding,
I downloaded the redhat 9 rpm (the version I'm using.) from samba.org's download section so I don't think I'll have to roll my own.

fedoralegacy.org.   good to know,  I'll check it out. I know redhat stopped supporting 9.0, but I didn't know that there was a site that carried the torch.  

there are a lot of bug security and fixes in this release, and we are rolling this server out to more areas in the facility.  I'm happy with functionality and configuration. (had to put in the 3.0.3 version to respect secondary group memberships...that was a pain to figure out...I was testing out 3.0.2 bumping into that, while the coder-gods were rewriting that piece...)

should I back anything up?  config files?, Kerberos stuff?...  winbindd databases?.   and if so,  what and how?
or will the daemons just restart and drive on.



LVL 40

Expert Comment

ID: 12365244
> I downloaded the redhat 9 rpm (the version I'm using.) from samba.org's download section

My point was that there's nothing on the Samba site that tells you what the build environment was. Was it built on the orginal release? A fully updated system, or something inbetween?

The safe solution is to bring your box up to date and build a package from the SRPM. That's certain to be compatible with your system.

On a mission critical server I'd certainly take a full backup before upgrading something like Samba. It should just drop in and run, but if it doesn't...
NEW Veeam Agent for Microsoft Windows

Backup and recover physical and cloud-based servers and workstations, as well as endpoint devices that belong to remote users. Avoid downtime and data loss quickly and easily for Windows-based physical or public cloud-based workloads!


Author Comment

ID: 12368189
Ahh,  ok, I see your point.  I'll give it a go and report back


Author Comment

ID: 12388248
wow,  I should have done a little more homework.

redhat 9,kernel 2.4.* with samba 3.0.3 running kerberos 1.2.7

when I set up this server, the domain controllers were win2k.  since the server was built, it hasn't been rebooted.  
during that time, the domain controllers have been upgraded to win2k3.  

with the domain controller upgrade, Microsoft changed the kerberos authentication back end.  changed the encryption type, and the size of the ticket packet....(big suprise there) this required kerberos 1.3.1 at least.  

so,  I uninstalled kerberos, and samba. (saving the config files etc.)  compiled kerberos 1.3.5 and samba 3.0.7-1 from source/ and installed.

the pieces worked independently. meaning that I could issue commands with the correct responses
wbinfo -u and -g returned domain information.  getent returned info.  

klist, kinit, net ads***  all worked as expected.  but when I tried to connect to it with a windows client, I go the error "failed to validate ticket"  so I turned on logging and took a look at the logs..  

after extensive googling,  I came to the conclusion that there have been a lot of people with the same problem.  so I've decided to upgrade the server to fedora core 2.  well,  not upgrade, but  rebuild.  this has the correct kerberos back end, and samba 3.0.7-2 all ready to go.  

also I'm using a promise controller, (have to use a 2.4 kernel with that...)  so I've ordered a 3ware controller to replace that.  in the meantime I'm working with another machine to buzz out the software.

any other thoughts?

LVL 40

Expert Comment

ID: 12388723
That sounds like a good plan to me.

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Over the last ten+ years I have seen Linux configuration tools come and go. In the early days there was the tried-and-true, all-powerful linuxconf that many thought would remain the one and only Linux configuration tool until the end of times. Well,…
Setting up Secure Ubuntu server on VMware 1.      Insert the Ubuntu Server distribution CD or attach the ISO of the CD which is in the “Datastore”. Note that it is important to install the x64 edition on servers, not the X86 editions. 2.      Power on th…
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.
Suggested Courses

618 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question