Celebrate National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17


VPN and DNS and Domains

Posted on 2004-10-20
Medium Priority
Last Modified: 2010-04-10
First question...

I have a Pix 506e setup for VPN.  I have the DNS setup as, which is the DNS server for all the local lan machines (and they work fine).  The local machines IPs are 192.168.1.x and my VPN'ed machines are given a 192.168.11.x.  From a 192.168.11.x machine I can ping the DNS server fine but cannot ping the actual DNS which the .10 forwards to (ie. and  Now when I connect remotely to the server (using XP remote desktop w/ my 192.168.11.x machine) I can ping the 64.89.x.x addresses fine.  Where is my DNS problem?

Second question...

Is there anyway to add a computer to a domain and then log on (for the first time...ie. no cache) to the domain while it is not present?  I have added my home machine to the domain while connected through VPN but then when I try to logon to the domain (again for the first time) and it says Domain is not available offline or whatever....I just dont' want to have to hall this to the office and log on once to the domain then bring it back to the house until the cache runs out.  Is there any way to automatically connect to the VPN before you logon...that way the domain would be available.

Question by:r270ba
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 5

Author Comment

ID: 12365716
Disregard the 2nd question....I have found it....

You can change that in the options of the Cisco VPN client software under Options->Windows Logon Properties for future reference.
LVL 79

Expert Comment

ID: 12366359
First question - unless you enable split tunneling for the VPN users, you will not be able to ping any public IP address, including the public DNS servers from your VPN client..

LVL 79

Expert Comment

ID: 12366367
Add this to your config:

  access-list split_tunnel_acl permit
  vpngroup tsp_admin split-tunnel split_tunnel_acl

Veeam Disaster Recovery in Microsoft Azure

Veeam PN for Microsoft Azure is a FREE solution designed to simplify and automate the setup of a DR site in Microsoft Azure using lightweight software-defined networking. It reduces the complexity of VPN deployments and is designed for businesses of ALL sizes.

LVL 79

Expert Comment

ID: 12403457
Any progress? Are you still working on this? Do you need more information?

Author Comment

ID: 12424165
I have been out of town and just got back in Monday.  I am getting caught up and will get back to you.  Sorry :(....

Author Comment

ID: 12437138
Didn't work....

Here is my running config:

I added another VPN Group tsp_sales which I want to do the split tunneling with:

Result of firewall command: "show running-config"
: Saved
PIX Version 6.3(3)
interface ethernet0 auto
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password ivL/lG89LSw2/TLx encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname tristatepix
domain-name tristate.tsppumps.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
access-list 101 permit icmp any any
access-list inside_outbound_nat0_acl permit ip
access-list inside_outbound_nat0_acl permit ip any
access-list outside_cryptomap_dyn_20 permit ip any
access-list tsp_sales_splitTunnelAcl permit ip any any
access-list outside_cryptomap_dyn_40 permit ip any
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside 66.83.x.x
ip address inside
ip audit info action alarm
ip audit attack action alarm
ip local pool VPNTEST
pdm location outside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 0 0
access-group 101 in interface outside
route outside 66.83.x.x 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
http server enable
http inside
http inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto dynamic-map outside_dyn_map 20 match address outside_cryptomap_dyn_20
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-MD5
crypto dynamic-map outside_dyn_map 40 match address outside_cryptomap_dyn_40
crypto dynamic-map outside_dyn_map 40 set transform-set ESP-3DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
isakmp enable outside
isakmp nat-traversal 20
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
vpngroup tsp_admin address-pool VPNTEST
vpngroup tsp_admin dns-server
vpngroup tsp_admin default-domain tristate.tsppumps.com
vpngroup tsp_admin idle-time 1800
vpngroup tsp_admin password ********
vpngroup tsp_sales address-pool VPNTEST
vpngroup tsp_sales dns-server
vpngroup tsp_sales default-domain tristate.tsppumps.com
vpngroup tsp_sales split-tunnel tsp_sales_splitTunnelAcl
vpngroup tsp_sales idle-time 1800
vpngroup tsp_sales password ********
telnet inside
telnet timeout 5
ssh outside
ssh timeout 5
console timeout 0
terminal width 80
LVL 79

Expert Comment

ID: 12437313
Try changing this:
  access-list tsp_sales_splitTunnelAcl permit ip any any

to this:
   access-list tsp_sales_splitTunnelAcl permit

Author Comment

ID: 12437524
how do i remove

>access-list tsp_sales_splitTunnelAcl permit ip any any

do I run

"no access-list tsp_sales_splitTunnelAcl permit ip any any"  in the command line

and then
"access-list tsp_sales_splitTunnelAcl permit"

Author Comment

ID: 12437567
I took away the first and tried to add the 2nd and received this error:

Result of firewall command: "access-list tsp_sales_splitTunnelAcl permit"
ERROR: invalid protocol
Usage:      [no] access-list compiled
[no] access-list deny-flow-max <n>
[no] access-list alert-interval <secs>
[no] access-list <id> compiled
[no] access-list <id> [line <line-num>] remark <text>
[no] access-list <id> [line <line-num>] deny|permit
      <protocol>|object-group <protocol_obj_grp_id>
      <sip> <smask> | interface <if_name> | object-group <network_obj_grp_id>
      [<operator> <port> [<port>] | object-group <service_obj_grp_id>]
      <dip> <dmask> | interface <if_name> | object-group <network_obj_grp_id>
      [<operator> <port> [<port>] | object-group <service_obj_grp_id>]
      [log [disable|default] | [<level>] [interval <secs>]]
[no] access-list <id> [line <line-num>] deny|permit icmp
      <sip> <smask> | interface <if_name> | object-group <network_obj_grp_id>
      <dip> <dmask> | interface <if_name> | object-group <network_obj_grp_id>
      [<icmp_type> | object-group <icmp_type_obj_grp_id>]
      [log [disable|default] | [<level>] [interval <secs>]]
Restricted ACLs for route-map use:
[no] access-list <id> deny|permit {any | <prefix> <mask> | host <address>}
Command failed
LVL 79

Accepted Solution

lrmoore earned 2000 total points
ID: 12437717

remove the first one:
   no access-list tsp_sales_splitTunnelAcl permit ip any any

My bad...

    access-list tsp_sales_splitTunnelAcl permit ip

Author Comment

ID: 12484256
worked like a charm!  thanks

Featured Post

Learn how to optimize MySQL for your business need

With the increasing importance of apps & networks in both business & personal interconnections, perfor. has become one of the key metrics of successful communication. This ebook is a hands-on business-case-driven guide to understanding MySQL query parameter tuning & database perf

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article is a collection of issues that people face from time to time and possible solutions to those issues. I hope you enjoy reading it.
This article will show how Aten was able to supply easy management and control for Artear's video walls and wide range display configurations of their newsroom.
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
Michael from AdRem Software explains how to view the most utilized and worst performing nodes in your network, by accessing the Top Charts view in NetCrunch network monitor (https://www.adremsoft.com/). Top Charts is a view in which you can set seveā€¦
Suggested Courses

730 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question