Solved

VPN and DNS and Domains

Posted on 2004-10-20
11
331 Views
Last Modified: 2010-04-10
First question...

I have a Pix 506e setup for VPN.  I have the DNS setup as 192.168.1.10, which is the DNS server for all the local lan machines (and they work fine).  The local machines IPs are 192.168.1.x and my VPN'ed machines are given a 192.168.11.x.  From a 192.168.11.x machine I can ping the 192.168.1.10 DNS server fine but cannot ping the actual DNS which the .10 forwards to (ie. 64.89.70.2 and 64.89.74.2).  Now when I connect remotely to the 192.168.1.10 server (using XP remote desktop w/ my 192.168.11.x machine) I can ping the 64.89.x.x addresses fine.  Where is my DNS problem?

Second question...

Is there anyway to add a computer to a domain and then log on (for the first time...ie. no cache) to the domain while it is not present?  I have added my home machine to the domain while connected through VPN but then when I try to logon to the domain (again for the first time) and it says Domain is not available offline or whatever....I just dont' want to have to hall this to the office and log on once to the domain then bring it back to the house until the cache runs out.  Is there any way to automatically connect to the VPN before you logon...that way the domain would be available.

Thanks
0
Comment
Question by:r270ba
  • 6
  • 5
11 Comments
 

Author Comment

by:r270ba
ID: 12365716
Disregard the 2nd question....I have found it....

You can change that in the options of the Cisco VPN client software under Options->Windows Logon Properties for future reference.
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 12366359
First question - unless you enable split tunneling for the VPN users, you will not be able to ping any public IP address, including the public DNS servers from your VPN client..

0
 
LVL 79

Expert Comment

by:lrmoore
ID: 12366367
Add this to your config:

  access-list split_tunnel_acl permit 192.168.1.0 255.255.255.0 192.168.11.0 255.255.255.0
  vpngroup tsp_admin split-tunnel split_tunnel_acl

0
 
LVL 79

Expert Comment

by:lrmoore
ID: 12403457
Any progress? Are you still working on this? Do you need more information?
0
 

Author Comment

by:r270ba
ID: 12424165
I have been out of town and just got back in Monday.  I am getting caught up and will get back to you.  Sorry :(....
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 

Author Comment

by:r270ba
ID: 12437138
Didn't work....

Here is my running config:

I added another VPN Group tsp_sales which I want to do the split tunneling with:

Result of firewall command: "show running-config"
 
: Saved
:
PIX Version 6.3(3)
interface ethernet0 auto
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password ivL/lG89LSw2/TLx encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname tristatepix
domain-name tristate.tsppumps.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list 101 permit icmp any any
access-list inside_outbound_nat0_acl permit ip 192.168.1.0 255.255.255.0 192.168.11.0 255.255.255.0
access-list inside_outbound_nat0_acl permit ip any 192.168.11.192 255.255.255.192
access-list outside_cryptomap_dyn_20 permit ip any 192.168.11.192 255.255.255.192
access-list tsp_sales_splitTunnelAcl permit ip any any
access-list outside_cryptomap_dyn_40 permit ip any 192.168.11.192 255.255.255.192
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside 66.83.x.x 255.255.255.0
ip address inside 192.168.1.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool VPNTEST 192.168.11.201-192.168.11.254
pdm location 192.168.11.0 255.255.255.0 outside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
access-group 101 in interface outside
route outside 0.0.0.0 0.0.0.0 66.83.x.x 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
http server enable
http 192.168.1.0 255.255.255.0 inside
http 0.0.0.0 0.0.0.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto dynamic-map outside_dyn_map 20 match address outside_cryptomap_dyn_20
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-MD5
crypto dynamic-map outside_dyn_map 40 match address outside_cryptomap_dyn_40
crypto dynamic-map outside_dyn_map 40 set transform-set ESP-3DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
isakmp enable outside
isakmp nat-traversal 20
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
vpngroup tsp_admin address-pool VPNTEST
vpngroup tsp_admin dns-server 192.168.1.10
vpngroup tsp_admin default-domain tristate.tsppumps.com
vpngroup tsp_admin idle-time 1800
vpngroup tsp_admin password ********
vpngroup tsp_sales address-pool VPNTEST
vpngroup tsp_sales dns-server 192.168.1.10
vpngroup tsp_sales default-domain tristate.tsppumps.com
vpngroup tsp_sales split-tunnel tsp_sales_splitTunnelAcl
vpngroup tsp_sales idle-time 1800
vpngroup tsp_sales password ********
telnet 0.0.0.0 0.0.0.0 inside
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 5
console timeout 0
terminal width 80
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 12437313
Try changing this:
  access-list tsp_sales_splitTunnelAcl permit ip any any

to this:
   access-list tsp_sales_splitTunnelAcl permit 192.168.1.0 255.255.255.0 192.168.11.0 255.255.255.0
0
 

Author Comment

by:r270ba
ID: 12437524
how do i remove

>access-list tsp_sales_splitTunnelAcl permit ip any any


do I run

"no access-list tsp_sales_splitTunnelAcl permit ip any any"  in the command line

and then
"access-list tsp_sales_splitTunnelAcl permit 192.168.1.0 255.255.255.0 192.168.11.0 255.255.255.0"
0
 

Author Comment

by:r270ba
ID: 12437567
I took away the first and tried to add the 2nd and received this error:

Result of firewall command: "access-list tsp_sales_splitTunnelAcl permit 192.168.1.0 255.255.255.0 192.168.11.0 255.255.255.0"
 
ERROR: invalid protocol 192.168.1.0
Usage:      [no] access-list compiled
[no] access-list deny-flow-max <n>
[no] access-list alert-interval <secs>
[no] access-list <id> compiled
[no] access-list <id> [line <line-num>] remark <text>
[no] access-list <id> [line <line-num>] deny|permit
      <protocol>|object-group <protocol_obj_grp_id>
      <sip> <smask> | interface <if_name> | object-group <network_obj_grp_id>
      [<operator> <port> [<port>] | object-group <service_obj_grp_id>]
      <dip> <dmask> | interface <if_name> | object-group <network_obj_grp_id>
      [<operator> <port> [<port>] | object-group <service_obj_grp_id>]
      [log [disable|default] | [<level>] [interval <secs>]]
[no] access-list <id> [line <line-num>] deny|permit icmp
      <sip> <smask> | interface <if_name> | object-group <network_obj_grp_id>
      <dip> <dmask> | interface <if_name> | object-group <network_obj_grp_id>
      [<icmp_type> | object-group <icmp_type_obj_grp_id>]
      [log [disable|default] | [<level>] [interval <secs>]]
Restricted ACLs for route-map use:
[no] access-list <id> deny|permit {any | <prefix> <mask> | host <address>}
Command failed
0
 
LVL 79

Accepted Solution

by:
lrmoore earned 500 total points
ID: 12437717


remove the first one:
   no access-list tsp_sales_splitTunnelAcl permit ip any any


My bad...

    access-list tsp_sales_splitTunnelAcl permit ip 192.168.1.0 255.255.255.0 192.168.11.0 255.255.255.0
                                                                 ^^
0
 

Author Comment

by:r270ba
ID: 12484256
worked like a charm!  thanks
0

Featured Post

Enabling OSINT in Activity Based Intelligence

Activity based intelligence (ABI) requires access to all available sources of data. Recorded Future allows analysts to observe structured data on the open, deep, and dark web.

Join & Write a Comment

Suggested Solutions

Hi All,  Recently I have installed and configured a Sonicwall NS220 in the network as a firewall and Internet access gateway. All was working fine until users started reporting that they cannot use the Cisco VPN client to connect to the customer'…
Data center, now-a-days, is referred as the home of all the advanced technologies. In-fact, most of the businesses are now establishing their entire organizational structure around the IT capabilities.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…

746 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now