Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Auto detecting PRI Master is slow

Posted on 2004-10-21
7
Medium Priority
?
1,754 Views
Last Modified: 2012-05-05
I have a PC that takes a long time (>1 minute) during the BIOS Phase "Auto detecting PRI master" Other PCs pass this stage almost instantly. There is only one device on the primary bus. BIOS is set to auto detect. Is there something I can do to speed up the boot process? When detected the system appears OK but bios just recognizes the device as an IDE device and does not identify the disk type as on other systems.
0
Comment
Question by:paulcronin
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
7 Comments
 
LVL 69

Expert Comment

by:Callandor
ID: 12371882
If it does this with other drives, I would reset the CMOS.  If that doesn't work, change the CMOS battery - it may be getting low.
0
 

Author Comment

by:paulcronin
ID: 12372253
The other devices including a slave hard disk are detected instantly after the PRI master is detected
0
 
LVL 69

Expert Comment

by:Callandor
ID: 12372521
You may have a problem disk connected.  Try swapping disks in to see if you can isolate it.
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 9

Expert Comment

by:tosh9iii
ID: 12373125
make sure the cables are in all the way, firmly
0
 
LVL 1

Accepted Solution

by:
alcantar06 earned 500 total points
ID: 12376851
I think the problem is with your cd unit.  

Do the following:  disconnect all but HDD. It should boot faster now.

make sure HDD´s jumpers are set to Master (see jumper configuration, most probably printed on top of HD.)

if not, try playing around with jumper settings (Master, Slave, Cable Select)

Ok now connect everything back again but (if there is space) try to leave HDD alone in IDE1 and change everything else to secondary ide IDE2.

Last if all else failed: go into cmos config, look for an option that is something like IDE HDD detect.  Do that. Now (if ok) in main config view HDD should be set from AUTO to something else (LBA 40gb CSH etc etc).
If no auto detect option then click enter directly on the main conf. screen, on top of HDD where it says auto detect.  It should "auto detect" it and  provide correct setting.

Good Luck!
0
 
LVL 7

Expert Comment

by:waffleironhead
ID: 12380542
you could manually set the drive parameters into the system, but as this seems to me to be a function of a failing harddrive
this will only bypass the real problem,

try to run a disk healt utility on the drive and see if it passes the tests
they are available from the hd makers website

waffle
0
 

Author Comment

by:paulcronin
ID: 12382230
Taking the advice from alcantar06 I disconnected the slave CD ROM on IDE1 and the system booted immediately. I then connected the removed CD ROM to IDE2 with the DVD, set them both to cable select and all is now well. Thanks a lot!
0

Featured Post

Tech or Treat! - Giveaway

Submit an article about your scariest tech experience—and the solution—and you’ll be automatically entered to win one of 4 fantastic tech gadgets.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

No matter the version of Windows you are using, you may have some problems with Windows Search running too slow or possibly not running at all. Before jumping into how you can solve this issue, just know there are many other viable alternative deskt…
I use more than 1 computer in my office for various reasons. Multiple keyboards and mice take up more than just extra space, they make working a little more complicated. Using one mouse and keyboard for all of my computers makes life easier. This co…
Finding and deleting duplicate (picture) files can be a time consuming task. My wife and I, our three kids and their families all share one dilemma: Managing our pictures. Between desktops, laptops, phones, tablets, and cameras; over the last decade…
Want to learn how to record your desktop screen without having to use an outside camera. Click on this video and learn how to use the cool google extension called "Screencastify"! Step 1: Open a new google tab Step 2: Go to the left hand upper corn…
Suggested Courses

609 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question