Solved

PIX 506 blocking access to specific outside IP addresses

Posted on 2004-10-21
688 Views
Last Modified: 2010-04-09
We have a PIX 506. We are for testing purposes trying to either block whole IP ranges or subnets. Our PIX currently works well for what we need. In a few weeks or so we are going to need to start blocking websites that employees are visiting during work hours (browsing is allowed but is being abused)
My users are computer savy and have figured out how to bypass the W2K proxy server.

1. The first thing I tried was to block a users computer IP address from being able to access any IP addresses outside. This would force them to go through the proxy which is permitted to get  to the outside. I could not figure this out (I am in over my head :-) )

2. I am now trying to block whole ranges of IP addresses and would like to redirect the user to a default page e.g. google.com

Please take a look at my config and let me know where I am am going wrong. I have marked the areas in question with "--->"
Also if there are thing that I can do to streamline my config I would love to get ay pointers.

Thanks

Opti

-----------------------------------------------------------------

Running config

Building configuration...
: Saved
:
PIX Version 6.3(3)
interface ethernet0 10baset
interface ethernet1 10baset
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password 9kMLrOeFU.sbene6 encrypted
passwd 1wx2wOiaRQlEVJZQ encrypted
hostname ALI-pix
domain-name aintll.com
clock timezone CST -6
clock summer-time CDT recurring
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
---> name 10.10.10.56 wlee
name 209.66.88.11 xanga
name 10.10.10.69 gizmo
name 209.66.88.13 xangablock2
name 209.66.88.12 xanga3
name 209.66.88.59 xanga4
name 209.66.88.60 xanga5
name 10.10.10.16 julie
name 209.66.88.0 xang
name 216.239.0.0 google
access-list 100 permit ip 10.10.10.0 255.255.255.0 xang 255.255.255.0
access-list 100 permit tcp any any
access-list 100 permit icmp any any
access-list 100 permit tcp any host 205.158.82.66 eq 3389
---->access-list 100 deny ip host wlee any
---->access-list 100 deny tcp any google 255.255.0.0 eq www
access-list 120 permit ip 10.10.10.0 255.255.255.0 10.1.2.0 255.255.255.0
access-list inside_cryptomap_dyn_20 permit ip any 10.1.2.0 255.255.255.0
pager lines 24
logging on
mtu outside 1500
mtu inside 1500
ip address outside 205.158.82.66 255.255.255.224
ip address inside 10.10.10.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool ippool 10.1.2.1-10.1.2.254
pdm location 10.10.10.0 255.255.255.0 inside
pdm location 10.1.20.0 255.255.255.255 inside
pdm location julie 255.255.255.255 inside
pdm location 10.10.10.20 255.255.255.255 inside
pdm location 10.10.10.0 255.255.255.0 outside
pdm location 10.10.10.3 255.255.255.255 inside
pdm location 10.10.10.88 255.255.255.255 inside
pdm location 216.239.37.99 255.255.255.255 inside
pdm location wlee 255.255.255.255 inside
pdm location wlee 255.255.255.255 outside
pdm location gizmo 255.255.255.255 inside
pdm location xanga 255.255.255.255 inside
pdm location xang 255.255.255.0 inside
pdm location xangablock2 255.255.255.255 inside
pdm location xanga3 255.255.255.255 inside
pdm location xanga4 255.255.255.255 inside
pdm location xanga5 255.255.255.255 inside
pdm location julie 255.255.255.255 outside
pdm location google 255.255.0.0 inside
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list 120
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) tcp interface 3389 10.10.10.20 3389 netmask 255.255.255.255 0 0
static (inside,outside) google google netmask 255.255.0.0 0 0
access-group 100 in interface outside
route outside 0.0.0.0 0.0.0.0 205.158.82.65 1
route outside wlee 255.255.255.255 205.158.82.65 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
http server enable
http julie 255.255.255.255 inside
http 10.10.10.0 255.255.255.0 inside
http 10.10.10.3 255.255.255.255 inside
http 10.10.10.88 255.255.255.255 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
tftp-server inside 10.10.10.70 /tftp-root
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set myset esp-des esp-md5-hmac
crypto dynamic-map dynmap 10 set transform-set myset
crypto dynamic-map inside_dyn_map 20 match address inside_cryptomap_dyn_20
crypto dynamic-map inside_dyn_map 20 set transform-set myset
crypto map mymap 10 ipsec-isakmp dynamic dynmap
crypto map mymap interface outside
crypto map inside_map 65535 ipsec-isakmp dynamic inside_dyn_map
crypto map inside_map interface inside
isakmp enable outside
isakmp identity address
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption des
isakmp policy 10 hash md5
isakmp policy 10 group 2
isakmp policy 10 lifetime 65534
vpngroup vpn3000 address-pool ippool
vpngroup vpn3000 dns-server 206.173.119.72 207.155.183.72
vpngroup vpn3000 default-domain concentric.net
vpngroup vpn3000 idle-time 1800
vpngroup vpn3000 password ********
vpngroup vbumhira address-pool ippool
vpngroup vbumhira dns-server 206.173.119.72 207.155.183.72
vpngroup vbumhira default-domain concentric.net
vpngroup vbumhira idle-time 1800
vpngroup vbumhira password ********
telnet 10.1.2.0 255.255.255.0 outside
telnet 10.10.10.0 255.255.255.0 inside
telnet 10.1.20.0 255.255.255.255 inside
telnet timeout 5
ssh timeout 5
console timeout 0
terminal width 80
Cryptochecksum:33420a0694b2277b79aa8c2a8cb10280
: end
[OK]

0
Question by:optidigix
    5 Comments
     
    LVL 79

    Expert Comment

    by:lrmoore
    To prevent them from bypassing the proxy, simply add this :

      access-list inside_out permit ip host <proxy ip> any
      access-group inside_out in interface inside

    You might want to look at WebSense, N2H2, or iPrism for internet control.
    I think iPrism is the most cost-effective solution - http://www.stbernard.com/iprism
    http://www.websense.com
    http://www.n2h2.com

    0
     
    LVL 79

    Expert Comment

    by:lrmoore
    Or, if you just want to deny certain hosts:
     >name 10.10.10.56 wlee

    access-list inside_out deny ip host wlee any
    access-list inside_out permit ip any any
    access-group inside_out in interface inside

    0
     

    Author Comment

    by:optidigix
    Thank. I applied the config to deny certain inside_out to a specific ip address on our network. It works perfectly. I am weary about applying the config to prevent all machines from bypassing the proxy as there are a few that I have to have connected directly to the Internet (Linux boxes being used for security testing)

    Would the following config work (test blocking google)

    access-list inside_out deny ip host any 216.239.0.0 any
    access-list inside_out permit ip any any
    access-group inside_out in interface inside

    I am also going to look into iPrism. Thanks you very much.
    0
     
    LVL 79

    Accepted Solution

    by:
    ..Close...

    >access-list inside_out deny ip host any 216.239.0.0 any

    Should be:
        access-list inside_out deny ip any 216.239.0.0 255.255.0.0

    0
     

    Author Comment

    by:optidigix
    thank you very much
    0

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    Highfive Gives IT Their Time Back

    Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

    Wikipedia defines 'Script Kiddies' in this informal way: "In hacker culture, a script kiddie, occasionally script bunny, skiddie, script kitty, script-running juvenile (SRJ), or similar, is a derogatory term used to describe those who use scripts or…
    This article offers some helpful and general tips for safe browsing and online shopping. It offers simple and manageable procedures that help to ensure the safety of one's personal information and the security of any devices.
    In this seventh video of the Xpdf series, we discuss and demonstrate the PDFfonts utility, which lists all the fonts used in a PDF file. It does this via a command line interface, making it suitable for use in programs, scripts, batch files — any pl…
    Illustrator's Shape Builder tool will let you combine shapes visually and interactively. This video shows the Mac version, but the tool works the same way in Windows. To follow along with this video, you can draw your own shapes or download the file…

    884 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    18 Experts available now in Live!

    Get 1:1 Help Now