Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

qmail pop3d very slow response

Posted on 2004-10-21
4
Medium Priority
?
840 Views
Last Modified: 2008-01-09
Hi all,

I have installed a new Redhat Enterprise load on a dual p3 Xeon 1ghz with 1 mb ram (rambus) and it runs really well. I installed Qmail with vpopmail, squirrelmail, qmailadmin, etc. The installation was done as per Qmailrocks.org. Very informative procedural walk through. Ok, so here is the problem I am having: I can send mail via smtp out to the world just fine (until we get our mx record changed over a lot of providers like hotmail, etc think it is junk), but pop3 takes forever to login. If I do a telnet to locahost port 110, it takes a long time, if I connect from a lan host, it takes a long time. I can get messages when it eventually does log in, but it is unacceptably slow. To let you know, squirrelmail works perfectly, and is quite fast, but pop3 clients will time out or prompt for longer times.

If any of you could help me on this please, I need to get it resolved ASAP and have placed a point value on this question to reflect my urgency.

Let me know what info you need, and I'll post it.

Thanks,

R
0
Comment
Question by:raspis21
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
4 Comments
 
LVL 19

Accepted Solution

by:
Gabriel Orozco earned 750 total points
ID: 12371990
there are some options that can speed up your pop3 service for qmail.

I have my qmail like this:


/usr/local/bin/tcpserver -R -H 0 pop3 /var/qmail/bin/qmail-popup myserver.com /bin/checkpassword /var/qmail/bin/qmail-pop3d Maildir &


if these options do not help, please post your qmail.rc or the file you are using to start qmail just for checking
0
 

Author Comment

by:raspis21
ID: 12372233
Hi Redimido

exec tcpserver -l -H -R -v -c100 0 110 qmail-popup mail.myserver.com \
/home/vpopmail/bin/vchkpw qmail-pop3d Maildir 2>&1

that is from my /var/qmail/supervise/qmail-pop3d/run script

it is a fairly straight forward setup I think

R.

0
 
LVL 7

Assisted Solution

by:rugdog
rugdog earned 750 total points
ID: 12385632
it could be caused by name service misconfig. I have the following ideas:

1. check  your /etc/resolv.conf and verify the nameservers there are responding, and the domain is correct
2. check the "hosts" entry in /etc/nsswitch.conf ,should be something like
   hosts: files dns
but you could try
   hosts: files
3. are your running a DNS in the server? if so, check the in-addr config, i've seen similar behavior of delayed connections because of that.
0
 

Author Comment

by:raspis21
ID: 12468718
Hi again,

It seems I have resolved the problem, at least to my satisfaction. It was a problem with the $localname variable in tcpserver. Since our local domain is Active Directory (unfortunately) I was not able to get a local domain hostname to resolve. I had entered the -R option in the qmial/run file, but it was still trying to resolve a localhost name. For some reason, the localname was whacking out, and would not pass through the tcpserver. I added the option -l0 (that's a zero) to make the $localname variable 0. That did the trick. Although that resolved my problem, I had a new problem of what to do with this thread. I have decided to split it equally, not based on answer merit, but because both of you pointed me in the right directions, and you at least tried. Thanks so much for helping, and keep answering those questions. We are great resources to each other, and EE making a bit of money keeps it going.

R.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…
In response to a need for security and privacy, and to continue fostering an environment members can turn to for support, solutions, and education, Experts Exchange has created anonymous question capabilities. This new feature is available to our Pr…

604 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question