ArcserveIT 6.61

I am using ArcServeIT 6.61 on NT4 SP6a Compaq machine for daily backup. For some time now, it was backing up okay. Recently, we had a preventive maintainance and the server was shutdown. after it was brought up again, I noticed that the backup was running faster (which was the good thing). However, I noticed that it was completing faster because it was NOT performing a merging.   It used to take around 4 hours to perform a merging of 6 sessions (as shown in the Job Status window).

However, without this merging, I assume now I cannot 'Restore by Tree'. When I tried to restore by tree, (one particular file), I cannot select. When started up the restore manager, and clicking on say C:, the tree is not presented.

How can I revert the job to such that it will automatically do what its suppose to and enable me to restore individual files?

LVL 1
minitazAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

mrielfCommented:
Open your backup asx file
Open Backup->Options->Operation tab
Ensure that "Record Detailed Information" is selected at Database selection
0
dovidmichelCommented:
Check the ARCserve\temp directory for files. If no jobs are running the directory should be empty. If there are *.cat files, then the merge after backup is not taking place. If there are any *.tmp files then the conversion of the tmp to cat extention did not take place. During backup, data goes into the tmp file at the end of the session the tmp file is changed to cat and backed up as the last file in the session. tmp files can just be deleted. As for the remaining cat files run mergecat.exe and that should merge in all those files. After this the directory should be empty and hopefully the problem solved. If mergecat fails to merge in all the files as a test move them out so the temp directory is empty, and see if after the next backup it is empty again, which indicates the data is merged as it should be.
0
minitazAuthor Commented:
mrielf>> That setting is set as said and no change was done.

dovidmichel>> That was what was noticed recently, many .tmp and .cat files. I'll try to run the mergecat and also moving out any remaining files and test backup again.

0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

minitazAuthor Commented:
Good news> Managed to run mergecat successfully. and All .cat files are gone. leaving only some .tmp files. deleted them and scheduled a backup.

Bad news.> After scheduled backup, temp directory left with few .cat files and 1 .tmp file. The catalogs did not get merged automatically after the end of the job.
It used to be as I can see lines like "[CAT] Wednesday [ID: 1234, Session:1] is merged." after the backup is completed;

I was hoping dovidmichel's suggestion will bring that back, but it did not.

PS: I'll split some points to all those who comment when the issue is resolved. Please be paitient.



0
dovidmichelCommented:
Take a look in the activity log for that job to see if the job completed normally or was interupted. If need be put the Job Engine in debug mode and run another job.

In the mean time keep running mergecat and deleting any tmp files.
0
minitazAuthor Commented:
Thanks dovidmichel. Under the activity log, the job runs and ended smoothly, with the job rescheduled to the next day. (Running a daily schedule).. I'm putting the job engine to debug mode for the next run to confirm things.

I was just thinking, is it necessary to put 'mergecat' as a Post-Job command?
0
dovidmichelCommented:
No it is spauned automatically when the backup finishes.

It does not make sense that the job finished without error and yet there is a tmp file left in the directory.
Here is what happens:
Backup starts
session 1 begins
tmp file created
tmp file is filled with all database info
session 1 finishes
tmp file is changed to .cat
cat file is backed up to tape as the last file in the session
session 2 begins
tmp file created
and so on

So the existance of a tmp file in the directory means that the job did not finish normaly or the file was already there.
0
minitazAuthor Commented:
Hello dovidmichel. Thanks for the help. Here's what happened in the latest backup. The catalog files are still not merging on its own. However, the temp directory does not contain any .tmp files anymore, though all the .cat files are there. Perform a mergecat and after which, the temp folder clears up.

From what you described, the backup seems to be performing okay but arcserve seems to have 'forgotten' to perform the mergecat at the end of the job. Any idea?

Once again, I thank you for your patience.
0
dovidmichelCommented:
If the # of cat files = the # of sessions then we know that mergecat did not run at all, and the problem is in Task failing to span it. If there are less cat files then it ran started merging but stopped for some reaon. Either way 6.61 does not have a debug that will capture it.

Thinking about it, perhaps your suggestion of putting mergecat in as a post command is the best way to go. Yes it should not be needed but it will provide the same level of functionality and it will be a quick fix. I don't think it is worth reinstalling just for this.

So I say go ahead and add it in as a post command and be done with it.
0
minitazAuthor Commented:
the # of cat files does not = # of sessions. damm!!

after schedule backup, # cat file= # of sessions -1, with 1 .tmp file..

0
minitazAuthor Commented:
and even afetr merging by mergecat, the part when selecting restore file by tree is still not working.

<<However, without this merging, I assume now I cannot 'Restore by Tree'. When I tried to restore by tree, (one particular file), I cannot select. When started up the restore manager, and clicking on say C:, the tree is not presented.>>

this part is very important. any help?
0
dovidmichelCommented:
Database corruption could be at the heart of it. Look in the ARCserve directory for dbmgr.exe it is a GUI utility for checking and repairing the database.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
minitazAuthor Commented:
ok. done that. database corrected.

though mergecat still don't run automatically, i guess its little point trying to troubleshoot it. will add in the mergecat either as a post job command or morning exercise for me... and proceed from there.

Thanks for all who contributed. accespting the answer from here.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Storage

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.