Solved

Access to only one PC through Router on XP Pro

Posted on 2004-10-22
233 Views
Last Modified: 2013-11-30
Hi everybody,

Hope you can help, it's driving me nuts.

I've set up a small home network using a Linksys 4 Port Router & 2 PCs running Win XP Pro. I can connect to the internet from either machine okay, & I setup both PCs using the Network Setup Wizard (I chose the "This PC connects to the net via a Network Hub" option) & I can see each machine on the Workgroup (MSHOME Network), I can access my 2nd PC fine, but when I double-click on the ICON to connect to the 1st PC from the 2nd, I recieve a message saying I don't have permission.

Also, when I check Network Places from my 1st PC, I can see my 2nd PC's Shared Files, but on the 2nd PC, I ONLY see it's files, the 1st PCs are not showing up.

Anyone know why I can access one machine fine, but be denied on the second?

Thanks in advance :)
0
Question by:Bdoing
    19 Comments
     
    LVL 3

    Assisted Solution

    by:cnewgaard
    You will need the exact same user account on both machine's.  Say you have an account named me with a password of letmein on one machine, both machines would have to have that account on them to be able to have permission to see each other.  
    0
     

    Author Comment

    by:Bdoing
    I see. I'll give it a wheeze & see what happens. I'll post & let u know if all is working. :)
    0
     
    LVL 8

    Assisted Solution

    by:holger12345
    Question: if "1" connects to "2" fine - what about the user/password for that? In case htey haven't the sam, they shouldn't connect - as they can connect, di they have the same user/pass ??

    In my opinion, the 1st PC isn't configured to let others see it's files.. i.e. XP-firewall enabled or the shares aren't open to all users
    0
     
    LVL 8

    Assisted Solution

    by:holger12345
    wow, i wrote some faults: htey = they and sam=same .. sorry ;-)
    0
     
    LVL 4

    Assisted Solution

    by:tmcguiness
    Try this on the first pc:

    control panel
    folder options
    view
    uncheck simple file sharing
    0
     
    LVL 4

    Expert Comment

    by:tmcguiness
    Please ignore my comment above... You'll be thinking I smoked my breakfast! :) (one of those days)

    Not that it isn't a good thing to do. It just isn't going to help your problem.
    0
     
    LVL 2

    Assisted Solution

    by:gdplusmore
    Hello;

    Try enabling Guest account on both units
    0
     

    Author Comment

    by:Bdoing
    Hi everyone & thanks for replying :)

    cnewgaard, the creation of the same accounts on both PC didn't help I'm afraid. I remember when my friend brought his laptop over once & we lanned up together, he managed to get net access from me in seconds, but it took us ages to get the file sharing to work. We didn't create any new accounts, but I did have to Enable some Services for it to work, shame I don't know which ones they are. I've checked them on both PCs & they are the same (Enabled, Disabled & Manual).

    holger12345, The usernames for each PC is different (no passwords on either). I think you might be along the right lines with my 1st PC isn't open to all users. How would I enable this?

    gdplusmore, I tried enabling Guest Accounts on both machines, rebooting & trying to connect, but I still have the same problem I'm afraid, but thanks to you all for trying :)

    Anyone have any other suggestions. My guess is either a Services thing, but I probably am wrong.
    0
     
    LVL 4

    Assisted Solution

    by:tmcguiness
    File & printer sharing is on machine 1?



    0
     

    Author Comment

    by:Bdoing
    Yep, File & Printer Sharing is on machine 1 & 2.
    0
     
    LVL 2

    Expert Comment

    by:johnrmorris
    You never answered holger12345 on the firewall issue. Right click on My Network Places and select Properties, Right click on Local Area Networking select Properties, Click on the Advanced tab and if there is a check mark in the "Internet Connection Firewall" area remove it for testing. Reboot and test access.

    If that doesn't work, or it was already un-checked, try right clicking on the folder you want to share and select sharing and Security. Click the radio button "Share this Folder" the default permissions should be "everyone"

    And it never hurts to do what tmcguiness suggested for simple file sharing. It does mess some things up when it is checked.
    0
     

    Author Comment

    by:Bdoing
    Sorry for not answering holger12345's second question. I've checked the Windows Firewall on both PCs & it's DISABLED. I've also tried to share folders on BOTH machines & I can only see them on one of them (the 2nd PC).

    I've also turned off Simple File Sharing on both PCs & still no joy.

    Sorry again for not answering your question holger12345.

    Everytime I click on the Workgroup icon for the 1st PC on the 2nd one, it comes up straightaway with "You do not have permission to access this server". Anyone know how I can grant access to the PC to access the other?
    0
     
    LVL 2

    Expert Comment

    by:johnrmorris
    Okay, I'm scratching my head.

    Are you SURE you don't have a third party firewall on that machine?? Sometimes Norton sticks one on.

    You might try renaming the workgroup on both machines.

    Post a list of the protocallx you have on each machine.
    0
     

    Author Comment

    by:Bdoing
    I have Norton Internet Security 2004 on both machines, & I've created rules on them to allow access to both machines.

    I've tried renaming the Workgroup using the Network ID Wizard (I used the DEFAULT profile for a Home Network (WORKGROUP)).

    As for Protocols for each connection, I have NETBEUI (was suggested before but still won't let me access PC 1), & the basic TCP/IP Internet Protocol.

    The other items used by each machine are:

    Client for MS Windows
    File & Print Sharing for MS Networks
    QoS Packet Scheduler

    I can see both machines in the Workgroup, & I can FULLY access PC2 from PC1, but when I try to access PC1 from PC2 it pops up with "Access Denied, you do not have permission to access this server".
    0
     
    LVL 2

    Expert Comment

    by:johnrmorris
    Special rules or not, for testing purposes disable the Norton firewall completely. It is possible identical rules may work differently on pcs that are setup differently.
    0
     

    Author Comment

    by:Bdoing
    I've disabled the Norton Firewall on both machines, & no luck. It's a puzzler. PC1 still can't be accessed from PC2.
    0
     
    LVL 2

    Accepted Solution

    by:
    The only thing I have left to try is redoing your networking. When you set it up, you could have picked a setup where one computer access the internet through another pc. Below is how I setup a pc with "Always on Internet"

    Right click My network Places, choose Properties
    Click on Create new Connection.
    Click Next
    Leave Connect to the Internet selected and click next
    Select Setup my Connection Manually and click next
    Select Connect with a Broadband connection that is always on and click next
    Click finish
    Right Click the original connection and select Disable (be sure the new connection is Enabled)

    This configuration ignores Bridges and a lot of other stuff you really do no need if you have cable or dsl

    If you already set things up this way, I'm at a loss as to what is causing the problem. You got (from the others above and me) about all the ideas I'd try. Perhaps you can back up all your data and reinstall the problem machine???? Seems severe, but maybe something is hosed in the Registry..... Good luck.
    0
     

    Author Comment

    by:Bdoing
    Thanks to all who submitted suggestions to fixing my frustrating Network problem. It hs been fixed.

    I took johnmorris' suggestion of re-formatting PC1. After re-installing XP Pro, disabling the XP-Firewall, creating rules for Norton IS 2004 on both PCs & running the Network Setup Wizard (using the Computer connects through a hub/router option), the network came online & I'm now able to transfer files from each machine & surf the net too.

    I accepted johnmorris' final suggestion as the Accepted Answer, but with no other option it was my last resort (a pain to do but it saves time & hair). I split the points with everyone who suggested possible fixes, johnmorris recieved half the points for he gave the most suggestions.

    I hope this will not offend anyone, but I thought it was the fairest thing to do for all your hard work in trying to help me fix my problem.

    Thank you all for your time & effort & being patient with me as I tried all your suggestions.

    Bdoing
    0
     
    LVL 2

    Expert Comment

    by:johnrmorris
    Glad it's fixed. Also glad you spread out the points as the other guys all gave you advice that would have fixed a less mangled pc...
    0

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    Learn The Basics of Ethical Hacking & Pen Testing

    Computer and network security is one of the fastest growing and most essential industries in technology, meaning companies will pay big bucks for ethical hackers. This is the perfect course to leap into this lucrative career, learning how to use ethical hacking to reveal ...

    The article explains the protocols and technology which is involved when two computers on different TCP/IP networks communicate with each other. In the diagram, a router is used to segregate two networks. The networks are 192.168.1.0/24 and 1…
    Configuring network clients can be a chore, especially if there are a large number of them or a lot of itinerant users.  DHCP dynamically manages this process, much to the relief of users and administrators alike!
    Viewers will learn how to properly install and use Secure Shell (SSH) to work on projects or homework remotely. Download Secure Shell: Follow basic installation instructions: Open Secure Shell and use "Quick Connect" to enter credentials includi…
    After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

    856 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    13 Experts available now in Live!

    Get 1:1 Help Now