?
Solved

PIX 506 easy question re: inside_out deny

Posted on 2004-10-22
7
Medium Priority
?
577 Views
Last Modified: 2013-11-16
1. Could anyone take a peek at my pix 506 config and tell me if I have an major flaws in it.
2. Also why do the denied hosts that I have marked still seem to be getting through to the outside?
3. Could you also show me how to block entire ranges of ip's from being access by internal ip's. (I have ISA server but am just expierimenting on the pix side of things)

Building configuration...
: Saved
:
PIX Version 6.3(3)
interface ethernet0 10baset
interface ethernet1 10baset
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password 9kMLrOeFU.sbene6 encrypted
passwd 1wx2wOiaRQlEVJZQ encrypted
hostname ALI-pix
domain-name aliciaintl.com
clock timezone CST -6
clock summer-time CDT recurring
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
name 10.10.10.56 wlee
name 10.10.10.69 gizmo
name 10.10.10.16 julie
name 216.239.0.0 googlee
access-list 100 permit tcp any any
access-list 100 permit icmp any any
access-list 100 permit tcp any host 205.158.**.** eq 3389
access-list 100 deny ip host wlee any
access-list 120 permit ip 10.10.10.0 255.255.255.0 10.1.2.0 255.255.255.0
access-list inside_cryptomap_dyn_20 permit ip any 10.1.2.0 255.255.255.0
access-list inside_out permit ip any any
>access-list inside_out deny ip host julie any
>access-list inside_out deny ip host 10.10.10.116 any
>access-list inside_out deny ip host 10.10.10.68 any
>access-list inside_out deny ip host 10.10.10.79 any
>access-list inside_out deny ip host 10.10.10.94 any
>access-list inside_out deny ip host 10.10.10.221 any
pager lines 24
logging on
mtu outside 1500
mtu inside 1500
ip address outside 205.158.**.** 255.255.255.224
ip address inside 10.10.10.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool ippool 10.1.2.1-10.1.2.254
pdm location 10.10.10.0 255.255.255.0 inside
pdm location 10.1.20.0 255.255.255.255 inside
pdm location julie 255.255.255.255 inside
pdm location 10.10.10.20 255.255.255.255 inside
pdm location 10.10.10.0 255.255.255.0 outside
pdm location 10.10.10.3 255.255.255.255 inside
pdm location 10.10.10.88 255.255.255.255 inside
pdm location wlee 255.255.255.255 inside
pdm location wlee 255.255.255.255 outside
pdm location gizmo 255.255.255.255 inside
pdm location julie 255.255.255.255 outside
pdm location googlee 255.255.0.0 outside
pdm location 10.10.10.68 255.255.255.255 inside
pdm location 10.10.10.79 255.255.255.255 inside
pdm location 10.10.10.94 255.255.255.255 inside
pdm location 10.10.10.116 255.255.255.255 inside
pdm location 10.10.10.221 255.255.255.255 inside
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list 120
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) tcp interface 3389 10.10.10.20 3389 netmask 255.255.255.255 0 0
access-group 100 in interface outside
access-group inside_out in interface inside
route outside 0.0.0.0 0.0.0.0 205.158.82.65 1
route outside wlee 255.255.255.255 205.158.82.65 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
http server enable
http julie 255.255.255.255 inside
http 10.10.10.0 255.255.255.0 inside
http 10.10.10.3 255.255.255.255 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
tftp-server inside julie /tftp-root
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set myset esp-des esp-md5-hmac
crypto dynamic-map dynmap 10 set transform-set myset
crypto dynamic-map inside_dyn_map 20 match address inside_cryptomap_dyn_20
crypto dynamic-map inside_dyn_map 20 set transform-set myset
crypto map mymap 10 ipsec-isakmp dynamic dynmap
crypto map mymap interface outside
crypto map inside_map 65535 ipsec-isakmp dynamic inside_dyn_map
crypto map inside_map interface inside
isakmp enable outside
isakmp identity address
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption des
isakmp policy 10 hash md5
isakmp policy 10 group 2
isakmp policy 10 lifetime 65534
vpngroup vpn3000 address-pool ippool
vpngroup vpn3000 dns-server 206.173.119.72 207.155.183.72
vpngroup vpn3000 default-domain concentric.net
vpngroup vpn3000 idle-time 1800
vpngroup vpn3000 password ********
vpngroup vbumhira address-pool ippool
vpngroup vbumhira dns-server 206.173.119.72 207.155.183.72
vpngroup vbumhira default-domain concentric.net
vpngroup vbumhira idle-time 1800
vpngroup vbumhira password ********
telnet 10.1.2.0 255.255.255.0 outside
telnet 10.10.10.0 255.255.255.0 inside
telnet 10.1.20.0 255.255.255.255 inside
telnet timeout 5
ssh timeout 5
console timeout 0
terminal width 80
Cryptochecksum:1d83dd7f731ab79efdc0db48f5c97707
: end
[OK]

0
Comment
Question by:optidigix
  • 4
  • 2
7 Comments
 
LVL 58

Accepted Solution

by:
Pete Long earned 150 total points
ID: 12382786
access-list inside_out permit ip any any

thats why your clients are getting out youve got ALL ports outbound open?
0
 
LVL 58

Expert Comment

by:Pete Long
ID: 12382794
and that is applied before the denies
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 12382877
Pete's right. You have to remember that the access-list is processed top-down. First line says permit, that's as far as it goes:

access-list inside_out permit ip any any  <=== move this
>access-list inside_out deny ip host julie any
>access-list inside_out deny ip host 10.10.10.116 any
>access-list inside_out deny ip host 10.10.10.68 any
>access-list inside_out deny ip host 10.10.10.79 any
>access-list inside_out deny ip host 10.10.10.94 any
>access-list inside_out deny ip host 10.10.10.221 any
access-list inside_out permit ip any any  <=== to here

Easy to do:
   no access-list inside_out permit ip any any
   access-list inside_out permit ip any any
0
KuppingerCole Reviews AlgoSec in Executive Report

Leading analyst firm, KuppingerCole reviews AlgoSec's Security Policy Management Solution, and the security challenges faced by companies today in their Executive View report.

 
LVL 58

Expert Comment

by:Pete Long
ID: 12382905
:)
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 12403421
Any progress? Are you still working on this? Do you need more information?
0
 

Author Comment

by:optidigix
ID: 12406642
Thanks you guys :-) I really appreciate everything. I have been running with this and having a lot of fun. The office was not laughing though when I screwed up lol although I though it was a laugh and a half. I am sure I will mess something up again so talk to you soon. Thanks again.

Opti
0
 
LVL 58

Expert Comment

by:Pete Long
ID: 12465726
ThanQ
0

Featured Post

[Webinar] Improve your customer journey

A positive customer journey is important in attracting and retaining business. To improve this experience, you can use Google Maps APIs to increase checkout conversions, boost user engagement, and optimize order fulfillment. Learn how in this webinar presented by Dito.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The DROP (Spamhaus Don't Route Or Peer List) is a small list of IP address ranges that have been stolen or hijacked from their rightful owners. The DROP list is not a DNS based list.  It is designed to be downloaded as a file, with primary intention…
This article offers some helpful and general tips for safe browsing and online shopping. It offers simple and manageable procedures that help to ensure the safety of one's personal information and the security of any devices.
When cloud platforms entered the scene, users and companies jumped on board to take advantage of the many benefits, like the ability to work and connect with company information from various locations. What many didn't foresee was the increased risk…
Watch the video to learn how one can deal with PST file corruption issue with an outstanding Kernel for Outlook PST Repair Tool easily. Using this tool, non-technical users can swiftly perform the repair process to restore their essential data witho…
Suggested Courses
Course of the Month4 days, 7 hours left to enroll

599 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question