Solved

Link laptop to PC via direct cable

Posted on 2004-10-22
1,089 Views
Last Modified: 2012-05-05
I have a laptop and a PC, both of which run W2k OS.
I bought a cable and want to link the 2 so I can browse files on one computer from the other.  I've never done this before, so please explain clearly.
The network connections are shown in the systray of both computers (@ 100Mbps) so I am pretty sure the physical connection is OK, but I cannot seem to browse from one to the other.

When I go into 'Computers Near Me' both computers are shown in the WorkGroup, but when I double click on the icon for the laptop (from the PC) it says the path is not accessible / file path not found.

Please help.
TIA
0
Question by:Sigh_Man
    34 Comments
     
    LVL 12

    Expert Comment

    by:guidway
    have you set up one of the drives for sharing on one of the computers? If not, right click on one of your hard drive letters and find the Sharing tab and enable sharing. If you do not see the Sharing tab then you probably need to enable MS file sharing under the network connection properties.

    hope this helps
    guid
    0
     
    LVL 1

    Author Comment

    by:Sigh_Man
    I have enabled sharing on both the PC and the laptop.
    0
     
    LVL 12

    Expert Comment

    by:guidway
    do you have a firewall enabled? If so, try disabling that.
    0
     
    LVL 1

    Author Comment

    by:Sigh_Man
    OK, I am trying to access the laptop's files from the PC.  I shut down Zone Alarm on the laptop, but still the same response - can't find the path.
    0
     
    LVL 12

    Expert Comment

    by:guidway
    Make sure you don't have the firewall running on your PC right now either. Once we figure this out we'll re-enable it. I just want to make sure there is no interference between 3rd party software.

    Since you can see the share names of the computers (it sounds anyway), let's try to ping the computers just to be sure they are really talking...

    go to Start->Run and type

    cmd

    now type:

    ping <share name of other computer>

    and see if it returns anything or errors out. Let me know the results.

    one other question:
    Did you use static IP addresses for each of the computers or are they configured to use DHCP to recognize each other?
    0
     
    LVL 12

    Expert Comment

    by:guidway
    sorry, not share names, I meant the names showing up under the "Computers Near Me" area.
    0
     
    LVL 3

    Expert Comment

    by:fadiramada
    About the physical connection, since these computers are directly connected, you are
    using a cross - over UTP cable correct?
    0
     
    LVL 3

    Expert Comment

    by:fadiramada
    if not, computers will not be able to connect
    0
     
    LVL 12

    Expert Comment

    by:guidway
    I didn't think they would even see each other at all if he wasn't using a cross-over cable, so I assumed he was using one. I could be wrong though. :)
    0
     
    LVL 1

    Author Comment

    by:Sigh_Man
    Ping worked fine.  0% loss.
    0
     
    LVL 12

    Accepted Solution

    by:
    good, that should rule out problems with connectivity. Let me ask this:

    when you enabled the share to your drive did you use the default share options that were automatically populated in the box (usually something like C$). If so, try creating a new share and calling it something different and then try to access it. See if that helps. (sometimes the default share does not work for some reason)
    0
     
    LVL 1

    Author Comment

    by:Sigh_Man
    Oh bloody hell.  It's working now.  I think the firewall must have been upsetting it maybe?  I've just accessed the PC from the laptop.  HOWEVER, once logged in, instead of seeing ALL folders etc in "PC", all I see is "Printers" and "Scheduled Tasks".  I need to be able to browse/see ALL files/folders.
    0
     
    LVL 1

    Author Comment

    by:Sigh_Man
    I'll try that...
    0
     
    LVL 1

    Author Comment

    by:Sigh_Man
    YES, created another Share and it has given me full access.  Superb.
    0
     
    LVL 1

    Author Comment

    by:Sigh_Man
    Will this enable me to program using Visual Studio on the laptop and access data held in MSDE on my PC?
    0
     
    LVL 3

    Expert Comment

    by:fadiramada
    To guidway ---> well done, good show!!!
    0
     
    LVL 12

    Expert Comment

    by:guidway
    >>Will this enable me to program using Visual Studio on the laptop and access data held in MSDE on my PC?<<

    To be honest, I never attempted that (I program in Visual Studio, but not across a network).  I believe it will be slow if you do it that way (unless you are creating a web-based application that needs a server and you are planning on using of the computers as the server), but again, I'm not sure what kind of affect that would have.
    0
     
    LVL 12

    Expert Comment

    by:guidway
    >>using of the computers as the server<<

    using *one* of the computers as the server

    fadiramada,

    thanks, that was a good idea you had also. computers are strange things sometimes. ;)
    0
     
    LVL 1

    Author Comment

    by:Sigh_Man
    Thanks all the same.  Brilliant response -- I was stuck big time if I couldn't fix this!!!  :D

    Thanks also fadiramada.
    0
     
    LVL 12

    Expert Comment

    by:guidway
    you might want to ask a question concerning that in the Programming topic area and see what the other experts say. I would love to help, but I really don't have much expertise on running software through a network, I just use my network to transfer files when testing my application.
    0
     
    LVL 1

    Author Comment

    by:Sigh_Man
    One more thing -- sorry -- if I re-enable Zone Alarm, this stops the sharing.  How can I configure ZoneAlarm to allow that connection so I am still protected on the internet?
    0
     
    LVL 12

    Expert Comment

    by:guidway
    p.s. you might want to re-enable the firewall now. Since we know it works with it disabled all you need to do to make it work with the firewall running is:

    (assuming you are using only ZoneAlarm)

    open the main application window for Zone alarm and click on the Firewall tab on the left, then at the top right you should see a tab called Zones. In here you need to add another zone and give it the name of the other computer that you want to share with so the firewall knows it is ok to access this computer (otherwise if it doesn't recognize it, it will block it). If you have any trouble with this, feel free to ask.

    guid
    0
     
    LVL 12

    Expert Comment

    by:guidway
    oops. I was already typing my response about ZoneAlarm before I realized you asked it. LOL :)
    0
     
    LVL 12

    Expert Comment

    by:guidway
    p.s. when you add the new zone, click on the Host/Site option and then just type in the name of the other computer that shows up under the "Comptuters Near Me" area and that should set it. If not, we might have to set a specific IP address (assuming you have one for each computer)
    0
     
    LVL 12

    Expert Comment

    by:guidway
    sorry for all the extra comments, I keep forgetting things to say...

     When you add the new zone it might add it as an Internet Zone (it should say it on the right of the newly added zone). If so, click on where it says "internet" and a dropdown should come up that will allow you to switch it to a "trusted" zone.

    hope this helps
    guid
    0
     
    LVL 1

    Author Comment

    by:Sigh_Man
    I can't seem to get Zone Alarm to accept this connection.

    I already have (in Zone Alarm):-

    WAN (PPP/Slip) Interface
    SiS NIC SISNIC

    both in internet zone.

    Do I need to add another Host, IP Address, IP Range or Subnet?
    0
     
    LVL 1

    Author Comment

    by:Sigh_Man
    Oops - same here - I'm asking already-answered points!!

    I will try and set it to a specific address?  If I use the address given by ipconfig, will this change each time I log on?  If so, will this be a problem for ZoneAlarm?
    0
     
    LVL 12

    Expert Comment

    by:guidway
    >>SiS NIC SISNIC<<

    is that your network card you are using to connect to the other computer? More than likely yes, so that needs to be set to "trusted". see if that helps.
    0
     
    LVL 1

    Author Comment

    by:Sigh_Man
    Yes, that works with the ipconfig address.  But will this change on each reboot?  ie will I have to re-do this ZoneAlarm permission every time I logon?
    0
     
    LVL 12

    Expert Comment

    by:guidway
    if you are not using a static ip address then don't attempt to set it to a an IP address in zone alarm otherwise it will change everytime you log on and zone alarm won't know. hmm... have you tried shutting down zone alarm and restarting it to see if maybe it needs to reset the settings to apply the new changes?
    0
     
    LVL 12

    Expert Comment

    by:guidway
    >>But will this change on each reboot?  ie will I have to re-do this ZoneAlarm permission every time I logon?<<

    If it set it based off the settings for your network card, then probably it will work fine. The best thing to do would be to reboot it and test it (if you can).
    0
     
    LVL 12

    Expert Comment

    by:guidway
    I use static IP addresses for my network (easier to know what computer is what after they are going, although they are more of a pain setting up). ZoneAlarm reads them in just fine. I'm not sure if it does DHCP the same way, but I'm pretty sure it will like whatever settings you put for your network card and keep those permanently.
    0
     
    LVL 1

    Author Comment

    by:Sigh_Man
    I've sorted it now.  Thanks for the extra advice!  :D

    Yes, that SiS... was my network card.  Zone Alarm automatically detected it after I removed it then restarted Zone Alarm.

    Thanks again.
    0
     
    LVL 12

    Expert Comment

    by:guidway
    excellent, glad it worked for you and thanks for the points! :)

    guid
    0

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    Course: JavaScript Coding - Massive 12-Part Bundle

    Regardless of your programming skill level, you'll go from basics to advanced concepts in a vast array of JavaScript subjects including Sammy.js, Agility.js, Ember.js, Node.js, jQuery, AJAX, Extjs, AngularJS, Knockout.js, and JSON.

    The DSL Parameters part of this article is valid and can be considered with any brand of internet router and modem (Dlink, 3com, Alcatel, Usrobotics, Parks), by accessing the configuration interface available by the manufacturer eg: http://10.1.1.1 …
    Let’s list some of the technologies that enable smooth teleworking. 
    Viewers will learn how to connect to a wireless network using the network security key. They will also learn how to access the IP address and DNS server for connections that must be done manually. After setting up a router, find the network security…
    After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

    931 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    18 Experts available now in Live!

    Get 1:1 Help Now