odbc.defaultlrl 4096 - How to increase the limit on characters

I'm working with MS SQL and PHP. When I make a call to a database for a <Long Text> field the page cuts the text off.

I know it has something to do with "odbc.defaultrl = 4096" in the php.ini file how do I get this to not cut off my text?

Thanks
neteleAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

minichickenCommented:
if you would like to set a larger value for odbc.defaultlrl, then try something like this at the top of your page.

ini_set ("odbc.defaultlrl", "16384");

Btw, I think you mistyped odbc.defaultrl, it should be odbc.defaultlrl.

regards
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
hernst42Commented:
Set that value to 0. So you should get as many characters as the long text contains.
You can do it by changing the php.ini (and reloading the webserver after that) or as minichicken suggested.

; Handling of LONG fields.  Returns number of bytes to variables.  0 means
; passthru.
odbc.defaultlrl = 0

0
neteleAuthor Commented:
Minichicken,

You wrote "try something like this at the top of your page." - do you mean the php page?

Thanks
0
Cloud Class® Course: CompTIA Healthcare IT Tech

This course will help prep you to earn the CompTIA Healthcare IT Technician certification showing that you have the knowledge and skills needed to succeed in installing, managing, and troubleshooting IT systems in medical and clinical settings.

hernst42Commented:
Yes, or do it just before you call the odb_exec
0
minichickenCommented:
Yep.... Thanks hernst42....
0
neteleAuthor Commented:
Just did that and it resolves nothing...
0
neteleAuthor Commented:
If I set it to a lower value I see that it works but setting it to a higher (even much higher 32000) doesn't make any difference.

Thanks
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
PHP

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.