• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 267
  • Last Modified:

Samba - backup from XP

Newbie
I have a Samba server FD2 now working after many days. My last problem is this.
When I use a backup system on the XP workstation to write to DVD, the backup software (BackupMyPC and Double Image) will not see the files on the Samba server.
I can copy files backwards and forwards with Explorer or Total Commander and the applications run fine.
Basically my Samba config looks like this:
Global
Workgroup = Newgroup
security = share
guest = ok
[Accounts]      ......            (just one of the folders)
comment = Accpac Plus
path = /home/accounts
browseable = yes
guest = ok
writeable = yes
force group = accounts ...... I also tried root
force user = root
create mask = 0777
directory mask = 0777

The above seems to be the only one I can get to work, so please forgive the use of root for group & user force.

I have a RH 7.3 from 2 years ago working with BackupMyPC. This is only my 2nd Linux install.
0
Alex Angus
Asked:
Alex Angus
  • 6
  • 4
  • 3
  • +1
1 Solution
 
owensleftfootCommented:
The easiest way around this would be to map a drive to your samba share - your backup software will then see this. You can do this from explorer or from the command prompt. To map your accounts share to the z: drive open a command prompt and use the command "net use z: \\samba-server\Accounts" (without the quotes). You will obviously have to change "samba-server" to the netbios name of your linux box. Then just include the z: drive in your backup.
0
 
hoonexpertCommented:
Map a samba drive on your Windows XP PC. Incase if you dont know how to map here's the tip. On the My Computer icon ->select and right click -> you should see Map Network Drive Option -> Click on it and u will see 2 options Drive and Folder --> let drive letter be any (u may change its logical letter) and in folder --> type \\<samba-server-name>\\Accounts -> Click reconnect at logon if u want to reconnect for all logins to windows XP. Now in ur explorer u will a logical drive (recently selected above). Thats it.

Regards,

Manish.
Baroda.
India.
0
 
Alex AngusDirectorAuthor Commented:
Already have mapped drive.
The mapped drive appears in the backup software, in my case L: drive is mapped to accounts foledr on Samba server, but when you click on that drive you would expect the files or sub-folders to appear on the RH side. However, nothing appears. Click on C: local drive to the XP PC and they appear, click on Samba L: drive, nothing appears.

I will try the NETBIOS name as I have not done that.

Someone from Double Image advised that rights are very critical in the backup software. But I already have root, so what more?

0
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

 
owensleftfootCommented:
I dont know what your problem is but a workaround would be to use a batch file to copy the files from the L: drive to the C: drive before backup. xcopy l:*.* c:\accounts would do it.
0
 
Alex AngusDirectorAuthor Commented:
What I have done for now is zip the files (1.6Gb) accross and then back up the zip.

I would however like to get Samba working correctly.
0
 
owensleftfootCommented:
If samba is working from explorer then I would say the problem is with your backup software, not samba.
0
 
Alex AngusDirectorAuthor Commented:
I also thought so, but:
1. It works on other servers, both Windows and Linux/Samba (RH 7.3)
2. The agents say it works.
3. I tried Double Image as I was told that works
4. Double Image does the same thing.

Makes me think it must be my setup. See original question with my Samba setup.

0
 
NirevCommented:
Were there any messages from samba within your logs when you tried to access the shared folder?
What version of samba are you running?
Try Upgrading your current version of samba and see if it helps.
Your config is ok.
0
 
Alex AngusDirectorAuthor Commented:
No messages in the logs.
Samba version 3, as used in latest Fedora 2 Core

Configured a new system yesterday but results the same.
0
 
hoonexpertCommented:
Run #iptables -F on the fedora server and try.

regards,

manish
baroda.
india.
0
 
Alex AngusDirectorAuthor Commented:
did the flush but no change.

In one of the manuals I read about a Samba option called descend, veto files and hide files. From what I gather the defaults of these should all be to show the files but maybe something has gone wrong. Don't know these options of Samba.

Also, I see the files in explorer, so why not in Backup applications.
0
 
hoonexpertCommented:
Problem is most probably with ur backup application then. So pls check if it supports virtual drive or not ?

regards,

manish.
0
 
Alex AngusDirectorAuthor Commented:
Works fine with Red Hat 7.3 and Samba version 2.
Also tried Double Image which supports Samba. Does the same thing.
0
 
hoonexpertCommented:
Simple if it works fine with 7.3 and not with fedora, it means that libraries files reqd are older version. Try contacting the vendor and inquire for support rpms reqd/used in the package. You can install the old rpm using -oldpkgs option of rpm. I had problem in one of the program which need older lib 4.1 and FD 2 has lib 4.2 so i kept both.

regards,

manish.
baroda.
india.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 6
  • 4
  • 3
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now