asp.net webservice proxy classs generation using wsdl for a webservice residing in an application protected by forms authentication

I have an asp.net webservice that resides on my webserver within a virtual directory that has a web.config file forcing forms authentication.  If I move my webservice to a nonprotected directory, then I can generate my proxy class with wsdl without a worry.  But when trying to execute wsdl when the webservice resides in the protected directory/application, then I get the following error :

Error: There was an error processing 'http://www.xxxx.com/asp.net/WebService.asmx?wsdl'.
  - The HTML document does not contain Web service discovery information.

I have tried specifying the username and passsword on the command line, but I get the same result.

What should I be doing here, changing my authentication method, or changing the way I generate and access my proxy class ?

Thanks in Advance.

MrMainAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

CJ_SCommented:
When creating a webservice, a single virtual directory is created. This should also be so on the production server. Personally I think that a webservice should NOT ever reside at the same location of a website. Problems like yours could arise if you do so.

If you create a seperate virtual directory you can also set other settings. For exam,ple you could make use of windows authentication or even create a new application pool (so it has it's own memory management and cannot interfere with the actual website).

CJ.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
MrMainAuthor Commented:
Thanks,

I have taken your suggestion on-board and have moved onto authenticating via the SoapHeader in a separate virtual directory.

Thanks
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
ASP.NET

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.