Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

redhat 7.2 cannot get internet connectivity

Posted on 2004-10-23
16
Medium Priority
?
224 Views
Last Modified: 2012-05-05
i don't know where to begin to solve this problem.

just installed rh 7.2, cannot get any internet connectivity

ethernet card is recognized

connect to router, dsl line

think has something to do with config files found in etc/sysconfig/networking/, but unsure

maybe something to do with firewall?  how do I configure firewall?

no services work - ping, http, etc

thanks

0
Comment
Question by:zanner
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 5
  • 3
  • +1
16 Comments
 
LVL 40

Expert Comment

by:jlevie
ID: 12390147
Are you using a DSL router or a DSL modem?

In the case of a DSL router are you using a static IP on the Linux system or  DHCP? And if DHCP does the ethernet interface get an IP (check with 'ifconfig eth0') and the correct default route (check with 'netstat -nr') and the correct DNS server(s) (check with 'cat /etc/resolv.conf'). The same checks would apply if you are using a static IP assignment.

In the case of a DSL modem the choices would be a static IP config, DHCP, or PPPoE. Without knowing which your provider requires it's hard to be of much help.

If you can provide more details about the configuration we should be able to help.
0
 

Author Comment

by:zanner
ID: 12390185
dsl modem with a router

the router assigns a static ip address, how do I check if RH is configured to use dhcp or static?
0
 
LVL 40

Expert Comment

by:jlevie
ID: 12390792
The router could only assign IP's via DHCP. The IP's it hands out could be dynamic or fixed (based on the MAC of the client). True static IP's are purely configured on the client and the router wouldn't have anything to do with them. You can tell what the RedHat box is set up for by running redhat-config-network.
0
Get your Conversational Ransomware Defense e‑book

This e-book gives you an insight into the ransomware threat and reviews the fundamentals of top-notch ransomware preparedness and recovery. To help you protect yourself and your organization. The initial infection may be inevitable, so the best protection is to be fully prepared.

 
LVL 38

Expert Comment

by:wesly_chen
ID: 12391770
Hi,

   Do you have any other Windows PC? If yes, then can your Windows PC connect to internet?
If your Windows can connect to internet (assume your Windows PC connect to the router), then problem is on your RH 7.2 box.

   Do "ifconfig -a" to see if the "eth0" interface is up or not.
If you don't see "eth0", then your NIC card driver didn't setup right. Go to the NIC card website to download the Linux driver and follow the instruction to set up the driver.
If you see eth0, then check the whether "UP" shows up after "eth0". If not, please do "ifconfig eht0 up" or "ifup eth0".

  Do "cat /etc/resolv.conf" will tell you your RH use DHCP or not. However, for the further network setting, /usr/bin/redhat-config-network can
give you a GUI for easily setup. If your Xwindows is not up, "netconfig" is the text mode network setting utility.

Good luck

Wesly
0
 

Author Comment

by:zanner
ID: 12394211
machine also running win2000 that has connectivity through the router

eth0 is recognized but is not up.  running ifup eth0 fails to determine ip information

using dhcp
0
 
LVL 38

Expert Comment

by:wesly_chen
ID: 12406117
The problem is on the eth0
Please use /usr/bin/redhat-config-network to configure your NIC again (save and apply the change)
then restart the network ( # service network restart).
Then run "ipconfig eth0" to see the eht0 is up or not.

If not, it may be the NIC driver issue. It might need to installed the driver.

Wesly

0
 
LVL 40

Expert Comment

by:jlevie
ID: 12406503
What NIC is in the machine (make/model)?

With some machines it helps to set the system BIOS to disable PnP mode, if you have that option.
0
 
LVL 38

Expert Comment

by:wesly_chen
ID: 12407092
NIC is Network Interface C? which is your network card.
Specially for gigabit network card, Linux doesn't have the driver built-in, in other word, not PnP.
As for RH7.2, which is quite old version of RedHat Linux, may not has the driver in the kernel.
In this case, you need to install the driver which download from the vendor's website.

The PnP application of RH 7.2 is called kudzu. You can run it as root manually and it is running at boot-up by default.

Wesly
0
 

Author Comment

by:zanner
ID: 12426732
i rpm'ed the kernel-source-2.4.7-10.i386.rpm off the redhat cd.

it has drivers for my card (sis900).

i loaded the module, still nothing.  

really need this up and running, please help

i increased point value for motivation :)
0
 
LVL 38

Expert Comment

by:wesly_chen
ID: 12426922
Could you provide the information of the following:
output of "ifconfig -a"
output of "/sbin/lsmod"

Wesly
0
 

Author Comment

by:zanner
ID: 12427769
lsmod

binfit_misc          1
autofs                0  autoclean [unused]
ipchains              0
printer               0  [unused]
usb_ohci            0 [unused]
usbcore              1
sis900                0
ext3                   2
jbd                     2

ifconfig

eth0

link encap: ethernet hwaddr 00:07:95:45:9A:49
broadcast   mtu:1500  metric:1
rx packets:1 errors:0 dropped: 0 overruns: 0 frame
tx packets:1 errors:0 dropped: 0 overruns: 0 carrier
collisions :0 txqueuelen:100
rx bytes: 86 (86.0 b) tx bytes: 0 (0.0 b)
interrupt 11  base addr 0xd00

lo

link encap: local loopback
inter addr 127.0.0.1 mask 255.0.0.0
up loopback running  mtu:16436 metric:1
rx packets:72 errors:0 dropped: 0 overruns: 0 frame
tx packets:72 errors:0 dropped: 0 overruns: 0 carrier
collisions :0 txqueuelen:100
rx bytes: 5060  (4.9  kb) tx bytes: 5060  (4.9  kb)interrupt 11  base addr 0xd00


0
 
LVL 38

Expert Comment

by:wesly_chen
ID: 12427832
Can you issue the following command as root:
# ifconfig eth0 <IP address you want> up

And tell me the output of result. If no result, run "ifconfig -a" again and the result.

Wesly
0
 

Author Comment

by:zanner
ID: 12427965
eth0

link encap: ethernet hwaddr 00:07:95:45:9A:49
inet addr 192.168.0.4 bcast 192.168.0.255 mask 255.255.255.0
rx packets:1 errors:0 dropped: 0 overruns: 0 frame
tx packets:0 errors:0 dropped: 0 overruns: 0 carrier
collisions :0 txqueuelen:100
rx bytes: 86 (86.0 b) tx bytes: 0 (0.0 b)
interrupt 11  base addr 0xd00

lo

link encap: local loopback
inter addr 127.0.0.1 mask 255.0.0.0
up loopback running  mtu:16436 metric:1
rx packets:72 errors:0 dropped: 0 overruns: 0 frame
tx packets:72 errors:0 dropped: 0 overruns: 0 carrier
collisions :0 txqueuelen:100
rx bytes: 5060  (4.9  kb) tx bytes: 5060  (4.9  kb)
0
 
LVL 38

Expert Comment

by:wesly_chen
ID: 12429091
Mmm, the eth0 is still not up. Any related error messages in /var/log/messages?
By the way, you can edit /etc/sysconfig/network-scripts/ifcfg-eth0 to assign the IP to eth0 so the IP address will assign to eth0 when system boot-up.
Did you try to use /usr/bin/redhat-config-network to config your network setting?

Wesly
0
 

Accepted Solution

by:
OzzMod earned 0 total points
ID: 13352427
Closed, no points refunded.
OzzMod
Community Support Moderator (Graveyard shift)
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…
In this video, Percona Solutions Engineer Barrett Chambers discusses some of the basic syntax differences between MySQL and MongoDB. To learn more check out our webinar on MongoDB administration for MySQL DBA: https://www.percona.com/resources/we…

610 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question