Solved

Pix to Pix problem

Posted on 2004-10-23
402 Views
Last Modified: 2013-11-16
Hello im setting up a pix to pix connection between my apartment and the office.

We have a pix 506 here at the office and i have a 501 at home.

The ip adress at the office is 213.184.206.164 and the ip adress at home is 213.234.122.31

 I used http://www.cisco.com/en/US/products/hw/vpndevc/ps2030/products_configuration_example09186a0080094761.shtml
as help but im not sure that i have done it right..

Here is the config at the first site the site with the 506 and 213.184.206.164.

PIX Version 6.3(3)
interface ethernet0 auto
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname aagotnes
domain-name ciscopix.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list 101 permit ip 192.168.1.0 255.255.255.0 10.10.1.0 255.255.255.0
pager lines 24
logging on
mtu outside 1500
mtu inside 1500
ip address outside 213.184.206.164 255.255.255.0
ip address inside 192.168.1.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
pdm location 192.168.1.10 255.255.255.255 inside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
route outside 0.0.0.0 0.0.0.0 213.184.206.1 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set chevelle esp-des esp-md5-hmac
crypto map transam 1 ipsec-isakmp
crypto map transam 1 set peer 213.234.122.31
crypto map transam 1 set transform-set chevelle
! Incomplete
crypto map transam interface outside
isakmp enable outside
isakmp key ******** address 213.234.122.31 netmask 255.255.255.255
isakmp identity address
isakmp policy 1 authentication pre-share
isakmp policy 1 encryption des
isakmp policy 1 hash md5
isakmp policy 1 group 1
isakmp policy 1 lifetime 1000
telnet 192.168.1.10 255.255.255.255 inside
telnet timeout 60
ssh timeout 5
console timeout 0
dhcpd address 192.168.1.2-192.168.1.254 inside
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
terminal width 80
Cryptochecksum:d999d7c6b5af17c13026944d74d71faf
: end


What is wrong?
0
Question by:daxa78
    4 Comments
     
    LVL 79

    Accepted Solution

    by:
    First item you need is a nat "zero" access-list to bypass nat through the VPN (assuming 10.10.1.0/24 is behind the 501)
        access-list nat_zero permit ip 192.168.1.0 255.255.255.0 10.10.1.0 255.255.255.0
        nat (iside) 0 access-list nat_zero

    crypto map transam 1 set transform-set chevelle
    ! Incomplete <== you are missing the "match" command
        crypto map transam 1 match address 101  <== add this
    crypto map transam interface outside   <== re-apply the crypto map

    Make sure you have complete mirror of these same configurations on the 501

    isakmp key ******** address 213.234.122.31 netmask 255.255.255.255  <== mirror on 501

    Make sure the policies are identical on each side, and match the transform-set

    >crypto ipsec transform-set chevelle esp-des esp-md5-hmac
                                                                ^^        ^^
    isakmp identity address                            |           |
    isakmp policy 1 authentication pre-share    |           |
    isakmp policy 1 encryption des  <======             |
    isakmp policy 1 hash md5   <===============
    isakmp policy 1 group 1
    isakmp policy 1 lifetime 1000

    0
     
    LVL 1

    Author Comment

    by:daxa78
    Oki, thanks for the input i put these lines into the 506

    access-list nat_zero permit ip 192.168.1.0 255.255.255.0 10.10.1.0 255.255.255.0
    nat (iside) 0 access-list nat_zero
    crypto map transam 1 match address 101
    crypto map transam interface outside

    Is this pix set u p right now?

    Thank som much for the help you are  providing. I must say that the intructions that cisco provides is
    not the best i have seen.

    Then my config looks like this:

    PIX Version 6.3(3)
    interface ethernet0 auto
    interface ethernet1 auto
    nameif ethernet0 outside security0
    nameif ethernet1 inside security100
    enable password 8Ry2YjIyt7RRXU24 encrypted
    passwd 2KFQnbNIdI.2KYOU encrypted
    hostname aagotnes
    domain-name ciscopix.com
    fixup protocol dns maximum-length 512
    fixup protocol ftp 21
    fixup protocol h323 h225 1720
    fixup protocol h323 ras 1718-1719
    fixup protocol http 80
    fixup protocol rsh 514
    fixup protocol rtsp 554
    fixup protocol sip 5060
    fixup protocol sip udp 5060
    fixup protocol skinny 2000
    fixup protocol smtp 25
    fixup protocol sqlnet 1521
    fixup protocol tftp 69
    names
    access-list 101 permit ip 192.168.1.0 255.255.255.0 10.10.1.0 255.255.255.0
    access-list nat_zero permit ip 192.168.1.0 255.255.255.0 10.10.1.0 255.255.255.0

    pager lines 24
    logging on
    mtu outside 1500
    mtu inside 1500
    ip address outside 213.184.206.164 255.255.255.0
    ip address inside 192.168.1.1 255.255.255.0
    ip audit info action alarm
    ip audit attack action alarm
    pdm location 192.168.1.10 255.255.255.255 inside
    pdm logging informational 100
    pdm history enable
    arp timeout 14400
    global (outside) 1 interface
    nat (inside) 0 access-list nat_zero
    nat (inside) 1 0.0.0.0 0.0.0.0 0 0
    route outside 0.0.0.0 0.0.0.0 213.184.206.1 1
    timeout xlate 0:05:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
    timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
    timeout uauth 0:05:00 absolute
    aaa-server TACACS+ protocol tacacs+
    aaa-server RADIUS protocol radius
    aaa-server LOCAL protocol local
    http server enable
    http 192.168.1.0 255.255.255.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server community public
    no snmp-server enable traps
    floodguard enable
    sysopt connection permit-ipsec
    crypto ipsec transform-set chevelle esp-des esp-md5-hmac
    crypto map transam 1 ipsec-isakmp
    crypto map transam 1 match address 101
    crypto map transam 1 set peer 213.234.122.31
    crypto map transam 1 set transform-set chevelle
    crypto map transam interface outside
    isakmp enable outside
    isakmp key ******** address 213.234.122.31 netmask 255.255.255.255
    isakmp identity address
    isakmp policy 1 authentication pre-share
    isakmp policy 1 encryption des
    isakmp policy 1 hash md5
    isakmp policy 1 group 1
    isakmp policy 1 lifetime 1000
    telnet 192.168.1.10 255.255.255.255 inside
    telnet timeout 60
    ssh timeout 5
    console timeout 0
    dhcpd address 192.168.1.2-192.168.1.254 inside
    dhcpd lease 3600
    dhcpd ping_timeout 750
    dhcpd auto_config outside
    terminal width 80
    Cryptochecksum:04b0064a748ed357b147acd8dbecd15a
    : end


    0
     
    LVL 1

    Author Comment

    by:daxa78
    this is my ip sec config

    aagotnes(config)# sh crypto ipsec sa


    interface: outside
        Crypto map tag: transam, local addr. 213.184.206.164

       local  ident (addr/mask/prot/port): (192.168.1.0/255.255.255.0/0/0)
       remote ident (addr/mask/prot/port): (10.10.1.0/255.255.255.0/0/0)
       current_peer: 213.234.122.31:0
         PERMIT, flags={origin_is_acl,}
        #pkts encaps: 0, #pkts encrypt: 0, #pkts digest 0
        #pkts decaps: 0, #pkts decrypt: 0, #pkts verify 0
        #pkts compressed: 0, #pkts decompressed: 0
        #pkts not compressed: 0, #pkts compr. failed: 0, #pkts decompress failed: 0
        #send errors 0, #recv errors 0

         local crypto endpt.: 213.184.206.164, remote crypto endpt.: 213.234.122.31
         path mtu 1500, ipsec overhead 0, media mtu 1500
         current outbound spi: 0

         inbound esp sas:


         inbound ah sas:


         inbound pcp sas:


         outbound esp sas:


         outbound ah sas:


         outbound pcp sas:
    0
     
    LVL 1

    Author Comment

    by:daxa78
    I got it thanks for the help you are the Pix wizard send me a message at garlid@nordicsol.no if you are looking for a job in norway :-)
    0

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    IT, Stop Being Called Into Every Meeting

    Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

    Suggested Solutions

    Title # Comments Views Activity
    Upgrade Core Switch 4 59
    Access-List and Distribute-List 5 39
    Cisco SG300 VLAN problem 8 27
    AnyConnect to 3rd vpn site 4 31
    To setup a SonicWALL for policy based routing to be used with the Websense Content Gateway there are several steps that need to be completed. Below is a rough guide for accomplishing this. One thing of note is this guide is intended to assist in the…
    Quality of Service (QoS) options are nearly endless when it comes to networks today. This article is merely one example of how it can be handled in a hub-n-spoke design using a 3-tier configuration.
    This video Micro Tutorial is the first in a two-part series that shows how to create and use custom scanning profiles in Nuance's PaperPort 14.5 (http://www.experts-exchange.com/articles/17490/). But the ability to create custom scanning profiles al…
    To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…

    856 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    13 Experts available now in Live!

    Get 1:1 Help Now