accelerators

I added accelerators  to my buttons in a winform app, however they don't show (the underline under the accelerator letter).  When i alt-tab to another app then alt-tab back to my app you can see them... Why cant i see them when the form first loads??

Im using Win XP and VS 2003 if that matters.
LVL 34
flavoAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
PaulHewsConnect With a Mentor Commented:
Right click on desktop, select properties.  Effects tab, uncheck "Hide keyboard navigation indicators until I press the Alt key."  This is a feature of Windows and has nothing to do with the setup of your accelerators in VS.
0
 
burakiewiczConnect With a Mentor Commented:
they don't show up until the alt button is pressed. Not sure how to get them to show up without hitting alt first
0
 
flavoAuthor Commented:
As much as it sickens me, i used

 SendKeys.Send("%")

at the end of my Form_Load events.

Works, but still very disapointed i had to resort to sendkeys....
0
Receive 1:1 tech help

Solve your biggest tech problems alongside global tech experts with 1:1 help.

 
PaulHewsCommented:
If it was me, I would just go with the Windows standard... If people want to see the accelerators, they either press tab or they uncheck the setting in the doothingy effects Tab.  It's better for your program to behave the same way as other programs that they use, than to try and buck the system (and use sendkeys....) for your personal preference.

0
 
flavoAuthor Commented:
Ill talk to the client and see what he wants..

Thanks Guys!

Dave
0
 
PaulHewsCommented:
Thanks for the points, flavo.  :)
0
 
flavoAuthor Commented:
Thank you!
0
All Courses

From novice to tech pro — start learning today.