Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

how to setup mail system with post fix

Posted on 2004-10-24
2
Medium Priority
?
210 Views
Last Modified: 2013-12-15
Hi,
I installed Fedora Core, [linux 2.4.22-1] with graphic Gnum and many of applications it provides at install time.

I could make postfix running, but I can't access the port.

my setup is like this.
a linksys router connects two computers to internet. One computer is XP and other one is the Linux server.

so on my small LAN, I can ssh to Linux from XP, but I can't telnet to it.
For ssh I use 192.168.1.101 and it works.
For telnet, telnet 192.168.1.101 smtp
or telnet 192.168.1.101 25
and I get error message, "can not open connection to the host on port 25."

I set the router to allow ports 25, 110 and 23.

I stopped iptables, not sure if that was the reason !!

Even I set up outlookexpress to access the stmp and pop3 and it give this error:
The connection to the server has failed. Account: '192.168.1.101', Server: ''192.168.1.101', Protocol: SMTP, Port: 25, Secure(SSL): No, Socket Error: 10061, Error Number: 0x800CCC0E
I wonder what I am missing! please help.

And other problem I have is, I changed the hostname to different name in /etc/sysconfig/network and after reboot, httpd and postfix did not start. so I had to change the host name back to localhost.localdomain !
how can I fix this?

thanks
0
Comment
Question by:Nav444
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
2 Comments
 
LVL 38

Accepted Solution

by:
wesly_chen earned 140 total points
ID: 12397069
>And other problem I have is, I changed the hostname to different name in /etc/sysconfig/network and after reboot, httpd and postfix did not start. >so I had to change the host name back to localhost.localdomain !
When you change the hostname of your machine, you need to change the httpd.conf and postfix setting to make those daemon recognize the FQDN.
By the way, please use redhat-config-network to change the host name and edit /etc/hosts to reflect the change.

For port 25, please check postfix documentation to make sure postfix is listening the port 25.

Regards,

Wesly
0
 

Author Comment

by:Nav444
ID: 13536614
Thanks
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Setting up Secure Ubuntu server on VMware 1.      Insert the Ubuntu Server distribution CD or attach the ISO of the CD which is in the “Datastore”. Note that it is important to install the x64 edition on servers, not the X86 editions. 2.      Power on th…
Join Greg Farro and Ethan Banks from Packet Pushers (http://packetpushers.net/podcast/podcasts/pq-show-93-smart-network-monitoring-paessler-sponsored/) and Greg Ross from Paessler (https://www.paessler.com/prtg) for a discussion about smart network …
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.
Suggested Courses

597 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question