Connecting dreamweaver MySQL database

I desire to create a web with dynamic functionality.  I have dreamweaver MX, MySQL server running with the db designed in MySQL control centre.  In the dreamweaver GUI I can not connect to the database I have created as I don't understand the connection string parameter requirements??? via SQL server connection.
This is required:
Persist Security Info=False;
Data Source=[serverName];
Initial Catalog=[databaseName];
User ID=[username];
Password=[password];
Is this correct?
Persist Security Info=False;
Data Source=[localhost];
Initial Catalog=[film];
User ID=[root];
Password=[];
??? I guess not as it isn't working to establish a connection allowing me to view the deveollped tables.  Can you assist?
At the moment I get the error message:
1) There is no testing server running on the server machine.
2) The testing server specified for this site does not mP TO THE HTTP://LOCALHOST/VISION/_MMsERVERsCRIPTS/mmhttpdb.ASP url.
Verify that the URL Prefix maps to the root of the site.
Can you assist?

  Initially the database panel is set to ASP.NET C# as requested, yet when I open a file the database document tile switches to ASP.NET VB.  I want to work in C#, how do I work to correct this also?
JarrodJohnAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

hhammashCommented:
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
nan1217Commented:
1.)  It looks like the path you are using to point to the database is local and it's not finding it there.  If it's located on a different server, then the path needs to represent that.
2.)  You mention you are using a SQL Server connection but a MySQL database.  SQL Server and MySQL are different - perhaps that's part of the problem as well. Refer to the following article on using Dreamweaver w/MySQL.  http://www.macromedia.com/support/dreamweaver/ts/documents/mysql_config.htm
0
JarrodJohnAuthor Commented:
Thankyou hhammash, the site you reccomended

http://paul.ecommerce.hct.ac.ae/tutorials/dwmx-php/dwmxphp.htm


 was very helpful..  But problem not yet solved for me can you help.  At step 23, I have no problems unitil I attempt to test the URL.  All files are held in the c/interpub/wwwroot/ (in a folder called) Vision.
When I test the URL I get this message:

DW can't use the prefix you entered to display live data. Please double check your site configuration pr click help for more info on how to correct this problem.  HTTP Error:12029

the URL I attempt to use is http://localhost/Vision/

Why is this not working?
0
Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

nan1217Commented:
1.)  Sometimes using "localhost" doesn't work.  Try using 127.0.0.1 instead.
2.)  Try setting up the "Vision" folder/path in IIS.
0
hhammashCommented:
I agree with nan1217

I usually use 127.0.0.1

Also,  have you created the virtual directory in IIS?

hhammash
0
JarrodJohnAuthor Commented:
Thankyou nan1217 & hhammash,
With the 127.0.0.1, you suggest I've tried a few times as  http://localhost/Vision/ doesn't cut it.
But like this  http://127.0.0.1/Vision/ doesn't work or 127.0.0.1 by itself doesn't work.  What is the full URL prefix for 127.0.0.1???  And please any suggestions on setting up the folder/path in IIS / creating the virtual directory in IIS?
0
nan1217Commented:
Your URL of http://127.0.0.1/Vision/ is the correct one to use.

To setup in IIS (and this assumes use of XP - modify instructions for another operating system)

Go to Start>Settings>Control Panel>Administrative Tools>Internet Information Services

Expand all the trees on the left until you see the branch that says "Default Web Site."  Right-click on the words "Default Web Site" and choose New>Virtual Directory.  Follow the wizard, naming the site what you wish (whatever you choose will be what you use to browse with so it would be http://127.0.0.1/whatevernameyouchoose/) and then choosing the directory where the files reside.

Browse to http://127.0.0.1/whatevernameyouchoose/ and see if that works.
0
JarrodJohnAuthor Commented:
OK much thank you as your help has been excellent.  Discovery is, don't waste time trying to get it together with an early verion of IIS.  Download a later version very necessary for good function.  So next time I know, I hope you have recieved 500 points with each comment you have made to assist me or is it set up so only the first response gets the 500??
I am sure I may resort to your assistance again but sincerely hope it isn't in an immediate future.  Nevertheless knowing the support is here if needed is bloody briliant.  Again, thank you
Jarrod Out
0
nan1217Commented:
JarrodJohn,
You need to award the points with a grade.  If you aware a grade of A, the accepted answer gets 4 times the amount of points.
0
nan1217Commented:
^^^Oh, and you can split the points between multiple users but too late for that as you have already accepted an answer.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Development

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.