Generic USB Hub fails to work under XP Pro SP1

This is a problem that has been annoying me for some time now...

These screenshot images are what the problem is..

I have tried to get the USB Hub to work as it is supposed to be a plug an play product with no drivers required - Win XP is ment to drive them.

Here is a list of some information:

1. This is the product:
This product has no drivers supplied- windows xp apparently has them.
2. I have XP SP1 installed as you can probably tell by the enhanced USB drivers installed.
3. I wont install SP2 coz I have experienced so many problems with it as well as a lot of my friends.
4. I have powered up the hub by a 2.3 - 3.0v DC power supply. Red power lights up.
5. Plugging it into any of my USB ports turns the green light on.
6  Both lights can be on simultaneously.
7. Although windows detects it as a Generic USB Hub and tries to install it , i am giving a dialog prompt installation wizard.
8. After many times of going round in circles it says there are problems with the device.
9 . I have uninstalled the hub in Safe Mode and rebooted back to normal mode. Still problems.
10.  All my USB ports have been tested and are fully operational - i have USB mouse, USB digital camera.
11. The BIOS is the most recent for the motherboard. Asrock
12. i have tested the product on my 1 of my friends computer and it instantly installs perfectly (Win XP Pro SP1.)

If your require any further informaion then please reply!

Any help is very much appreciated!
Who is Participating?
CallandorConnect With a Mentor Commented:
Do you have any settings in the BIOS that might need to be activated, in order for the USB controller to work?  My motherboard gives me the option to disable any number of I/O devices.  Check in device manager whether power-saving is enabled for the USB controllers.  Problems like this one are some of the hardest to troubleshoot, because some perfectly fine motherboards don't seem to have functioning ports - I know, because I have one myself.
sunray_2003Connect With a Mentor Commented:
Try this

open command prompt and give this
set devmgr_show_nonpresent_devices=1

then give this "devmgmt.msc"

Device manager should open.
Donot close the command prompt.
IN the device manager , go to view > show hidden devices.

Now you should be seeing all ghost devices under USB and other places.
Try uninstalling the USB ones pertaining to your USB product.
Restart the computer after removing all of them and then try plugging your USB device again to see if that would help..

randomronaldAuthor Commented:
Thanks for responding sunray...

I did exactly all what you advised.

There were 2 ghost USB Digital Cameras.

However I uninstalled them plus the Generic USB Hub, unplugged the Hub, restarted XP and upon booting up I plugged the hub back in.

Alas this has not worked bringing up yet again the following screen:

What is going on...?
WEBINAR: GDPR Implemented - Tips & Lessons Learned

Join the WatchGuard team on Thursday, March 29th as we recount some valuable lessons learned in weighing the needs of a business against the new regulatory environment, look ahead at the two months left before implementation, and help you understand the steps you can take today!

Lamont77Connect With a Mentor Commented:
Random ronald,

It might be worth while checking out the trust troubleshooting here ...

Also if it is a driver issue you should visiti this page: 
and see if downloading the drivers for that product fix the problem.

I have created a trust account and submitted your question to their experts. I should recieve an answer by the lastest 48 hours and then I will relay everything they suggest to you.
Do you know if that USB hub comes with a CD that has drivers. I am sure that company should atleast have it in their website.

If they do , unplug the USB hub , first install the drivers and then hook the USB device. I  have experienced similar situation working with a hardware in XP , in one the XP accepted fine and other it didnot..
randomronaldAuthor Commented:
I have went through the troubleshooting guide at the Trust website. No resolutions there.
There are no IRQ conflicts.

If you investigate further about the driver downloads you will find that there are none.

Windows is supposed to supply the Generic USB Hub drivers by defualt.

There is no cd with the package.

Windows 2003  no driver needed. Is supported by default by this version of Windows.  
 Windows XP  no driver needed. Is supported by default by this version of Windows.  
 Windows ME  no driver needed. Is supported by default by this version of Windows.  
 Windows 98  no driver needed. Is supported by default by this version of Windows.  
 Windows 95  no driver available    
 Windows 2000  no driver needed. Is supported by default by this version of Windows.  
 Windows NT 4  no driver available    
 MacOS 10.3  no driver needed. Is supported by default by this version of Apple Macintosh.  
 MacOS 10.2  no driver needed. Is supported by default by this version of Apple Macintosh.  
 MacOS 10.1  no driver needed. Is supported by default by this version of Apple Macintosh.  
 MacOS X  no driver available    
 MacOS 9.2.x  no driver needed. Is supported by default by this version of Apple Macintosh.  
 MacOS 9.0.x  no driver needed. Is supported by default by this version of Apple Macintosh.  
 MacOS 8.6  no driver needed. Is supported by default by this version of Apple Macintosh

Normally with installation files there are .inf files. There are no .inf files to intiate the Generic USB Hub at all that I can find anywhere.

As I will express, the product DOES work on another XP Pro SP1 machine with no xtra/3rd party software. The driver is installed automatic and quickly like a typical USB device should.
However I cannot get it to work on the target machine.

Thanks for your advice, please keep it coming :) --- Problem still unresolved though. :(

Please dont hesitate to ask for screenshots or information.
Let me think about this somemore .. Meanwhile , I would request callandor (my hardware guru) to come and see this..

Hang on

randomronaldAuthor Commented:
Here is a USB test by the program "usbready.exe"
and this is the result:

I have contacted callandor and whenever he has time would come here and check this one for you..
Meanwhile., tell one more thing

when you plugged in your USB hub , did XP by any chance gave a warning stating that ,  "some drivers may not work and hence continue installing the drivers anyway " ?
Did you say NO to that ?

randomronaldAuthor Commented:
There was no warning given.

I recognise the warning for non-digitally signed drivers on previous hardware installs.

I wish there was coz I would then choose "Install anyway" and it would work im sure.
randomronaldAuthor Commented:
I've activated all USB options in the BIOS. I can take photograph to show you if you desire not a problem.

This manual is for my motherboard which contains all the BIOS screens and information. Please feel free to browse and examine it.

Your power saving option advice in the USB controller was enabled, but i quickly untick it to disable.
Still no effect of being able to install hub:
CallandorConnect With a Mentor Commented:
From your screen capture, I see that you have a USB mouse that seems to be working.  The controller looks like it is identical to the problematic one, so can you swap connections and see what happens?
randomronaldAuthor Commented:
This page has 3 screenshots detailing your request:
CallandorConnect With a Mentor Commented:
Let me see if I understand what happened: the mouse was on one USB controller, and when you plugged it into the other, the appears on that controller, and works fine.  With nothing plugged into the other port, you are prompted for drivers to install, and it fails.

I am led to believe that your motherboard has a bad interaction with the WinXP USB drivers, not installing them correctly.  Did you have motherboard drivers for the chipset?  That is the only thing I can think of that might cause your USB to behave this way, apart from a USB controller problem itself (which would require replacing the motherboard or buying a PCI USB card to replace the controller).
randomronaldAuthor Commented:
No, i think your confused... sorry

All i did was have the original setup

Mouse using a rear USB port and the hub using a front port.

All i did was disconnect all then put the usb hub into the port at the rear where the mouse had been.:
ref :
screenshot 2

Then i plugged the mouse into the same front usb port where the hub was plugged in.
screenshot 3

Notice the difference in screenshot 1 and 3. As expected the roots have swapped with the devices in opposite ports.

I will now see if there is any new USB updates from Asrock on the main website and will download them anyway regardless and re-install them.

Would this effect the USB2.0 support? as only win xp sp1 (and onwards) supports usb2.0 drivers.
Asrock dont have usb2.0 stand-alone drivers but say you must get them from the sp1 update.
CallandorConnect With a Mentor Commented:
Ok, so the problem port moved with the USB hub, and the mouse is ok?  Did you try a different USB hub?

The motherboard updates I'm referring to are not for USB, but for the chipset on the board.  This controls all I/O functions, and may need to be updated.
randomronaldAuthor Commented:
The mouse works perfect on any port i choose.
I dont have a different USB hub to try. I do however have a virtually identical computer, but motherboard is differnent make. The hub works perfectly well: automatically installs itself and functions fine.

These are all the available downloads for my motherboard
What's that cpu driver for?  Did you install that?  This is looking more and more like an incompatibility problem between the hub and your motherboard, since both work well separately, but not together - that's why I suggested another hub.
randomronaldAuthor Commented:
can u believe its now working?
what did you do ?
randomronaldAuthor Commented:
all i did was a reboot, nothing changed at all, when xp came back up, i plugged the hub in for the final last time before calling it quits, and it installed instantly no problem.

But i will add, no popup appeared - normally u get the USB bubble thing telling u about new hardware and its installed ok. no messages, but the driver is installed and functions perfectly.

its all very mysterious and im not happy about not finding the cause. but of course im happy its working

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.