Solved

RedHat Linux 9 - Trouble with AMD

Posted on 2004-10-25
222 Views
Last Modified: 2013-12-16
I have a cluster of Linux machines running RedHat 9 (2.4.20)
All machines have their amd service configured so as all machines can access the others disks.
My problem is that at times the amd process takes up >50% cpu on ALL machines!!!
Does anyone have a clue?
0
Question by:shayb022800
    4 Comments
     
    LVL 38

    Expert Comment

    by:wesly_chen
    Hi,

       amd is the automount daemon. As my experience, amd doesn't work well under multiple heavy data transfer through (/net).
    So for the NFS server with frequenty data access, you better use hard mount (specify in /etc/fstab or mount in /etc/rc.d/rc.local ) so you can specify the mount option to tune the NFS performance.

       Cross NFS mounting is the CPU and network killer. Besides it is the trouble maker even though it is convenient by use of amd or autofs.

       Tuning NFS/amd/autofs is the job for Unix systems adminstrators..... ^_^

    Good luck,

    Wesly
    0
     

    Author Comment

    by:shayb022800
    Hi Wesly,
    Thanks for the reply. Althogh I personally am not a Unix Sys Admin, all you have said above is known to me. And yet, my Unix Sys Admins have trouble locating and solving the problem of AMD taking > 50% of the CPU.
    If I am not mistaken once the mount is established (automatically) minimal resources are needed as long as the mount is active.
    So again what could be the problem? what should I ask my Sys Admins to check/do?
    0
     
    LVL 38

    Accepted Solution

    by:
    Ok, amd will unmount the unactive mount point after it idles for 5 minutes (or 10 minutes ?).
    Change the setting to make it short (say 2 or 3 miuntes) So it will release the CPU resources quickly.

    My suggestion is that you shouldn't use amd.net (mount /net) and make a list of necessary nfs shared directory and hostname.
    So it can cut short of un-necessary mount points. Also, use options "async", "soft", and "noatime" on nfs client.

    I perfer autofs instead of amd. Besides, autofs4 support /net on Linux, too. I got rid of amd (I want to use /net) after I used
    autofs4.

    Good luck,

    Wesly
    0
     

    Author Comment

    by:shayb022800
    Wesly,
    I will pass this info to our sys admins and let you know how it goes.
    0

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    Cisco Complete Network Certification Training

    If you’re an IT engineer or technician, it's time you take your career to the next level. This elite training bundle is brimming with all of the information you need to learn to sit for Cisco CNNA, CCNP, and CCENT certification exams.

    Suggested Solutions

    I am a long time windows user and for me it is normal to have spaces in directory and file names. Changing to Linux I found myself frustrated when I moved my windows data over to my new Linux computer. The problem occurs when at the command line.…
    How many times have you wanted to quickly do the same thing to a list but found yourself typing it again and again? I first figured out a small time saver with the up arrow to recall the last command but that can only get you so far if you have a bi…
    Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
    Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…

    846 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    8 Experts available now in Live!

    Get 1:1 Help Now