Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win


Outgoing mail stuck in queue with response of "the remote server did not respond to a connection attempt" to any domain (Exch2k3)

Posted on 2004-10-25
Medium Priority
Last Modified: 2008-02-01
I'm currently running an Exchage Server 2003 w/ SP1 on a Win2K3 box.  I have no problems receiving email (pennnetworkconsulting.com is the domain).  However, I cannot send any outgoing mail regardless of the domain.  I have tried a large amount of domains for email tests and none go through.  All of these domains can be resolved fine (via nslookup) from the Exchange box, but they sit in the outgoing queue on retry with a "the remote server did not respond to a connection attempt" message.  Forcing the connection does not help.  I've done a dnsreport.com test on my domain without any errors.  The Exchange box sits behind a Netgear WGT624v2 router with all the appropriate ports being forwarded.  I can telnet into my exchange server from the outside world fine (used a remote terminal server).  I've been searching through other similar questions, but none have helped.  It does not appear to be a DNS issue--I'm running DNS on the exchange box with it pointed to itself for resolution and have my ISP's DNS servers as forwarders.  I completly re-worked my entire setup over the weekend in hopes to resolve the issue--but alas, no dice.  Any ideas are greatly appreciated, I'm at the end of my rope here.  I have a feeling that it's something simple and I just need another pair of eyes to look at it.  Thanks!

Question by:rmccune218
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 6

Expert Comment

ID: 12403697
use "set vc" ... before Querying for MX, under NSLookup, to force it to make TCP Queries

Test SMTP Communication with any problemetic Domain ... and see if dropping a message manually works or not

Turn on Diagnostics logging on Transport
Enable NCSA Logging on SMTP Virtual Server

And My Favourite any 3rd Party Products ... AntiVirus/AntiSpam?


Author Comment

ID: 12403899
Thanks for the response.  Will try the above suggestions and let you know the results.  As for 3rd party--nothing...it's a fresh install and I havn't reached that point yet.

Author Comment

ID: 12404061

Used set vc command--getting valid resolution for problematic domains.  Will try the article you suggested when I can get through to the MS site.  

NCSA on the virtual server is on:

#Software: Microsoft Internet Information Services 6.0
#Version: 1.0
#Date: 2004-10-25 16:19:39
#Fields: time c-ip cs-method cs-uri-stem sc-status
16:19:39 QUIT - 240
16:24:15 HELO - 250
16:24:15 MAIL - 250
16:24:15 RCPT - 250
16:24:15 RCPT - 250
16:24:15 RCPT - 550
16:24:15 RCPT - 550
16:24:15 QUIT - 240
#Software: Microsoft Internet Information Services 6.0
#Version: 1.0
#Date: 2004-10-25 16:28:37
#Fields: time c-ip cs-method cs-uri-stem sc-status
16:28:37 EHLO - 250
16:28:37 MAIL - 250
16:28:37 RCPT - 250
16:28:37 DATA - 250
16:28:37 QUIT - 240
16:30:45 HELO - 250
16:30:45 MAIL - 250
16:30:45 RCPT - 250
16:30:45 DATA - 250
16:30:45 QUIT - 240
16:31:42 EHLO - 250
16:31:42 MAIL - 250
16:31:42 RCPT - 250
16:31:42 DATA - 250
16:31:42 QUIT - 240
16:35:19 EHLO - 250
16:35:19 MAIL - 250
16:35:19 RCPT - 250
16:35:19 DATA - 250
16:35:19 QUIT - 240
16:40:13 EHLO - 250
16:40:13 MAIL - 250
16:40:13 RCPT - 250
16:40:13 DATA - 250
16:40:13 QUIT - 240
16:41:19 HELO - 250
16:41:19 MAIL - 250
16:41:19 RCPT - 250
16:41:19 RCPT - 250
16:41:19 RCPT - 550
16:41:19 RCPT - 550
16:41:19 QUIT - 240
17:05:18 HELO - 250
17:05:18 MAIL - 250
17:05:18 RCPT - 250
17:05:18 DATA - 250
17:05:18 QUIT - 240
18:07:01 EHLO - 250
18:07:01 MAIL - 250
18:07:01 RCPT - 250
18:07:01 DATA - 250
18:07:06 QUIT - 240
19:14:32 EHLO - 250
19:14:32 MAIL - 250
19:14:32 RCPT - 250
19:14:32 DATA - 250
19:14:32 QUIT - 240
19:22:10 EHLO - 250
19:22:10 MAIL - 250
19:22:10 RCPT - 250
19:22:10 DATA - 250
19:22:10 QUIT - 240

Could you explain what you mean by the diagnostics logging?

Are your AD admin tools letting you down?

Managing Active Directory can get complicated.  Often, the native tools for managing AD are just not up to the task.  The largest Active Directory installations in the world have relied on one tool to manage their day-to-day administration tasks: Hyena. Start your trial today.


Author Comment

ID: 12404116
MS must have removed the article...couldn't find it.

Expert Comment

ID: 12404336
Check this Article for SMTP Communication

this log doesn't look like NCSA ... this I guess is W3 format

Author Comment

ID: 12404519
Worked through the article and it queued my test message.  Received the message fine.  Not sure what that tells me?

Expert Comment

ID: 12404560
can you check with the recipient ... whether he received it or not !!!

Author Comment

ID: 12404596
actually I sent an email to myself (duh, my bad)
when I try it with a valid recipient other than myself, I get "unable to relay for user@domain.com" and I cannot go further, regardless of the recipient I try.

Expert Comment

ID: 12405540
... ok ...

I think you are trying to telnet to your own server ...

Do Telnet to external Domain Exchange Server ... if you have Yahoo account ...

get MX record for yahoo.com

'Telnet MX_IP_of_yahoo.com 25'
mail from: <your_company_email_address>
rcpt to: <your_yahoo_address>

and see if you are getting email on your yahoo

Do this all from your Exchange Server

Author Comment

ID: 12405833
Can't set the local echo on the yahoo mail server so it doen't allow me to see what I'm typing...

Expert Comment

ID: 12405851
try to set using -
set localecho

Author Comment

ID: 12406121
feel free to try my smtp server

yahoo will not allow my login

Accepted Solution

Maharajkp earned 2000 total points
ID: 12406472
I think I got your problem ....

This is what I am doing


Welcome to Microsoft Telnet Client

Escape Character is 'CTRL+]'

Microsoft Telnet> set localecho
Local echo on
Microsoft Telnet> open mx1.mail.yahoo.com 25

220 YSmtp mta141.mail.sc5.yahoo.com ESMTP service ready
250-SIZE 31981568

mail from: maharajkp@hotmail.com
501 Syntax error in parameters or arguments

mail from: <maharajkp@hotmail.com>
250 sender <maharajkp@hotmail.com> ok

rcpt to: <maharajkp@yahoo.com>
250 recipient <maharajkp@yahoo.com> ok

354 go ahead
TRest Message from Telnet
250 ok dirdel

Please NOTE ...  < ...@...> around Email Address


Featured Post

Tech or Treat! - Giveaway

Submit an article about your scariest tech experience—and the solution—and you’ll be automatically entered to win one of 4 fantastic tech gadgets.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Are you an Exchange administrator employed with an organization? And, have you encountered a corrupt Exchange database due to which you are not able to open its EDB file. This article will explain all the steps to repair corrupt Exchange database.
The core idea of this article is to make you acquainted with the best way in which you can export Exchange mailbox to PST format.
To show how to create a transport rule in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Rules tab.:  To cr…
A short tutorial showing how to set up an email signature in Outlook on the Web (previously known as OWA). For free email signatures designs, visit https://www.mail-signatures.com/articles/signature-templates/?sts=6651 If you want to manage em…

610 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question