Windows XP won't recognise Microsoft Sidewinder Gamepad

I run Windows XP Pro on a AMD 1800+, 512Mb RAM, with Creative SoundBlaster Live! Value soundcard with gameport, and NVidia GeForce4 MX440 Graphics card.
I had XP Pro before and my MS Sidewinder Gamepad worked perfectly. I had a problem which meant re-installing XP Pro, and a few MS updates later (I don't have SP2!) & autodetect detects the gamepad as "Microsoft SideWinder 3D Pro" and shows "not connected" when it is!. I remove this, try again, install different soundcard drivers, etc, and finally get "Microsoft SideWinder gamepad" and shows as connected. The game will work, but keep stalling & when I quit game & check in "gaming devices", I see the 3D Pro has returned & says not connected again.

This is very frustrating, as this has worked perfectly for a long time before with XP Pro, and on the same machine with the same spec, so this must be some sort of software conflict or problem, or a MS update that has changed things. Please can anybody help me?

Peter (UK)
peter-parkerAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
Wojciech DudaConnect With a Mentor Commented:
Try to update your DirectX to version 9.0c if you have not done this yet.

Similar problem with solution but not the correct one:
http://www.kbalertz.com/kb_842957.aspx

Also I would check the game port driver and settings thoroughly, could be there is something wrong with it.
0
 
HJohnsonCommented:
On the microsoft website, they only support windows 95/98 with the Sidewinder series of controllers.  No updated drivers exists for Windows XP.  It probably worked only by the grace of God.

You could try using just a standard "4 button 3 (or 2) axis" joystick or gamepad and see if it works.  I've done this successfully with a Sidewinder 3d Pro joystick in XP.

I assume that this is a gameport device only and not a USB.

Also, try checking on www.driverguide.com for a community driver for XP.  I took a look around, but couldn't find anything.

0
 
kmorris1186Connect With a Mentor Commented:
I also have a MS Sidewinder gamepad.  One thing to check is to make sure that the green light is lit up on the game pad.  If it is not, press the MODE button and it should light up.  Now Windows should detect the hardware.

I have had my gamepad for over 6 years not and it is still chuging along.  As others have said, there are no updated drivers for the gamepad.  Just used the one called "MS Sidewinder (auto detect)".  That driver works for my Gamepad and my Precision Pro (no FF).  You are not trying to daisy chain any other gamepads off of the same one?  The daisy chaining only works with MS Gamepads.  Any other joysticks, and you will have to turn off the gamepad (the mode button) for the 2nd joystick to work.
0
 
KOTORCommented:
You said that you installed different soundcard drivers, so this may not be much help but the Creative Soundblaster Live had problems with it's Gameport and required installing drivers/gamepads etc in a certain order (had the same problem with a standard 2 button joystick).

I don't have the link offhand but I'll have a look. You could try a quick search on the creative website for it, in the soundcard FAQs section.
0
 
06vsantiCommented:
You can go to Control Planel and then to Gaming Options.  Make sure it apperas there, if not, click on refresh, if it is still not there, you will have to add it manually.
0
All Courses

From novice to tech pro — start learning today.