Solved

configure  cisco router

Posted on 2004-10-25
33,405 Views
Last Modified: 2011-08-18
Hey all router gurus.

I have got this cisco 3660 router. It has got 6 T1 slots.. I need to configure one of them.
What I am planning to do is to configure that T1 interface (giving static IP address) and then connect a T1 line from it to an Adtran netvanta router (1224R) . Then  a computer would be connected to that  Adtran.

As of now , I would like to configure one T1 interface of the cisco.. Possibly giving an ip address 172.16.80.10..

I would like to know the instructions to do the same. I would be telneting to the router ..

Thanks.
SR
0
Question by:sunray_2003
    74 Comments
     
    LVL 79

    Expert Comment

    by:lrmoore
    can you post your existing config (just the controller and serial interfaces)
    It's pretty simple:
      router(config)#controller t1 4/2
      router(config)#channel-group 1 timeslots 1-24
      router(config)#no shut
      router(config)#interface serial 4/2:1    <== controller 4/2: channel-group 1
      router(config-if)#no shut
      router(config-if)#ip address 172.16.80.10 255.255.255.0 <== apropriate mask
      router(config-if)#encapsulation ppp
      router(config-if)#exit
      router(config)#  

    What routing protocol are you using? you need to add this interface subnet to the networks list..
    0
     
    LVL 79

    Expert Comment

    by:lrmoore
    Do you need help with the Adtran side, too?
    0
     
    LVL 49

    Author Comment

    by:sunray_2003
    Thanks for asking Lrmoore. I have already configured that Adtran.

    Could you tell me more on what is the existing config you are asking ?

    Can you get that from my previous question. I am at home and donot have access to the router now.. but If we cannot get it from the other question , then I can give only tommorrow morning ..

    0
     
    LVL 49

    Author Comment

    by:sunray_2003
    Let me back with what I am trying to achieve by configuring this.. It will take me few more minutes to write up here... brb
    0
     
    LVL 79

    Expert Comment

    by:lrmoore
    Looks like we had the other post edited. If you can follow my first post, that's really about all there is to it. Just use the appropriate controller slot/port

    Need the part from the existing config, starting with 'router ?????'

    0
     
    LVL 49

    Author Comment

    by:sunray_2003
    We have this cisco router .. 6 T1 cards , basically 12 ports.
    We have 2 T1 cards already configured and working great.. Thanks to your help on fixing one of those ..

    So the connection from one of the Cards is


    CISCO router (T1 card ) <--------------TI line -------------> Smart Jack (Our location)  <---------------T1 line ------------->
    Smart Jack (remote location)  < ----------T1 cable ---------> Adtran router <-------- Cross-Over cable ---------> Polycom video equipment..  

    The above setup works great..

    Now, I have this Adtran router (different one , ofcourse) which I had configured.. Instead of going to the remote location to test it , I want to test it in my location itself..

    So what I plan to do is as follows

    CISCO router (3rd T1 Card as 1/0,1/1,2/1 and 2/1 are already configured..)    <----------T1 cable ---------> Adtran router <----------- Cross-over cable  ---------> Polycom unit..


    Will the above work doing that by-passing those smart jacks etc ?

    SR
    0
     
    LVL 5

    Expert Comment

    by:AutoSponge
    I assume that the leased line T1 goes through a provider's frame network in which case you're using their clock (stratum 4).  Most of the Adtrans have a stratum 2 clock at best.  So, while it may "work" for design purposes, I wouldn't expect lengthy tests to be accurate as clock slips will create errors on the ckt.
    0
     
    LVL 79

    Expert Comment

    by:lrmoore
    You'll need to set the clock source on the 3660 for the link, and you'll need a T1 crossover cable crossover 1-4, 2-5 to set this up in the lab

    router(config)#controller t1
    router(config-if)#clock source internal
    router(config-if)#clock rate 154000

    0
     
    LVL 49

    Author Comment

    by:sunray_2003
    Lrmoore,

    So you are saying about the cross over cable between the T1 card in cisco router to the Wan port of the Adtran , is it ?

    So instead of a  T1 cable , I would be using a cross over because it is between 2 routers, Am i right ?
    0
     
    LVL 79

    Expert Comment

    by:lrmoore
    Yes, but a T1 crossover, not the same as a Ethernet crossover. Pin 1 crosses to pin 4, pin 2 crosses to pin 5..
    Easy way to make one is to snip one end off a cat5 cable, swap the blue and orange pair in a new end..
    0
     
    LVL 49

    Author Comment

    by:sunray_2003
    OK Thanks.. I would have to work on it tommorrow and see and will post you back if I am successful
    0
     
    LVL 79

    Expert Comment

    by:lrmoore
    OK. I'll be away all morning tomorrow  (going to a cisco systems new product seminar)...
    0
     
    LVL 49

    Author Comment

    by:sunray_2003
    Is that seminar in NC ?  
    0
     
    LVL 79

    Expert Comment

    by:lrmoore
    No. In Birmingham, AL..
    0
     
    LVL 49

    Author Comment

    by:sunray_2003
    Curious to know if You got my emails ..  
    0
     
    LVL 79

    Expert Comment

    by:lrmoore
    Probably not. I've got a filter on this account. With few exceptions, anything NOT from EE goes straight to deleted folder..I don't usually look at them. I'll keep my eye out, though..


    0
     
    LVL 49

    Author Comment

    by:sunray_2003
    LOL !!. Probably , you missed 3 or 4 of my emails then.. I replied to the email that you sent me few days back.. Nothing important tho..
    0
     
    LVL 49

    Author Comment

    by:sunray_2003
    Lrmoore,

    Just made the T1 crossover cable..

    Instead of configuring the new interface in the CISCO , I am using the already configured interface since I am doing the testing..

    I connect the T1 cross over from CISCO to Adtran.. Light comes up fine in CISCO and NO alarms.
    Now in the Adtran router , I see the WAN light going green.. Looks good.
    I connect a patch cable from one of the 24 ports of the Adtran to my computer.  

    Can ping my computer (just loopback)
    Can ping the ethernet port of Adtran
    Can ping the WAN port of the Adtran..

    That is it.. I cannot ping the Cisco router..

    Now , what I would like to know is should I be doing these config changes inside the CISCO router

    *******
    router(config)#controller t1
    router(config-if)#clock source internal
    router(config-if)#clock rate 154000
    ********
    even to make the connection between CIsco and Adtran..

    I have got a spare Adtran , configured it and still no go.. I wish I had one of those 3205 Netvanta .. I donot have it ..
    This router/switch never has worked so far.. Confirmed with the Adtran customer support that the configuration , I have got inside it is correct.. So no configuration problem..

    Now the problem could be the T1 cross cable I made.. See this is how I made..

    One end                                              Other end  

    1  White orange  <----------------------->  Blue                  1
    2  Orange           <----------------------->  White Blue         2

    4  Blue   <---------------------------------> White Orange      4
    5  White Blue  <---------------------------> Orange              5

    Is this fine ?

    SR
    0
     
    LVL 49

    Author Comment

    by:sunray_2003
    Now I go inside the Cisco router and do enable

    router(config)#  controller t1 2/1
    router(config-controller)# clock source internal
    router(config-controller)# clock rate 154000  (when I type this it is saying invalid character and goes back to prompt)

    Now when I say "show run", it gives

    *******************
    controller T1 2/0
     framing esf
     linecode b8zs
     channel-group 0 timeslots 1-24 speed 64
     description D1 T1
    !
    controller T1 2/1
     framing esf
     clock source internal
     linecode b8zs
     channel-group 1 timeslots 1-24 speed 64
     description D2 T1

    ********************

    As you can see above 2/0 is operational and I am working on 2/1..  

    I guess I cannot do the testing with Adtran because I have not set the clock rate

    and

    I cannot connect to the remote site as you can see there is this " clock source internal " added in the above configuration.
    How do I Undo that so that I can connect to remote site and what extra step I need to do to connect to adtran ?

    SR
    0
     
    LVL 79

    Expert Comment

    by:lrmoore
    Crossover cable looks OK.
    You need the clocking on one end. Suggest the Cisco side

    What speed options do you get with

    router(config)#  controller t1 2/1
    router(config-controller)# clock source internal
    router(config-controller)# clock rate ?   <== use the ? liberally to access the on-board help system..
    Set it for whatever is closest to full T1 rate..

    To undo the "clock source internal"

    router(config)#  controller t1 2/1
    router(config-controller)# clock source line

    Since this is the default setting, it may  not show up with "show config"


    0
     
    LVL 49

    Author Comment

    by:sunray_2003
    Ah.. I get it . I first on thursday when I get access to the router , I should do clock source line so that atleast I donot disturb the original connection to that remote site. Well at this moment there is no equipment there so fine..

    As Far as I remember , When I did "clock rate ? " , it said something equivalent to invalid command..

    Here is my previous configuration that I used in my previous question..

    ********
    command:  sh controller t1

    Result:

    T1 2/1 is up.
      Applique type is Channelized T1
      Cablelength is long gain36 0db
      Description: County T1
      No alarms detected.
      alarm-trigger is not set
      Framing is ESF, Line Code is B8ZS, Clock Source is Line.
      Data in current interval (477 seconds elapsed):
         0 Line Code Violations, 0 Path Code Violations
         0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
         0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
      Total Data (last 24 hours)
         0 Line Code Violations, 0 Path Code Violations,
         0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins,
         0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

    *****************************************************

    and going inside the web management of the router , I press
    SHOW INTERFACE

    and for 2/1:1

    Result:

    Serial2/1:1 is up, line protocol is down
      Hardware is DSX1
      Internet address is 172.16.89.1/28
      MTU 1500 bytes, BW 1536 Kbit, DLY 20000 usec,
         reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation PPP, loopback not set
      Keepalive set (10 sec)
      LCP Listen
      Closed: IPCP, CDPCP
      Last input 2d05h, output 00:00:18, output hang never
      Last clearing of "show interface" counters 7w3d
      Input queue: 0/75/72729070/0 (size/max/drops/flushes); Total output drops: 958664
      Queueing strategy: weighted fair
      Output queue: 0/1000/64/0 (size/max total/threshold/drops)
         Conversations  0/1/256 (active/max active/max total)
         Reserved Conversations 0/0 (allocated/max allocated)
         Available Bandwidth 1152 kilobits/sec
      5 minute input rate 0 bits/sec, 0 packets/sec
      5 minute output rate 0 bits/sec, 0 packets/sec
         797373 packets input, 11163222 bytes, 0 no buffer
         Received 0 broadcasts, 12351421 runts, 0 giants, 0 throttles
         72729514 input errors, 5325915 CRC, 67405929 frame, 0 overrun, 0 ignored, 23000961 abort
         1292220 packets output, 18091080 bytes, 0 underruns
         0 output errors, 0 collisions, 239490 interface resets
         0 output buffer failures, 0 output buffers swapped out
         176 carrier transitions
      Timeslot(s) Used:1-24, Transmitter delay is 0 flags

    ******************

    PS: Framing is ESF, Line Code is B8ZS, Clock Source is Line.   is because this is the previous configuration before I did this clock command so I guess it is still showing "Clock Source is Line"...

    0
     
    LVL 79

    Expert Comment

    by:lrmoore
    Looks like you have the exact same issue that you had before:

    Serial2/1:1 is up, line protocol is down  <==
      Hardware is DSX1
      Internet address is 172.16.89.1/28 <== What is the test Adtran set to? This must be the same subnet

    > Possibly giving an ip address 172.16.80.10.. <== is the Adtran set to .80.9 ?

    What is the LAN subnet on the Adtran? 172.16.81.0 /24 ?
    Add a route to it also:
       ip route 172.16.81.0 255.255.255.0 172.16.80.9
    0
     
    LVL 49

    Author Comment

    by:sunray_2003
    No Lrmoore. That line protocol is down because that configuration I tool before my previous issue was solved. It is up now..
    Sorry for the confusion..

    The IP address I am using is all 89.1.. THis is because as I said before I am using the same interface card which I used in my previous question ..

    Here are some info

    Adtran WAN port  172.16.89.14
    VLAN port : 172.16.89.17
    and subnet mask = 255.255.255.240 ..

    When I went inside the configuration  of the adtran  router , If I am not mistaken the IP route inside was
    172.16.89.16   255.255.255.240

    I need to check IP route one more time...

    I am giving the config here which I had given in my previous question (well it is not there  now)

    ************************

    Current configuration : 2209 bytes
    !
    version 12.2
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname MYOFFICE
    !
    enable secret 5 $1$B6FN$MwpxvniOfbbzLJi0NR7j9/
    enable password <password removed>
    !
    ip subnet-zero
    !
    !
    !
    !
    controller T1 1/0
     framing esf
     linecode b8zs
     channel-group 0 timeslots 1-24 speed 64
     description D1 T1
    !
    controller T1 1/1
     framing esf
     linecode b8zs
     channel-group 1 timeslots 1-24 speed 64
     description D2 T1
    !
    controller T1 2/0
     framing esf
     linecode b8zs
     channel-group 0 timeslots 1-24 speed 64
     description D3 T1
    !
    controller T1 2/1
     framing esf
     linecode b8zs
     channel-group 1 timeslots 1-24 speed 64
     description D4 T1
    !
    interface Tunnel1
     no ip address
    !
    !
    interface Serial1/0:0
     ip address 172.16.90.10 255.255.255.0
     encapsulation ppp
    !
    interface Serial1/1:1
     ip address 172.16.96.10 255.255.255.0
     encapsulation ppp
    !
    interface Serial2/0:0
     ip address 172.16.98.10 255.255.255.0
     encapsulation ppp
    !
    interface Serial2/1:1
     ip address 172.16.89.1 255.255.255.240
     encapsulation ppp
    !
    interface Serial3/0:0
     no ip address
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 <removed IP address >
    ip route 172.16.89.16  255.255.255.240 172.16.89.14
    ip route 172.16.91.0 255.255.255.0 172.16.90.11
    ip route 172.16.92.0 255.255.255.0 172.16.90.11
    ip route 172.16.93.0 255.255.255.0 172.16.90.11
    ip route 172.16.94.0 255.255.255.0 172.16.90.11
    ip route 172.16.95.0 255.255.255.0 172.16.90.11
    ip route 172.16.97.0 255.255.255.0 172.16.96.11
    ip route 172.16.99.0 255.255.255.0 172.16.98.11
    ip http server
    ip pim bidir-enable
    !
    !
    line con 0
     password <password removed>
     login
    line aux 0
    line vty 0 4
     password <password removed>
     login
    !
    end



    0
     
    LVL 79

    Expert Comment

    by:lrmoore
    These look OK....

    interface Serial2/1:1
     ip address 172.16.89.1 255.255.255.240
     encapsulation ppp
    !
    ip route 172.16.89.16  255.255.255.240 172.16.89.14


    On the Adtran, make sure you have a default:
       ip route 0.0.0.0 0.0.0.0 172.168.89.1

    What's the status now of "show interface serial2/1:1" ?
    Once you set the timing on the controller, you should be good to go....


    0
     
    LVL 49

    Author Comment

    by:sunray_2003
    Oh gosh.. I am at home right now and no access to router.. I am going to think about this all nite.. oh man..

    I guess everything looks good except that I need to check that timing on the controller..
    I also know that ip route  0.0.0.0 0.0.0.0 172.16.89.1 was added in the router...

    Now the only thing is about that "clock rate"..

    From the above comment of mine
    Comment from sunray_2003
    Date: 10/26/2004 04:35PM EDT

    Can I not get the timing of the controller ??

    SR
    0
     
    LVL 79

    Expert Comment

    by:lrmoore
    Whenever you set up back-to-back WAN connections in a lab, you must provide T1 clocking on one end or the other. You can set the clockrate to whatever you want and emulate a lower speed link, but it is best to use something closest to a T1 154000, 153600, or even 2000000
    You are telling the controller what clock rate to use for the "internal" timing.

    0
     
    LVL 49

    Author Comment

    by:sunray_2003
    SO first thing I would do is to check all the above suggestions are fine in both cisco and adtran.

    then will check "show interface of 2/1" and then provide you the result..

    I am confident that should work..  Thanks so much for hanging with me..
    0
     
    LVL 49

    Author Comment

    by:sunray_2003
    One more thing.. Will be online this evening.. If yes, I am going to go to my office and do the setup again and post back..
    I cannot wait to get this resolved (well I am like that).... It should be in my office and can do all the setup in the next 30 mins
    0
     
    LVL 49

    Author Comment

    by:sunray_2003
    will be online = will you be online
    0
     
    LVL 79

    Expert Comment

    by:lrmoore
    Wife is getting annoyed, so I must jump off and spend some time with her and have dinner....

    I'll check back later...

    0
     
    LVL 49

    Author Comment

    by:sunray_2003
    any approximate time you would be back..  I can go to office anytime ..
    0
     
    LVL 79

    Expert Comment

    by:lrmoore
    Most likely around 8 pm Central time...
    0
     
    LVL 49

    Author Comment

    by:sunray_2003
    oops. I was too fast to say I can go to office anytime.. LOL.. 9 EST is kind of late and moreover, that is my dinner time..

    I will do the tests tomm then.. Around 8 am or so I should have the show interface result here.. will post back tommorrow
    0
     
    LVL 5

    Expert Comment

    by:epylko
    You should try the "clock rate" command on the serial interface that gets created by the controller. I've never seen a "clock rate" inside a controller configuration before.

    -Eric
    0
     
    LVL 79

    Expert Comment

    by:lrmoore
    Good catch, Eric. I don't have anything with controller interfaces in my lab, but it certainly does work under the serial interface if using WIC-T1-DSU..
    Also, I noticed that if I set the clockrate to the "default" 2000000, then it does not show up with "show config"
    Perhaps if you simply set the controller to clock source internal, unless you can change it to something else it will use that default clock rate?

    Any luck today?

    0
     
    LVL 49

    Author Comment

    by:sunray_2003
    I forgot yesterday that it was my off-day today. I will be in office tommorrow. Will report asap tomm..

    So you want me to change the clock to internal and then post back with the interface log
    0
     
    LVL 49

    Author Comment

    by:sunray_2003
    Lrmoore,

    This is the show controller t1 info that I got for 2/1:1


    ************
    T1 2/1 is up.
      Applique type is Channelized T1
      Cablelength is long gain36 0db
      Description: D1 T1
      No alarms detected.
      alarm-trigger is not set
      Framing is ESF, Line Code is B8ZS, Clock Source is Internal.
      Data in current interval (506 seconds elapsed):
         0 Line Code Violations, 0 Path Code Violations
         0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
         0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
      Total Data (last 24 hours)
         0 Line Code Violations, 0 Path Code Violations,
         0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins,
         0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

    *************
    I didnot do any changes for the clock rate after tuesday.. I am going to hook the adtran router and see how it all goes.
    Will check inside the adtran router and will add the ip route if it is not there..

    SR
    0
     
    LVL 79

    Expert Comment

    by:lrmoore
    >Cablelength is long gain36 0db
    This might give you problems with a short crossover back-to-back


    0
     
    LVL 49

    Author Comment

    by:sunray_2003
    Yet to do the connections..

    Before that here is my Adtran config..

    Hope everything is fine in here

    *******************************
    Switch#show run              
    Building configuration...                        
    !
    !
    hostname "Switch"                
    enable password password                        
    !
    ip subnet-zero              
    ip classless            
    ip routing          
    !
    event-history on                
    no logging forwarding                    
    no logging email                
    logging email priority-level info                                
    !
    username "admin" password "password"                                    
    !
    banner motd #            
                     ****** Important ******                                        

    Enable and Telnet passwords are configured to "password".                                                        
    Please change them immediately.                              

    The vlan 1 interface is enabled with an address of 10.10.10.1                                                            
    Telnet access is also enabled.                              



    #
    !
    !
    !
    !
    !
    !
    !
    !
    vlan 1      
      name "Default"                
    !
    interface eth 0/1                
      no shutdown            
    !
    interface eth 0/2          
      no shutdown      
         
    <REMOVED OTHER INTERFACE CONFIGURATIONS HERE..didnot want to paste that cos there are 24 interfaces>

    !
    interface vlan 1                
      ip address  172.16.89.17  255.255.255.240                                          
      no shutdown            
    !
    !
    interface t1 1/1                
      clock source internal                      
      tdm-group 1 timeslots 1-24 speed 64                                    
      no shutdown            
    !
    interface ppp 1              
      ip address  172.16.89.14  255.255.255.240                                          
      no shutdown            
    !
    !
    !
    !
    ip route 0.0.0.0 0.0.0.0 172.16.89.1
    !
    no ip n-form agent
    ip http server
    no ip http secure-server
    no ip snmp agent
    no ip ftp agent
    !
    !
    !
    !
    line con 0
      no login
    !
    line telnet 0 4
      login
      password password
    !
    !
    !
    !
    end
    Switch#

    ****************************
    0
     
    LVL 79

    Expert Comment

    by:lrmoore
    Just make sure you plug something into one of the switchports to bring VLAN1 up...
    Do you have to do the cross-connect on this adtran box for the T1 - ppp? I have a Adtran 3200 that requires it..

    0
     
    LVL 49

    Author Comment

    by:sunray_2003
    I connected a patch cable from one of the switches to my laptop and can get into the web management of the router. SO i guess that part is fine..

    Not sure what you mean by cross-connect T1 --ppp.. could you please explain ..
    0
     
    LVL 79

    Expert Comment

    by:lrmoore
    This is my ppp setup on my Adtran NetVanta 3200

    !
    interface t1 1/1
      tdm-group 1 timeslots 1-24 speed 64
      no shutdown
    !
    interface ppp 1
      ip address  192.168.1.1  255.255.255.252
      no shutdown
      cross-connect 1 t1 1/1 1 ppp 1    <<<=== may not need this on your version....??

    0
     
    LVL 49

    Author Comment

    by:sunray_2003
    Oh.. Yeah I see that cross-connect in our 3205 router..

    Not seen in this 1224 router..

    Still no luck.. Tested the T1 crossover with a cable tester and looks fine. So no problem with cable..

    From adtran , I can only the VLAN port , WAN port.  I cannot ping both the IP of the CISCO or
    the IP route 172.16.89.1...

    Only thing that I have not done is to put a clock rate.. Other than that I have done all the suggestions..
    0
     
    LVL 79

    Expert Comment

    by:lrmoore
    On the 3660, try (I'm doing this from memory, so liberal use of "?" please..):
      controller T1 2/1
        cable length short

    Will the 1224 even take that cross-connect command?
    0
     
    LVL 49

    Author Comment

    by:sunray_2003
    No problem , lrmoore.. I can understand how difficult to have all these in memory.

    when i do cable short ?
    it gives this

    router(config-controller)#cable short ?
      133ft  0-133 ft
      266ft  134-266 ft
      399ft  267-399 ft
      533ft  400-533 ft
      655ft  534-655 ft


    Do you want me to put  "cable short 133ft" and see what happens ?

    I have not tried putting cross-connect command in 1224 ?  Remember what command to put ?
    0
     
    LVL 49

    Author Comment

    by:sunray_2003
    Also I found that the Adtran has got a cross-connect command

    so it is showing when i go inside the switch by enabling

    switch(config)# cross-connect ?
    <1-1024>

    0
     
    LVL 79

    Expert Comment

    by:lrmoore
    Yes, use "cable short 133"

    On the 1224, try this..
     switch(config)#cross-connect 1 t1 1/1 1 ppp 1  
    cross-connect rule #1, take T1 1/1 tdm group #1, connect to interface ppp #1
    0
     
    LVL 49

    Author Comment

    by:sunray_2003
    Sorry, Lrmoore.. not worked with this router and hence getting few errors so not sure what would be the next step.

    router(config-controller)#cable short 133
    % Configuration of Short Cable not permitted in CSU mode

    Not sure what needs to be done for the above error ?

    *******
    In Adtran , I had put this
    >> switch(config)#cross-connect 1 t1 1/1 1 ppp 1  

    Did give this statement,
    >> cross-connect rule #1, take T1 1/1 tdm group #1, connect to interface ppp #1
    just to explain that cross-connect statement ?

    SR
    0
     
    LVL 79

    Expert Comment

    by:lrmoore
    >just to explain that cross-connect statement ?
    Yes....

    I don't know what to tell you on the controller config.. that's one thing I don't have access to in  my lab equipment..
    If you can't make them work back-to-back, that still does not rule out that they won't work over the "real" wan link..

    Any progress after adding the cross-connect sommand?
    What is current status of interface ppp1 on the Adtran? "show interface ppp1"

    What is current status of "show interface seraial 2/1:1" on the 3660?
    0
     
    LVL 49

    Author Comment

    by:sunray_2003
    for the command :  show controller t1 2/1

    T1 2/1 is down.
      Applique type is Channelized T1
      Cablelength is long gain36 0db
      Description: D1 T1
      Receiver has remote alarm.
      alarm-trigger is not set
      Framing is ESF, Line Code is B8ZS, Clock Source is Internal.
      Data in current interval (514 seconds elapsed):
         0 Line Code Violations, 0 Path Code Violations
         30 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
         30 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
      Data in Interval 1:
         0 Line Code Violations, 0 Path Code Violations
         51 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
         51 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
      Data in Interval 2:
         0 Line Code Violations, 0 Path Code Violations
         48 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
         48 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
      Data in Interval 3:
         0 Line Code Violations, 0 Path Code Violations
         50 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
         50 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

    **********************
    Switch#show interface ppp 1
    ppp 1 is DOWN
      Link state is STARTING
      Internet address is 172.16.89.14, Mask is 255.255.255.240
      Far end internet address is 0.0.0.0
      MTU is 1500 bytes,   Keepalive set (10 sec)
      Authentication protocol is NONE
      CLOSED: LCP, IPCP, BRIDGE
      BW 0 Kbit
      Queueing method: weighted fair
      HDLC tx ring limit: 2
      Output queue: 0/1/400/64/0 (size/highest/max total/threshold/drops)
        Conversations  0/1/256 (active/max active/max total)
        Available Bandwidth 0 kilobits/sec
        24 packets input, 0 bytes
        Received 0 broadcasts
        24 input errors, 0 discards
        1 packets output, 24 bytes
        0 output errors, 0 discards

    ****************************
    0
     
    LVL 79

    Expert Comment

    by:lrmoore
    We definately have some issues with the slip sec errors on the controller....
    How about result of router(config)#controller T1 2/1
                                 router(config-controller)#cable ?    Length? perhaps "cable length <short>"???

    I think I'm hitting the wall of how much I can help at this point with your back-back setup since I don't have anything of either product at hand to test with.. ( I should have an Adtran 1224 by Nov 8th)...

    I set up a back-back Cisco 3640 with WIC-1DSU-T1 crossover cable to Adtran netvanta 3200. Piece of cake, took 5 minutes with no problems, but there must be subtle differences between the module that you have and the 1224..
    0
     
    LVL 49

    Author Comment

    by:sunray_2003
    router(config)#controller T1 2/1
    router(config-controller)#cable ?
      long   long cable
      short  short cable

    and if i get this

    router (config-controller)#cable long ?
      gain26  26db Gain
      gain36  36db Gain

    Can the above help here ?
    0
     
    LVL 79

    Expert Comment

    by:lrmoore
    Makes you want to go hmmmmmmm.....

    What is current status of "show interface serial 2/1:1" not controller 2/1
    0
     
    LVL 49

    Author Comment

    by:sunray_2003
    Oops .. Sorry

    **************
    Serial2/1:1 is reset, line protocol is down
      Hardware is DSX1
      Internet address is 172.16.89.1/28
      MTU 1500 bytes, BW 1536 Kbit, DLY 20000 usec,
         reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation PPP, loopback not set
      Keepalive set (10 sec)
      LCP Closed
      Closed: IPCP, CDPCP
      Last input 01:35:45, output 01:42:24, output hang never
      Last clearing of "show interface" counters 8w2d
      Input queue: 0/75/75785758/0 (size/max/drops/flushes); Total output drops:
    96
    156
      Queueing strategy: weighted fair
      Output queue: 0/1000/64/0 (size/max total/threshold/drops)
         Conversations  0/1/256 (active/max active/max total)
         Reserved Conversations 0/0 (allocated/max allocated)
         Available Bandwidth 1152 kilobits/sec
      5 minute input rate 0 bits/sec, 0 packets/sec
      5 minute output rate 0 bits/sec, 0 packets/sec
         940321 packets input, 33843135 bytes, 0 no buffer
         Received 0 broadcasts, 12431547 runts, 0 giants, 0 throttles
         75786256 input errors, 5593123 CRC, 70195460 frame, 0 overrun, 0 ignored,
    3009808 abort
         1446820 packets output, 55173402 bytes, 0 underruns
         0 output errors, 0 collisions, 240826 interface resets
         0 output buffer failures, 0 output buffers swapped out
         213 carrier transitions
      Timeslot(s) Used:1-24, Transmitter delay is 0 flags

    *************************
    0
     
    LVL 79

    Expert Comment

    by:lrmoore
    Odd...
       >Serial2/1:1 is reset, line protocol is down
                               ^^
    Huge problem here. May be result of all the slip sec errors on the controller...
    >   75786256 input errors, 5593123 CRC, 70195460 frame, 0 overrun, 0 ignored,
    3009808 abort

    >Last clearing of "show interface" counters 8w2d
    Need to clear these stats:
       router#clear count interface serial 2/1:1

    Then try "bouncing" the T1 line...

       controller T1 2/1
         shut
          <wait 15 seconds>
          no shut


    0
     
    LVL 49

    Author Comment

    by:sunray_2003
    from
    router# clear count interface serial 2/1:1

    gives "unrecognised command"

    so i did this

    ******
    router#clear count ?
      Async              Async interface
      BVI                Bridge-Group Virtual Interface
      CTunnel            CTunnel interface
      Dialer             Dialer interface
      FastEthernet       FastEthernet IEEE 802.3
      Group-Async        Async Group interface
      Line               Terminal line
      Loopback           Loopback interface
      Multilink          Multilink-group interface
      Null               Null interface
      Serial             Serial
      Tunnel             Tunnel interface
      Vif                PGM Multicast Host interface
      Virtual-Template   Virtual Template interface
      Virtual-TokenRing  Virtual TokenRing
      <cr>
      Lex                Lex interface

    router#clear count serial ?
      <0-6>  Serial interface number

    ***********

    So shall I give

    router#clear count serial 2/1:1

    0
     
    LVL 79

    Expert Comment

    by:lrmoore
    yep
    0
     
    LVL 49

    Author Comment

    by:sunray_2003
    when i put "clear count serial 2/1:1", it asked to confirm and I gave C and it back to prompt , router#

    Now I did this to do the bouncing

    router#config t
    Enter configuration commands, one per line.  End with CNTL/Z.
    router(config)#controller T1 2/1
    router(config-controller)#shut
    router(config-controller)#no shut  <--------------waited for 20 secs  before I gave this
    router(config-controller)#exit
    router(config)#exit
    router#

    Now my "show interface serial 2/1:"

    **********
    Serial2/1:1 is reset, line protocol is down
      Hardware is DSX1
      Internet address is 172.16.89.1/28
      MTU 1500 bytes, BW 1536 Kbit, DLY 20000 usec,
         reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation PPP, loopback not set
      Keepalive set (10 sec)
      LCP Closed
      Closed: IPCP, CDPCP
      Last input 02:07:13, output 02:13:51, output hang never
      Last clearing of "show interface" counters 8w2d
      Input queue: 0/75/75785758/0 (size/max/drops/flushes); Total output drops: 964
    412
      Queueing strategy: weighted fair
      Output queue: 0/1000/64/0 (size/max total/threshold/drops)
         Conversations  0/1/256 (active/max active/max total)
         Reserved Conversations 0/0 (allocated/max allocated)
         Available Bandwidth 1152 kilobits/sec
      5 minute input rate 0 bits/sec, 0 packets/sec
      5 minute output rate 0 bits/sec, 0 packets/sec
         940321 packets input, 33843135 bytes, 0 no buffer
         Received 0 broadcasts, 12431547 runts, 0 giants, 0 throttles
         75786256 input errors, 5593123 CRC, 70195460 frame, 0 overrun, 0 ignored, 2
    3009808 abort
         1446820 packets output, 55173402 bytes, 0 underruns
         0 output errors, 0 collisions, 240889 interface resets
         0 output buffer failures, 0 output buffers swapped out
         214 carrier transitions
      Timeslot(s) Used:1-24, Transmitter delay is 0 flags
    0
     
    LVL 79

    Accepted Solution

    by:
    Router#clear count serial 0/0
    Clear "show interface" counters on this interface [confirm]  <ENTER> do not use "C"

    With the interface still reporting as 'reset', I'm out of ideas for now, but I'll see what I can find...

    Slip Secs Counter Increasing
    If slips are present on the T1 line, there is a clocking problem. The Customer Premises Equipment (CPE) will need to synchronize to the clocking from the T1 provider (telco). Complete the following steps to correct this problem:

    Change the clock source back to line on the 3660...

    Set the Adtran to provide the clocking:

      interface t1 1/1
         clock source internal

    0
     
    LVL 49

    Author Comment

    by:sunray_2003
    pressed "enter" instead of "C" and now this is the info

    Serial2/1:1 is reset, line protocol is down
      Hardware is DSX1
      Internet address is 172.16.89.1/28
      MTU 1500 bytes, BW 1536 Kbit, DLY 20000 usec,
         reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation PPP, loopback not set
      Keepalive set (10 sec)
      LCP Closed
      Closed: IPCP, CDPCP
      Last input 02:31:36, output 02:38:15, output hang never
      Last clearing of "show interface" counters 00:01:32
      Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 12
      Queueing strategy: weighted fair
      Output queue: 0/1000/64/0 (size/max total/threshold/drops)
         Conversations  0/1/256 (active/max active/max total)
         Reserved Conversations 0/0 (allocated/max allocated)
         Available Bandwidth 1152 kilobits/sec
      5 minute input rate 0 bits/sec, 0 packets/sec
      5 minute output rate 0 bits/sec, 0 packets/sec
         0 packets input, 0 bytes, 0 no buffer
         Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
         0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
         0 packets output, 0 bytes, 0 underruns

    Does it look good.. Looks like the counter has changed.. I mean
    >> Last clearing of "show interface" counters 00:01:32


    Will change the clock source and be back
    0
     
    LVL 49

    Author Comment

    by:sunray_2003
    Now I changed the clock source to line on CISCO's 2/1 and when I put "show controller T1", I get this for 2/1

    *********
    T1 2/1 is down.
      Applique type is Channelized T1
      Cablelength is long gain36 0db
      Description: D1  T1
      Receiver has remote alarm.
      alarm-trigger is not set
      Framing is ESF, Line Code is B8ZS, Clock Source is Line.   <----------changed, I guess.
      Data in current interval (832 seconds elapsed):
         0 Line Code Violations, 0 Path Code Violations
         46 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
         46 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
      Total Data (last 24 hours)
         2073557 Line Code Violations, 0 Path Code Violations,
         663 Slip Secs, 96 Fr Loss Secs, 39 Line Err Secs, 0 Degraded Mins,
         661 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 122 Unavail S

    ***********************

    In the Adtran , changed the clock source from line to internal.
    Did a cool restart and still no go..

    I will wait.. no problem ..
    0
     
    LVL 5

    Expert Comment

    by:AutoSponge
    The adtran as well as the router have poor stratum 2 clocks.  On a point-to-point T1, you're better off going with something like a larscom that provides a stratum 3, an external clock (litterally a device that plugs into the CSU), or engineer the ckt so telco can provide the clock (stratum 4).  Those slip seconds are (obviously) timing slips and there isn't a strong enough clock source for the T1 to time off of.  Make sure that only one of the CSU's is providing clocking and make sure that telco isn't providing it somehow (if they are and you're adding a clock, you're going to get errors).
    0
     
    LVL 49

    Author Comment

    by:sunray_2003
    AutoSponge,

    Thanks for your comments.. Eventhough , I donot completely  interpret what you say , I am sure you know the stuff you are good at.. I am just beginning to set foot on these high-end routers so I have to do the basic homework of knowing about CISCO routers. I have 3 or 4 books here and I am going to spend sometime this weekend on going through this.

    Thanks for hanging with me here.. This issue is not very high priority right now but we want to do this setup so that if we get new adtran routers next month , we would configure it here and donot want to go to a remote site to do the actual real time testing.. Not only does it saves lot of time but also I can get good knowledge ..

    Sure you all can expect more questions in routers TA from me..

    I am researching more on this issue aswell..  

    Thanks all once again

    SR
    0
     
    LVL 79

    Expert Comment

    by:lrmoore
    Any change to the status after setting the clocking to the Adtran side?
    What does "show int serial 2/1:1" sho now? Does it still say "reset"?
    Have the slip sec errors stopped on the controller?
    0
     
    LVL 49

    Author Comment

    by:sunray_2003
    Sorry , Lrmoore.. No change ..

    I have changed the clock in Adtran and still cannot ping the 172.16.89.1  . From the laptop connected to the Adtran , I can go only as far as the WAN port of the Adtran..
    From CISCO , I cannot go to 172.16.89.1 ..

    Yes it still says reset for showing interface serial 2/1:1

    ***************
    Serial2/1:1 is reset, line protocol is down
      Hardware is DSX1
      Internet address is 172.16.89.1/28
      MTU 1500 bytes, BW 1536 Kbit, DLY 20000 usec,
         reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation PPP, loopback not set
      Keepalive set (10 sec)
      LCP Closed
      Closed: IPCP, CDPCP
      Last input 01:15:47, output 04:00:13, output hang never
      Last clearing of "show interface" counters 01:23:31
      Input queue: 0/75/1931/0 (size/max/drops/flushes); Total output drops: 676
      Queueing strategy: weighted fair
      Output queue: 0/1000/64/0 (size/max total/threshold/drops)
         Conversations  0/1/256 (active/max active/max total)
         Reserved Conversations 0/0 (allocated/max allocated)
         Available Bandwidth 1152 kilobits/sec
      5 minute input rate 0 bits/sec, 0 packets/sec
      5 minute output rate 0 bits/sec, 0 packets/sec
         1 packets input, 24 bytes, 0 no buffer
         Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
         1932 input errors, 156 CRC, 911 frame, 0 overrun, 0 ignored, 0 abort
         0 packets output, 0 bytes, 0 underruns
    0 output errors, 0 collisions, 171 interface resets
         0 output buffer failures, 0 output buffers swapped out
         2 carrier transitions
      Timeslot(s) Used:1-24, Transmitter delay is 0 flags
    *****************
    0
     
    LVL 49

    Author Comment

    by:sunray_2003
    Once again Lrmoore has proved is the best of the best..

    Oh my goodness.  What a silly mistake ... I didnot plug the WAN cable properly at the back of the adtran. Everything was plugged in correctly but when I used  a cable tester to test the T1 cross-over, I guess I messed it up..

    Also I think the main trick here was to change the clock inside the Adtran to source...

    0
     
    LVL 79

    Expert Comment

    by:lrmoore
    All righty, then...
    Give yourself 3 whacks with a wet noodle for that one!

    Glad you're up and running!

    - 3 Cheers!

    0
     
    LVL 49

    Author Comment

    by:sunray_2003
    Now again one more question..  

    Should I be changing the clock in the adtran to LINE if I take it to a remote site and plug a polycom unit to it or just keep it as source ..
    0
     
    LVL 79

    Expert Comment

    by:lrmoore
    Keep it just as is, assuming that it will be a leased line and the telco does not provide the clocking. That is a question that you must ask the telco when they establish the leased line for you..
    0
     
    LVL 49

    Author Comment

    by:sunray_2003
    Super.. I can now connect to all the sites (polycom) and remote desktop to all computersin all our counties..

    Hopefully , tommorrow I will be going to the remote site and put this router there.. If I have any issues, I should hopefully tackle but will post another question (i guess I donot have to ...LOL)

    Thanks for all your help , Lrmoore.. I guess you did hit the wall here but you should be confident that if you can do the same setup in 5 mins in ur lab , how come this one will not..

    You are the Network King.

    SR
    0
     
    LVL 79

    Expert Comment

    by:lrmoore
    >if you can do the same setup in 5 mins in ur lab , how come this one will not..
    'cause I plugged the cables into the right holes?
    I can only "see" so much in this type textual forum you know...

    0
     
    LVL 49

    Author Comment

    by:sunray_2003
    lrmoore,

    Sorry if my silly mistake would have frustated you.

    It should have been obvious for me to check on those cables but it never gave that clicking sound when I plugged into the WAN port. I guess i should tweak the cable little bit so that it gets fixed properly..
    Nice lesson learnt..

    0
     
    LVL 79

    Expert Comment

    by:lrmoore
    Just glad you're working now!

    Good lesson for both of us. I've got to remember to suggest checking, double-checking all the layer 1 connections before changing any configuration..
    0
     
    LVL 49

    Author Comment

    by:sunray_2003
    0

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    How your wiki can always stay up-to-date

    Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
    - Increase transparency
    - Onboard new hires faster
    - Access from mobile/offline

    It happens many times that access list (ACL) have to be applied to outgoing router interface in order to limit some traffic.This article is about how to test ACL from the router which is not very intuitive for everyone. Below scenario shows simple s…
    The Cisco RV042 router is a popular small network interfacing device that is often used as an internet gateway. Network administrators need to get at the management interface to make settings, change passwords, etc. This access is generally done usi…
    After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
    After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

    934 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    12 Experts available now in Live!

    Get 1:1 Help Now