Solved

Configure RD access from outside

Posted on 2004-10-26
236 Views
Last Modified: 2010-04-19
Hi,

I have RD access to the 2003 server from within the network, but not from outside. I need a little more detailed instructions. I have tried to ajust NAT and basic firewall, but no luck yet. I would appreciate even a reference for (inexpensive) help.
0
Question by:kerzner
    12 Comments
     
    LVL 3

    Accepted Solution

    by:
    no help needed...

    what is the firewall you are using?

    you need to set a static route from the internet to the ip address of the serveron port 3389 and 3390.

    that should do it.  if you need more help tell me what NAT / firewall device you have and I will send you the direction from the vendor web site.  They should also be in the book.

    Hope this helps.

    kelo

    0
     
    LVL 1

    Author Comment

    by:kerzner
    I did this, and it worked. Still, now it does not authenticate. Same username and password work from inside the network. What should i look at? And then, it stopped connecting, I must have ruined some other settings. I know i am vague, but which settings should I check?
    0
     
    LVL 3

    Expert Comment

    by:kelo501
    Make sure the user is a member of the remote users group.

    Try the administrator account as a test it is in the correct account by defult.

    2nd make sure your account is not locked.


    This is rather straight forward.  You should not be changing to many settings.

    Check that and see if it works if not let me know.

    But I will need better info on the issue to help more.

    kelo501




    0
     
    LVL 3

    Expert Comment

    by:kelo501
    ok I read that again sorry if the user works inside but not outside it is not the user.  so dont worry about mebership but make sure you are not locked out.

    email me your IP address at klong@integra1.net

    DO NOT SEND USER NAME OR PASSWORDS I JUST WANT TO SEE IF I CAN HIT THE SERVER.

    AGAIN NO USER NAME OR PASSWORD!!!!!!

    kelo
    0
     
    LVL 1

    Author Comment

    by:kerzner
    shmsoft.tzo.com goes there
    0
     
    LVL 3

    Expert Comment

    by:kelo501
    OK i get there but no answer from the server.

    1. make sure you opened tcp and udp port 3389.

    2. click START>CONTROL PANEL>ADD REMOVE PROGRAMS> WINDOWS COMPONENTS  make sure terminal server is not installed nor is terminal server licensing

    3 right clik MY COMPUTER> PROPERTIES> REMOTE  make sure the check box for remote conections is cleared

    4. reboot the server

    5. right clik MY COMPUTER> PROPERTIES> REMOTE  and check the remote conections box.

    6. test remote connection again.

    Notes:  If you are not getting to the logon screen then we are not connecting to the server.  This is before we would even start to troubleshoot user accounts or policys.

    the parts in play are the one above and the firewall/NAT plus maybe your TCP/IP settings on the server.
    kelo
    0
     
    LVL 1

    Author Comment

    by:kerzner
    You say "terminal server is not installed nor is terminal server licensing". I know that I have these, because I thought they are needed. I will uninstall them. What are they for then?

    The server was rebooted just now.
    0
     
    LVL 3

    Expert Comment

    by:kelo501
    they are used if the server is to be used as a true terminal server.  This would mean have users loggin  from thin clients, legacy clients or remote clients.  The server would then run all there applications that were published.  In 2000 there were two options application mode or remote administration mode.  In 2003 it is application mode only.  Remote administration mode is configured with the check box on the remote tab.

    kelo
    0
     
    LVL 3

    Expert Comment

    by:kelo501
    Make sure your IP address 24.174.73.138
    kelo
    0
     
    LVL 1

    Author Comment

    by:kerzner
    i removed terminal server role, and got no connnection at all
    0
     
    LVL 3

    Expert Comment

    by:kelo501
    OK thats good.
    Now go to
    MY COMPUTER > PROPERTIES> REMOTE TAB

    and enable it from there.

    kelo
    0
     
    LVL 1

    Author Comment

    by:kerzner
    There was a bug in Linksys router, where it would force-redirect, ignoring my instructions. But thank you for the effort to help. I saw that I was on the right way. NIXsolutions.com company helped me fix it.
    0

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    Why You Should Analyze Threat Actor TTPs

    After years of analyzing threat actor behavior, it’s become clear that at any given time there are specific tactics, techniques, and procedures (TTPs) that are particularly prevalent. By analyzing and understanding these TTPs, you can dramatically enhance your security program.

    I guess it is not common knowledge to most Wintel engineers/administrators: If you have an SNMP-based monitoring system in your environment (and it's common to have SNMP or Syslog) it's reasonably easy to enable monitoring of the Windows Event logs,…
    Numerous times I have been asked this questions that what is it that makes my machine log on so slow, there have been cases where computers took 23 minute exactly after taking password and getting to the desktop. Interesting thing was the fact th…
    This video Micro Tutorial is the second in a two-part series that shows how to create and use custom scanning profiles in Nuance's PaperPort 14.5 (http://www.experts-exchange.com/articles/17490/). But the ability to create custom scanning profiles a…
    This video discusses moving either the default database or any database to a new volume.

    856 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    18 Experts available now in Live!

    Get 1:1 Help Now