slow network copy between Win2000 pro and Win2003 std server

Hi

We have an interesting issue. Basically we have a new windows 2003 std server sat on a 1GB switch and 2 pc's hanging off. One pc runs win200 pro sp4 and a Dlink DGE550T (gigabit) network card, the other is XP sp1 and again has a gigabit network card.

when copying down the XP pc copies down say 10GB in about 10 mins but the windows 2000 pro pc takes anything up to 40 minutes. The issue however is the win2000 pc was fine until the server was replaced with the win2003 server.

I have checked the drivers and everything is up to date Dlink drivers seems unchanged since release.

any pointers appreciated as I assume this is either a server issue or win2k issue but everthing worked out fine until the server platform chaged.

thanks in advance

H
exchangedude2004Asked:
Who is Participating?
 
harleyjdCommented:
In Default Domain Controller Policy

CompCon
+Windows Settings
 +Security Settings
  +Security options

set to disabled:
Domain Member: Digitally Encrypt or sign secure channel data (Always)
Microsoft Network Server: Digitally Sign Comminications (Always)
Microsoft Network Server: Digitally Sign Comminications (if client agrees)

You can also set the "client" options as well, but usually these do the trick, as the server refuses to sign. If the server is a member server, not a domain cotroller then do those steps, but in Default Domain Policy...
0
 
exchangedude2004Author Commented:
thanks for the tips but I was lead to believe this was to do more with copying files up to the server, I am copying down and getting the issue I described and no changes have been made to the xp machines which does not have a problem.
0
 
harleyjdCommented:
It doesn't matter which way you're copying, signing will affect everything.

0
Cloud Class® Course: Amazon Web Services - Basic

Are you thinking about creating an Amazon Web Services account for your business? Not sure where to start? In this course you’ll get an overview of the history of AWS and take a tour of their user interface.

 
exchangedude2004Author Commented:
ok final question :), the server is not a domain controller and is not a member server - we actually use it as a glorified workstation for processing so its just added to the domain like normal pc, no dc promo been done etc so do this still apply.

cheers

H
0
 
harleyjdCommented:
In that case, it's done on the server, under Group Policy for the local machine.

0
 
exchangedude2004Author Commented:
thanks for your help - I checked the policy for the local machine and the only option that was enabled by default was

Domain Member: Digitally Encrypt or sign secure channel data (Always) - so I disabled that one. the other 2 were already disabled by default.

Do you think this is enough to cure it and do I need to reboot or does the change take affect without a reboot

thanks again
0
 
harleyjdCommented:
By now it will have well and truly taken effect.

The other thing you can do, to be sure it's active is use the Resultant Set of Policy. This will tell you for sure whether signing is on or off.
0
 
harleyjdCommented:
I meant "be sure the local policy is active" not "be sure signing is active" :)

0
 
kelo501Commented:
I would have went with harley on this one but if you have checked those setting and they are as he sugested...

Try the ez stuff.  Reinstall or update your NIC driver.  You may also want to set it to 1000 full in place of auto.

Just a idea

kelo
0
 
exchangedude2004Author Commented:
well onward and upward turned out the smb changes made no difference.

traced it down to
New registry entry for controlling the TCP Acknowledgment (ACK) behavior in Windows XP and in Windows Server 2003 (328890)

got the hot fix first as mentioned in another article, applied and then changed the registry. so far so good

thanks though for helping harley as I had to start somewhere..

H
0
 
harleyjdCommented:
Aye. I got that hotfix for another client, but haven't gotten around to installing it yet, so I don't know what it achieves
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.